5 Replies Latest reply on Sep 18, 2008 3:02 PM by TonyRaines

    How to Trace Publishing errors in CS3

    TonyRaines
      Using Flash CS3 (updated 9.0.3, AIR 1.1) on a Mac (10.5.5) and my AIR files that were publishing fine a month ago are now not publishing at all (even though it's telling me the AIR file has been created).

      Found this on adobe.com:
      quote:

      * There’s no error checking. When packaging fails, there’s no error dialog so it might appear as if the task succeeded.

      And also this:
      quote:

      Things to watch out for that might cause packaging to fail: * Invalid characters in ID, file type name, file type extension fields. * Space, double byte characters or high ASCII characters in path or file name * Password does not match the selected digital certificate. * Icon size does not match the specified size.

      I've checked out these things, point by point, to no avail. Anyone else encountering this issue?

      Is there any way for me to find out where the problem is and at what point packaging fails?

      Thanks for reading this.
        • 1. Re: How to Trace Publishing errors in CS3
          Oliver Goldman Adobe Employee
          You might try packaging at the command line using the "adt" command in the SDK. It will report any errors that occur.

          • 2. Re: How to Trace Publishing errors in CS3
            TonyRaines Level 1
            Oliver, thanks for your response. I was able to get the "adt" command line tool up and running and passed in the necessary arguments to try and compile that way. I'm getting 302 and 303 errors for the swf and icon files. Within the descriptor xml file all of the file paths are relative to the xml. I've tried absolute paths as well to no avail. I've also tried relative and absolute paths for the .air file argument being passed in to the adt. Not sure where I'm messing up...

            Thanks again for your help.
            • 3. Re: How to Trace Publishing errors in CS3
              TonyRaines Level 1
              Here's the error messages I received (with actual folder/file names changed to protect the guilty):

              filepath/filepath/myDescFile-app.xml(10): error 302: Root content mySWF.swf is missing from package

              filepath/filepath/myDescFile-app.xml(18): error 303: Icon widget_icons/icon_16.png is missing from package

              filepath/filepath/myDescFile-app.xml(19): error 303: Icon widget_icons/icon_32.png is missing from package

              filepath/filepath/myDescFile-app.xml(20): error 303: Icon widget_icons/icon_48.png is missing from package

              filepath/filepath/myDescFile-app.xml(21): error 303: Icon widget_icons/icon_128.png is missing from package
              • 4. Re: How to Trace Publishing errors in CS3
                Oliver Goldman Adobe Employee
                The paths in the descriptor are relative to the root of the package, not the descriptor file. (The location of the decriptor file is basically irrelevant.) So, given the paths in the error message above, your application must have this layout:

                mySWF.swf
                widget_icons/icon_16.png
                widget_icons/icon_32.png
                widget_icons/icon_48.png
                widget_icons/icon_128.png

                If adt was run in the same directory as the mySWF.swf file, then you could package things up like so:

                adt [other args] mySWF.swf widget_icons/*


                • 5. Re: How to Trace Publishing errors in CS3
                  TonyRaines Level 1
                  Thanks for your continued help. Once I gave the .air file argument the full path then all of the other relative assets loaded fine and compiled successfully. I can now package AIR files using the "adt"!

                  I still can't publish the AIR files using Flash CS3, however. It allows me to publish an unsigned certificate but when I try to use the same certificate that I used successfully with the "adt" it leaves me with a nonexistent .air file. I'm assuming it has to do with the certificate, but this was all working fine a few weeks ago so I'm at a loss.

                  I guess I'll have to wait for some sort of update with error tracing within the Flash CS3 environment. In the meantime I can use the "adt" command line method which seems to work fine, thanks to all of your help.

                  Much appreciated.