8 Replies Latest reply on Oct 15, 2009 4:05 PM by tunghoy

    Problem importing Illustrator CS3 paths into AE CS3

    fr3u2 Level 1

      I'm used to use my illustrator paths in After Effects and have the proper settings in Illustrator (AICB checked). The weird thing is that it no longer works whereas it used to work just fine with the exact same illustrator file a month ago.

       

      I changed nothing in terms of software settings, so what can be wrong?

       

      Thanks for helping m out on tha one if you can, because it really breaks my workflow!

       

      François

        • 1. Re: Problem importing Illustrator CS3 paths into AE CS3
          TimeRemapper Level 4

          Are you trying to paste a spline into a property of a layer in the timeline (i.e. Position)?

           

          If so, make sure you are selecting the name of that property in the timeline prior to pasting.

          Also, make sure that the "Preserve Paths" radial button in your Illustrator preferences is enabled.

          • 2. Re: Problem importing Illustrator CS3 paths into AE CS3
            fr3u2 Level 1

            Hello and thanks for the prompt answer.

             

            First, the "preserve paths" is checked in the Preferences so that's not an issue.

             

            What I want to do is select a "path" in Illustrator (and I think I select it properly by using the white arrow and wether clicking on it in the layer window OR selecting it directly on the canvas)

             

            Then I copy it (Control + V OR edit /copy) and want to paste it on a solid layer in AE. SO I select the layer in AE and I cannot copy the path (ine the Edit menu, Paste is not active). I've been doing it on a regumar basis until I noticed a couple of weeks ago that it did not work anymore. The AE project is different but I use the same Illustrator file that used to work just fine!

             

            Is there anything I might have checked/unchecked inadvertantly in AE that causes the problem? I have no clue on that one.

            • 3. Re: Problem importing Illustrator CS3 paths into AE CS3
              TimeRemapper Level 4

              Hey there. It would appear that you want to create a mask on a layer in AE usiing a path you created in Illustrator.

               

              So, try these steps:

              • Draw your path in illustrator
              • Select it with the black arrow (you'll see the transform box appear)
              • Copy it via the Edit menu, or "Control C" (PC) or "Command C" (Mac)
              • Select the layer in the timeline on which you'd like to create the mask shape
              • Paste via the Edit menu, or "Control V" (PC) or "Command V" (Mac)
              • 4. Re: Problem importing Illustrator CS3 paths into AE CS3
                fr3u2 Level 1

                OK - I did not put it as clearly, but that is exactly what I want to do.

                 

                And the steps you describe are the one I follow (black or white arrow is not the issue here I guess)

                 

                It does not work - still.

                 

                I tried to copy paste the path in Photoshop in order to see if it was a problem with WINDOWS or else. And it works  from Illustrator to Photoshop, so it might be a problem with After Effects.

                 

                While we're at it, I had the same kind of copy/paste problem with text from a rtf file recently... I was copying text into After Effect from a .rtf text document and it was working fine until it stopped working suddenly. At last, I eventually quit AE and started it again, and the copy/paste started working again.

                 

                SO I did it again on that one. I quite AE and started it again. And YES, my copy/paste from Illustrator worked. The question is:

                 

                What causes that? because I cannot see that as the answer to my problem. I am not going to quit AE every 10 minutes!.. And prior to quitting it, I purged the memory and all, so it has nothing to do with that. Any clue?..

                • 5. Re: Problem importing Illustrator CS3 paths into AE CS3
                  TimeRemapper Level 4

                  I remember seeing that in the past.

                  It has to do with how the clipboard is handled with the Windows version of AE.

                  As far as I remember, the only solution was to restart AE. Sorry.

                  1 person found this helpful
                  • 6. Re: Problem importing Illustrator CS3 paths into AE CS3
                    Mylenium Most Valuable Participant

                    Another tool is polluting your clipboard, there's no way around that. A known issue is specific versions of Windows Media Player breaking the internal Windows messaging system for the clipboard. See here: http://support.microsoft.com/kb/941282. The same happens, when you use Office and have multiple sets of clipboard data. Eventualyl at some point the sets will loose their "uniqueness" and the whole thing falls apart. More a problem with MS, not so much Ae. Unfortunately, however, you're stuck with the quit & re-launch procedure. There is no otehr way to straighten out these things. Specific to your illustrator issue you may wish to check the artboard size and DPI in AI. Sometimes odd settings will cause the position values of the path vertices to be too smal lor too large and AE can't make sense of them...

                     

                    Mylenium

                    1 person found this helpful
                    • 7. Re: Problem importing Illustrator CS3 paths into AE CS3
                      fr3u2 Level 1

                      thank you both for your time. Mylenium, I think you nailed it. At the very same time the computer maintenance guy at my company sent me the exact same hotfix link.

                       

                      So I installed it. We'll see if it solves my problem - even though I am never using Window Media Player (I use VLC and 321 media classic). Maybe it impacts AE through the .wmv thingies. If it doesn't (I am not sure since you seem to say it doesn't) I'll keep quitting+re-launching.

                       

                      Anyway, thank you

                       

                      François

                       

                      PS: I'll keep you posted in the next days in order to help other people who might have the problem.

                      • 8. You're right -- restarting worked
                        tunghoy Level 1

                        Six months after this thread began.......

                         

                        I had the same problem today and it was driving me bananas. Exiting and restarting AE did the trick and I can now copy and paste paths from Photoshop into AE. Thanks.