2 Replies Latest reply on May 6, 2009 8:07 AM by pete_5419

    Director 11 Mac projector problem

    PhilGibson

      Hello everyone.

       

      We've been running Director MX 2004 forever and picked up a copy of Director 11 a little while ago. Due to several large projects in house, we were unable to actually dig into using it. I now have the opportunity to try to upgrade our future projects to use Director 11. My tests have been less than positive so far and the boss doesn't want to put money into buying new versions of extras or Director 11.5 unless we know it works.

       

      So here's the setup: I'm building a cross-platform projector from Director 11 under Windows XP. The project is going to end up as ROM Content on a Video DVD, so the disc is UDF format. I can test the projector under Mac OS 10.4.11 before burning the disc as well as on the disc and it works fine. On the disc under 10.5.6, I get an Application Error "This application requires Shockwave Player 11, which can not be found. Click OK to download it." This is NOT a shockwave player, but a stand alone Projector. Clicking OK also does nothing.

       

      I've tried copying the .app file to an NTFS USB drive and that simply results in a projector that will not run at all (This application could not run. Try restarting your computer).

       

      I've worked with Director and Macs for years. Things worked very well under MX2004 as any mac projectors would be created in a compressed archive file to make sure that no mac specific stuff would break when moved around on a windows machine. Since the .app file is really only a package folder, I'm assuming that there is something within it that is Mac specific, has no file extension, and is losing it's Mac attributes when it is being moved around on a Windows system/being read from a UDF formatted disc under 10.5.

       

      Does anyone have any idea how to resolve this?

       

      One of the big reasons we bought Director 11 was to help improve compatability with the newer OSs and it seems to simply not work under 10.5 at all due to this problem.

       

      Thank you for any information you may have.

        • 1. Re: Director 11 Mac projector problem
          hhmartin

          I am just beginning my Director 11 experience. I am having some problems creating a Mac projector even though I'm running OS X.

           

          On the problem of creating a Mac projector from Windows, I looked at most of the files in the .app folder and have so far not found any with resource forks. The only potential problem I see is in the .framework folders. The top level of each folder has two links to lower level items, e.g. DPLib and Resources for the DPLib.framework. If these links are broken buy the copy process, the projector will require shockwave to be installed.

           

          Even working on a Mac, I have to build my projectors in a disk image using the same volume name as the final CD.

           

          To see if this is where the problem lies, access your working volume from a mac, right click on the app to see package contents and look in the Frameworks folder. Open any of the .framework folders, click once on the Resources folder link, the select get info from the File menu. Does the path to the orignal match the name of the mounted volume and the exact path all the way down to ....Versions/A/Resources. If not, fix this link and all the others ON A VOLUME WITH THE SAME NAME AS YOUR FINAL DISTRIBUTION VOLUME and then burn from that volume.

          • 2. Re: Director 11 Mac projector problem
            pete_5419

            Phil, I had posted a question about this issue a while back. I bumped that post to make resurface. Take a look at some of the discussion there. The post is titled 'Director 11 - Publishing Mac Projector from Windows'. I have not come up with the solution for this yet. In my case, the Mac projector needs to be auto generated so 'fixing' the problem manually with each projector will not work.