14 Replies Latest reply on Jul 10, 2010 10:19 PM by robbiemud

    Instances on Flash CS4 stage, but aren't visable?

    ewenx012

      Last night I was working on my flash file and I must have changed some setting that has caused all of my buttons, movie clips and graphics to disappear from my Flash CS4 stage. Instead, it shows each instance's actionscript registration on the screen with a small circle. The instances are still there and show up when exported, but I can't see them while I'm editing the file. The static text and basic grapics are fine. Does anyone have an idea what setting might be causing this? I've tried multiple .fla files and had the same problem with all of them.

       

      Thanks, I really appreciate any help!

       

      - McKenna

        • 1. Re: Instances on Flash CS4 stage, but aren't visable?
          kglad Adobe Community Professional & MVP

          just above all timelines is an eye (and lock and square).  toggle (click) the eye to see if your hiding your objects.

          1 person found this helpful
          • 2. Re: Instances on Flash CS4 stage, but aren't visable?
            ewenx012 Level 1

            I have all of my layers selected to show up. I have one layer with both static text and buttons, but it's only the buttons that won't show up.

            • 3. Re: Instances on Flash CS4 stage, but aren't visable?
              kglad Adobe Community Professional & MVP

              post a link to your fla and specify the problem's location.

              • 4. Re: Instances on Flash CS4 stage, but aren't visable?
                tomhorn3r

                Hi,

                 

                Has anyone found a solution to this as I am suffering from the same problem?

                 

                It only seems to be with movie clips on the stage. If I convert a bitmap or graphic on the stage to a movie clip it instantly disappears, with only the bounding box and registration point visible.

                 

                Any help greatly appreciated.

                 

                Thanks,

                Tom

                • 5. Re: Instances on Flash CS4 stage, but aren't visable?
                  mrmarcusmook

                  Hello McKenna,

                   

                  Did you find a resolution to this?

                   

                  I have been experiencing this too. If I open the same file at work, its fine, but at home all the the instances are shown as registration circles. If you click into the movie clip and its a bitmap, it shows the bitmap when inside, but click out again and it disappears (see attached). Movie Clips inside Clips are just shown as reg points too. If I draw a a shape on the stage and convert it to a movie clip it immediately disappears too.

                   

                  This is really frustrating as I can do any work! - Is a re-install likely to do the trick?

                   

                  Thanks

                   

                  Marcus

                  • 6. Re: Instances on Flash CS4 stage, but aren't visable?
                    tomhorn3r Level 1

                    Hi,

                     

                    Here's how I fixed this.

                     

                    I reset my custom workspace by deleting the xml files that Flash creates in '/Volumes/Media/yourname/Library/Application Support/Adobe/Flash CS4/en/Configuration/Workspace'

                     

                    I then restarted Flash and created my custom workspace again.

                     

                    Remember, only delete the ones you have created - not the deault ones.

                     

                    Let me know if this works for you!

                     

                    Thanks,

                    Tom

                    • 7. Re: Instances on Flash CS4 stage, but aren't visable?
                      ewenx012 Level 1

                      Hi Marcus,

                       

                      I was able to get this to work after I reinstalled CS4 on my machine. I would try your fla file on a different machine and see if it works. If you're still having trouble, then I'd reinstall the software and that should do the trick.

                       

                      - McKenna

                      • 8. Re: Instances on Flash CS4 stage, but aren't visable?
                        mrmarcusmook Level 1

                        Hi Tom,

                         

                        Many thanks for the tip, that did not work initially, as flash re-created my custom workspace after I deleted it, but whilst finding the folder you mentioned i noticed there were also over 10,000 tempXXX.swf files in the configuration folder above this which I have deleted too. After deleting both the temp files and my custom workspace it worked... so many thanks... :-)

                         

                        Much appreciated

                         

                        All the best

                         

                        Marcus

                        • 9. Re: Instances on Flash CS4 stage, but aren't visable?
                          tomhorn3r Level 1

                          Hi,

                           

                          Yes it seems deleting those files does work.

                           

                          My next question is, why is Flash creating these files? I find myself having this recurring problem where I need to go back and deleted these files in order for Flash to work correctly!

                           

                          A work colleague of mine does not have the same problem of Flash creating these files - is this a preference in Flash?

                           

                          Any help is apppreciated.

                           

                          Thanks,

                          Tom

                           

                           

                          ***EDIT***

                           

                          Additional to this I have found that the problem seems to occur on Macs that are running Tiger, rather than Leopard.

                          • 10. Re: Instances on Flash CS4 stage, but aren't visable?
                            robbiemud

                            Has anyone else had trouble with this lately? I just experienced it and the solutions posted here aren't solving the problem. I has no custom workspaces saved so I tried creating one and deleting that but no luck. Also found one 'tempXXX.swf' and deleted that. Hoping not to have to re-install but that's my next option.

                             

                            This is a real pain, I'm right in the middle of a big job, any help greatly appreciated.

                            • 11. Re: Instances on Flash CS4 stage, but aren't visable?
                              JurriaanR

                              Yes, I still have this issue, and the suggestions here also didn't help. Im not working on a Mac, but on windows, and I only experience the problem when working on an AIR file. But I do have this issue on more than 1 computer and it basically rendered creating air apps impossible for me.

                               

                              It's a shame adobe is sticking it's head in the sand on these kind of bugs. 1 Patch in the entire product cycle is all you get, than what they see as support is called: buy the new version, you'll get new bugs, but we may, but probably not, have fixed this.

                              • 12. Re: Instances on Flash CS4 stage, but aren't visable?
                                mrmarcusmook Level 1

                                Just an idea to try....  try searching your entire HD for temp and if you come across a load of tempXX.swf files delete them. Might be worth a go? Good luck

                                • 13. Re: Instances on Flash CS4 stage, but aren't visable?
                                  JurriaanR Level 1

                                  Hi marcus,

                                   

                                  thanks for your reply. Yeah I tried that. But other than 1 tempXXX.fla (not even an swf), no such luck. Anyway, this is a pretty recent install so I didnt expect to find many. Also, it's not the whole file that has the problem. Only certain elements in the library behave like that, but there is nothing they have in common. Some are just ordinary sprites/movieclips, some are extended classes, some are buttons. Some have bitmaps included, others are just plain vectors.

                                   

                                  I just started a new project today, creating a new fla. Made 1 sprite, a background. No problem. Than another sprite, as close button, no problem. All pretty simple square vector shapes. Ok, so I make a second button, and as soon as I press f8 to convert it into a sprite, it gets invisible, the registration point jumps to another place on the stage and only if i know to find the clip and double click  I will see the button. Still just a basic vector shape.

                                  • 14. Re: Instances on Flash CS4 stage, but aren't visable?
                                    robbiemud Level 1

                                    Quick update...The bug has disappeared after a few days (completely at random from where I'm sitting), the workaround I used was to edit movieclips by selecting them in the Library and selecting Edit from the flyout menu. Luckily for me all my content was nested within a single clip so this worked most of the time, still a few random cases of the whole stage becoming blank a few seconds after trying to select anything.

                                     

                                    Also reading previous posts some people had the registration points of movieclips showing but no content, I just had blank space, nothing at all.

                                     

                                    Is there any point to this analysis? Anyone from Adobe listening out there? If this isn't going to be fixed how about a free upgrade? This has cost me about ten hours extra work and frustration so far.