15 Replies Latest reply on May 6, 2009 10:24 PM by sundeep.maithani

    AIR Applications fail to install (Acer Aspire One, Linux)

    relen-vPGuVI

      I've successfully installed the latest version of AIR for Linux on my Aspire One, although it took a few attempts.

       

      I am, however, not succeeding in installing any apps.

       

      1. My system believes that .air files are actually ZIP files and offers to unpack them: there seems to be nothing I can point them at to be opened by AIR itself.AIR does not appear in any menus, app lists etc

       

      2. If I go to a site that offers a "badge" install, the install system correctly recognises that AIR 1.5 is installed (checked box in the installer) and doesn't try to install it again. However, the apps do not install successfully - all fail with an Error #2004 and ask me to try again, which always fails.

       

      I can't seem to find any information whatsoever on this anywhere and I'm a bit surprised. It is surely not impossible to achieve, and I equally don't believe nobody else has had any trouble.

       

      Suggestions anyone?

       

      Thanks!

      --Richard E

        • 1. Re: AIR Applications fail to install (Acer Aspire One, Linux)
          relen-vPGuVI Level 1

          Looking into this further, it would appear that AIR isn't actually installed at all. I found an adobe-certs rpm package installed with the correct name, but the only other Adobe packages present are the flash player 10 and Acrobat Reader 8. I uninstalled certs just in case, but on trying to run the AIRInstaller I get a lovely progress bar which goes all the way across, then starts again, gets half-way and then fails with an error telling me that I might have to have admin rights. Well, it had already asked me for the root password, successfully, and I had already set it executable...

           

          Badge installs now tell me that they need to install the runtime and they also fail as before.

           

          I would rather like to find the actual AIRInstaller rpm and install it normally and see if that works, but it is not in the Adobe repo...

           

          Anyone else have any better ideas?

           

          Thanks in advance!

           

          --R

          • 2. Re: AIR Applications fail to install (Acer Aspire One, Linux)
            jbenson@oper8

            Have you tried installing AIR directly from the bin?

             

            Download File:

            http://airdownload.adobe.com/air/lin/download/latest/AdobeAIRInstaller.bin

             

            chmod it to executeable from terminal:

            chmod +x AdobeAIRInstaller.bin

             

            install from terminal as super user:

            sudo ./AdobeAIRInstaller.bin

            • 3. Re: AIR fails to install (Acer Aspire One, Linux)
              relen-vPGuVI Level 1

              Regrettably, that's EXACTLY what I've been doing. I think I might have better luck installing the rpm, but I don't know where to find it. Surprised it's not in the Adobe repo like flash is... I really want to go "# yum install adobeair" and sit back :-)

               

              Thanks for the thought though. Any other suggestions?

               

              BTW, in case you haven't run into it, the Acer's "Linpus" is a slightly customised fedora8.

               

              Thanks!

              --Richard E

              • 4. Re: AIR fails to install (Acer Aspire One, Linux)
                GauravKhurana Adobe Employee

                Could you try again after enabling logging?

                 

                http://kb2.adobe.com/cps/403/kb403123.html

                 

                What does ~/.airinstall.log says?

                • 5. Re: AIR fails to install (Acer Aspire One, Linux)
                  relen-vPGuVI Level 1

                  The file appears to be empty. :-(

                   

                  Setup is telling me, incidentally:

                   

                  "Sorry, an error has occurred.

                  "An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator."

                   

                  As I had su'd to root, I somewhat doubt its veracity.

                   

                  --R

                  • 6. Re: AIR fails to install (Acer Aspire One, Linux)
                    GauravKhurana Adobe Employee

                    If you are running the installer as root (or sudo user), i.e.

                    $ sudo AdobeAIRInstaller.bin

                    or

                    $ su -c AdobeAIRInstaller.bin

                     

                    the path of log file will be /root/.airinstall.log.

                     

                    If you are launching the AdobeAIRInstaller.bin as a normal user, the path of log file will be ~/.airinstall.log.

                     

                    Please create an empty log file before trying again.

                    • 7. Re: AIR fails to install (Acer Aspire One, Linux)
                      relen-vPGuVI Level 1

                      Yargh. Silly me.

                       

                      Here we go:

                       

                      Performing runtime install
                      UI SWF load is complete
                      UI initialized
                      starting user confirmation
                      Installation type: new
                      starting elevated install
                      subinstaller: starting install
                      subinstaller: Scheduling runtime installation operations
                      subinstaller: Session detected: GNOME
                      subinstaller: new installation
                      subinstaller: Beginning runtime installation
                      subinstaller: Beginning install
                      subinstaller: Copying /tmp/air.Ouahbi/build/opt/Adobe AIR/Versions/1.0/Resources/setup.deb to /tmp/air.Ouahbi/setup.deb
                      subinstaller: Error occurred; beginning rollback: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="Cannot run rpmbuild" errorID=1]
                      subinstaller: Deleting /tmp/air.Ouahbi/setup.deb
                      subinstaller: Error during rollback ignored: [IOErrorEvent type="ioError" bubbles=false cancelable=false eventPhase=2 text="Error #3003" errorID=3003]
                      subinstaller: Rollback due to error complete
                      subinstaller: error during install: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="Cannot run rpmbuild" errorID=1]
                      Failed during elevated install: error 1 Cannot run rpmbuild
                      runtime install entering error state: [ErrorEvent type="error" bubbles=false cancelable=false eventPhase=2 text="Cannot run rpmbuild" errorID=1]
                      begin quitting

                       

                      I do hope that helps, and thanks for your perseverance and assistance!

                       

                      Best,

                      --R

                      • 8. Re: AIR fails to install (Acer Aspire One, Linux)
                        relen-vPGuVI Level 1

                        From the above, it sounds a little as if it thinks it's running GNOME (close, but no cigar: it's Xfce); and Debian (no, it's more or less Fedora 8).

                        Whether that matters or not, I couldn't say :-).

                         

                        --R

                        • 9. Re: AIR fails to install (Acer Aspire One, Linux)
                          jbenson@oper8 Level 2

                          Just googling around it seems that there are a lot of issues with xfce and Adobe AIR.  (#1 being that it doesn't work.)

                           

                          Perhaps filing a bug away with Adobe would help (posting your log along with it) or at least might help at some point in the future.

                          http://www.adobe.com/cfusion/mmform/index.cfm?name=wishform

                           

                          Of course you can install Gnome or KDE packages within your distro to get those window managers available along side xfce.  Although I don't recommend it on that Aspire because it'd probably slow things down considerably.  (For instance I use Gnome primarily but have several KDE 4 apps with KDE 4 interfaces running just fine.  Have done the same with xfce.  I'll try installing gtk and some apps then installing AIR on an xfce machine later and see what happens.)

                           

                          It's kinda a shame but I understand that the developers can't target all window managers, however at the very least the big three (Gnome, KDE and XFCE) would be great.

                          • 10. Re: AIR fails to install (Acer Aspire One, Linux)
                            relen-vPGuVI Level 1

                            I found a respondent to a BBC iPlayer conversation who was running my hardware and although was having trouble with the iPlayer app, he had evidently installed AIR OK - but as the convo is closed I can't post anything asking what he did.

                             

                            Running GNOME on the Aspire One is problematical. There are some conflicts and I am not sure whether they can be circumvented or not.

                             

                            However it does seem to me that if the installer worked out that it should be creating an RPM and not a .deb installer file, I might have a better chance. As noted previously, I would like to download the .rpm and work from that - it would appear the Adobe installer is a little too clever for its own good in this area.

                             

                            Thanks for the observations!

                             

                            --R

                            • 11. Re: AIR fails to install (Acer Aspire One, Linux)
                              GauravKhurana Adobe Employee

                              Adobe AIR runtime installer is unable to find rpmbuild on the machine. Could you try again after installing rpmbuild?

                              Please do enable logging and attach the log file.

                               

                              Thanks!

                              • 12. AIR installed successfully; apps have issues (Acer Aspire One, Linux)
                                relen-vPGuVI Level 1

                                Right! "rpmbuild" was the answer to installing AIR successfully on this machine.

                                 

                                Assuming that you have somewhat unlocked the machine as described in http://macles.blogspot.com/ and elsewhere, this simplest way of getting rpmbuild installed is to open a terminal and, as root, do "yum install rpm-build" - note the hyphen in the package name. If you aren't subscribed to a suitable repository, you can find it pretty easily with a Google for "fedora8 rpm-build".

                                 

                                With rpm-build in place, AIR installed successfully using "./AdobeAIRInstaller.bin".

                                 

                                ".air" applications are now correctly identified as belonging to AIR and badge installs also work.

                                 

                                My intention in doing all this was to get a suitable Twitter etc app running on the machine, so I first tried the current version of Seesmic Desktop. It opened normally and allowed me to enter account details… and lo! it downloaded tweets! Unfortunately I never managed to get it to do that again. A bunch of small authorisation windows opened up, one for each installed account, requiring confirmation of password, and I couldn't enter anything in the field with the main window open. Minimising the main window I could now enter passwords, and OK dismissed the window, but it didn't seem to do any good. I have not seen a tweet since and all the panels in the main window are empty. A pity.

                                 

                                My other favourite Twitter app is Tweetdeck - in fact I think it's superior to Seesmic Desktop if you just run a single Twitter account. Here the main window opens somewhat off-screen and blank (black) with control buttons at the top. Unfortunately although the buttons reveal their tooltips on mouseover, you can't actually access any of them, notably the account setup button. Thus the app is not usable.

                                 

                                Third attempt was Twhirl, also from Seesmic (http://www.twhirl.org/). The version I had previously downloaded, 0.8.6, opened an account setup window but when you entered a password it just sat there. Luckily behind it was a window offering an update. Updating the package installed 0.9.2. This time the account window allowed the entering of an account name and password and duly displayed a window of tweets! And I was also able to write and send tweets successfully. Success! You can enter details for multiple accounts, and each has its own resizable window that contains messages pertaining to the account. Not as useful for me as Tweetdeck or Seesmic Desktop, but entirely usable (Desktop is actually a bit big for this machine's display anyway). However closing and reopening Twhirl I discovered that the application is not remembering passwords even when you tell it to - though it does remember the account names. Although I would like a fully-functioning app (and preferably one or both of the other two) this will do for the time being.

                                 

                                I notice that issues regarding passwords and authorisation are the common factors in these misbehaviours: if anyone can shed any light on this, please let me know.

                                 

                                Thanks to GauravKhurana for the key to solving this issue and the support in discovering it.

                                 

                                --Richard E

                                • 13. Re: AIR installed successfully; apps have issues (Acer Aspire One, Linux)
                                  jbenson@oper8 Level 2

                                  Thanks for posting your really detailed followup.  I was thinking of getting an Aspire One and this will save me some time.

                                  • 14. Re: AIR installed successfully; apps have issues (Acer Aspire One, Linux)
                                    relen-vPGuVI Level 1

                                    Finally got Seesmic Desktop to work, but it also won't remember passwords.

                                     

                                    You have to open the app, open the config window, enter the password for each account and hit Save and/or Apply (nothing actually happens so you can't tell which of these actually does the trick). You then start to receive tweets. Do not close the config window or the little username/password windows come up, one for each account, and you have to minimise the main window to enter the passwords - to which there is no point as you won't get anywhere. Instead, after completing the config window, bring the main window to the front and the app works fine. It does not, however, remember any passwords.

                                     

                                    I have found one app that remembers the password, although it only handles one account: Destroy Twitter (https://destroytwitter.com/). Icons are a bit small but it works pretty well. The version on the Adobe site is not the current one: install it with the badge install on the Destroy Twitter site as the straight download seems to have a problem at the time of writing.

                                     

                                    I would like to know what is causing these apps to have trouble with accounts settings, especially saving passwords.

                                     

                                    --R

                                    • 15. Re: AIR installed successfully; apps have issues (Acer Aspire One, Linux)
                                      sundeep.maithani

                                      Hi Relen

                                      I believe you are using XFCE. Well, AIR uses gnome-keyring (kwallet in case of KDE) to remember passwords.

                                      To be able to save passwords in XFCE you will have to do the following:

                                       

                                      1. From the terminal, run : gnome-keyring-daemon

                                       

                                      2. When you run the command, you will get  variables: GNOME_KEYRING_SOCKET, SSH_AUTH_SOCK, GNOME_KEYRING_PID initialized

                                       

                                      3. Export each these variable with the value the daemon in step 1 had assgined them, e.g.: export GNOME_KEYRING_SOCKET=/tmp/keyring-aKLPnd/socket;

                                      export SSH_AUTH_SOCK=/tmp/keyring-aKLPnd/socket.ssh;

                                      export GNOME_KEYRING_PID=7955;

                                       

                                       

                                      4. Now launch the app from the same terminal  (/opt/Seesmic\ Desktop/bin/Seesmic\ Desktop) and enter your passwords, your passwords should be getting saved.

                                       

                                      Let me know if thats not the case.

                                       

                                      -Thanks

                                      Sundeep