0 Replies Latest reply on May 6, 2009 2:30 PM by ethr

    plotchart - bug?

    ethr

      Im wanting to use a PlotChart but have run into the following problem: its defaulting to all black with black text! I have several of these charts in my application and only one is having this problem. Here is the code:

       

       

      <mx:PlotChart width="100%" height="100%"

                  id="x10_2_PlotChart" paddingBottom="0" paddingLeft="0" paddingTop="0" paddingRight="0">

                  <mx:series>

                  <mx:PlotSeries xField="fullDate" yField="nameLoc"/>

                  </mx:series>

                 

                  <mx:verticalAxis>

                      <mx:LinearAxis id="vaxis" labelFunction="x10_2_LabelFunction" />

                  </mx:verticalAxis>

       

                     <mx:horizontalAxis>

                      <mx:DateTimeAxis />

                  </mx:horizontalAxis>

       

      </mx:PlotChart>

       

       

      This is the only chart where I'm using the DateTimeAxis.

       

      The 'all black' version appears immediately when I load the form - before I set the dataprovider.

       

      I've tried changing various params in hope of understanding what I've set wrong. Setting / changing the data provider doesn't fix it.  My labelFunction returns "" if the data hasn't been loaded yet.

       

      It appears to be random. Im trying to be systematic about getting a repro case but making changes in other (unrelated) parts of the code can cause the problem to go away / return.

       

      Im guessing that the alpha has gotten set in some odd space. If I change it to .5 at design time I get a usable chart with a greenish background. I can see the text now though. Its not a solution though. I tried adjusting the 'blendmode' too. No luck.

       

      Im doing something completely silly and I can't see it. Set me right and laugh all you want.