3 Replies Latest reply on May 11, 2009 4:45 AM by RoboColum(n)

    Hyperlinks in merged chm files not working

    TTS_Eric

      I have been using Robohelp X3 for years and have a rather large hlp project which actually consists of 8 seperate projects.

       

      I have converted the files to chm format and have gotten the merged TOC to work but I can not get any of the hyperlinks which link to topics in other merged chm files to work. When I click on the link I get "The page cannot be displayed".

       

      I have tried creating thee links from scratch but still no good. What is the correct procedure for this?

        • 1. Re: Hyperlinks in merged chm files not working
          RoboColum(n) Level 5

          Hi TTS_Eric and welcome to the RH community.

           

          Inter CHM links are performed by using the Insert > Hyperlink menu item or toolbar icon. When the dialog is displayed, click the down arrow to the left of the "Link to" field and select Remote Topic. From there, navigate to the CHM file that contains the topic and from there the list of topic is displayed from where you can select the topic.

           

          If this is what you have done, there are other possibilities that could be causing the problem. The first is that your CHM files are not on a local drive or are not in the same directory. Check this first and let us know how you get on.

           


          Read the RoboColum(n) for mutterings on RoboHelp, Technical Communication Suite and technical communication.

          • 2. Re: Hyperlinks in merged chm files not working
            TTS_Eric Level 1

            Hyperlink.jpg

             

            When I use the Insert Hyperlink menu that option does not exist. When I select the link in the Remote URL list in the bottom, see image, then the link does not work. My menus come out correctly merged and the topics show up when clicked on in the TOC but not the Hyperlink.

             

            I am using the latest Version 8 demo downloaded last Friday.

            • 3. Re: Hyperlinks in merged chm files not working
              RoboColum(n) Level 5

              This looks like you do not have Microsoft HTML Help set as your primary single source layout. The Remote Topic option is only available when it is.

               

              I also just want to check that you are using the RH HTML application rather than the RH for Word application. I ask because many WinHelp users try to generate CHMs from the RH for Word application. It is best to use the RH HTML application for CHM production as it is better designed for the purpose. MS Word's efforts at generating HTML is IMHO woeful whereas RH8's HTML code is SO much better.

               


              Read the RoboColum(n) for mutterings on RoboHelp, Technical Communication Suite and technical communication.