4 Replies Latest reply on May 13, 2009 8:47 AM by Rothrock

    Can't get embedding characters to work

    maxelcat Level 1

      Hi

       

      I have to embed VAGRounded bold. I can't seem to get it to work reliably. I have created 4 dynamic text boxes, one for each of the 4 styles and embedded the characters into each one for the 4 versions of the font. I then wrote some text directly into the boxes on the stage.

       

      I created a 5th dynamic box and called it "test". I set the family to VAG ROunded, style:bold (ie just like one of the ones above). I then embedded the characters into it.

       

      I added this dead simple as2

       

      stop();

      test.text="hello"

       

       

      THis 5th text box looks NOTHING like the bold one from above, as you can see in the attached image.

       

      What am I doing wrong?

       

      Thanks

       

      E

        • 1. Re: Can't get embedding characters to work
          Rothrock Level 5

          I don't see an attached image, so I don't know what it looks like.

           

          Check to make sure that your fonts are getting embedded. You can go into Publish settings and turn on "Generate Size Report." The report (which will show up in your output window when you test publish) will show what fonts and characters are embedded.

           

          What kind of font is it, e.g. truetype, opentype, etc.?

           

          Are the textfields html enabled?

           

          Which version of Flash player are you publishing to?

           

          You haven't somehow changed the Anti-alias settings for one of the fields?

          • 2. Re: Can't get embedding characters to work
            maxelcat Level 1

            Thanks for the reply

             

             

            have tried to attach image again

            am publishing to flash player 8

            have kept anti-alias the same

             

            I have embedded the fonts, so that they appear with my new names and an * next to them. I notice that their appearence is a bit hit and miss. When I open up the fonts list sometimes some of them are missing, and I have to scroll up and down to get them to appear. This font has an "O" symbol rather than a "TT"

             

            The textfields are not html enabled - but I have tried with and without

             

            What you see in the image is just an experiement. FOr the actual project I have given up and used createTextField which seems to work fine. HOwever, I would like to get this sorted since I have had issues like this before, and its time to beat it!!!

            • 3. Re: Can't get embedding characters to work
              maxelcat Level 1

              sorry the font has a red "a" next to it, not and "o" or "tt"

              • 4. Re: Can't get embedding characters to work
                Rothrock Level 5

                I have no idea. It works just like it should for me. I tried it both on my Mac at home and my PC at work. I don't have the font you are working with so that might be an issue. Have you tried it with other fonts. Let's make the test simpler.

                 

                One dynamic textfield, font of your choice, style of your choice, put some text in it, embed basic latin.

                 

                Wait a minute....you aren't embedding all by any chance? Does your font have a bunch of crazy higher unicode plane characters? Does embedding basic latin work better than all? Anyways back to our simpler test.

                 

                Another dynamic textfield, match the font and style as above, embed only lowercase, and give it an instance name.

                 

                Then assign it "Hello World."

                 

                Do you get the capital H and W? If so then the embedding is working fine. What happens if you delete the first field and test publish again? Do the H and W go away? If so then you are certainly pulling the embeded font from the published swf's "library" (not to be confused with the library panel and fonts that you create in there.