1 Reply Latest reply on May 12, 2009 7:43 AM by 44web

    why do users get "unable to set template properties" message?

    44web

      Hi there,

       

       

      I am trying to administer a new site that was created with DW and has a .dwt (Templates/ locatedat the site root). I'm creating "Publisher" role connection keys so users can edit their subsections of the site. Users should be able to modify template properties when they edit/create new pages.

       

      While testing the keys, the users report that they can connect and edit pages. However, when they try to modify template properties on either a new or existing page, they get this message "Unable to set template properties" and are prevented.

       

      I've tried redefining the site and starting all over, tried CS3 vs. CS4 to see if it was a compatibility issue, looked at forum after forum but can't find any answers. I am experienced with DW but new to Contribute administration so I don't know what else to try. Hoping that someone will have encountered this before and can suggest a solution.

       

      Thanks in advance!

       

      ps- Let me know if there's other info I can provide to help troubleshoot.

        • 1. Re: why do users get "unable to set template properties" message?
          44web Level 1

          I did find this April 9, 2009 post from majtom2grndctrl that suggests the issue is how contribute treats https:// sites. My site is set up as majtom2grndctrl described and I am having the same problem.

           

          "I've got a problem with not being able to edit Template Properties on our test sites we host on HTTPS servers. I've narrowed down the problem to Contribute CS4 ignoring the website root configuration when it looks for the Templates folder. For example, say you have a site hosted at the following address:

           

          https://www.yourdomain.com/yourfolder/

           

          Contribute is configured to know your site is in /yourfolder/, but for whatever reason, when you open or create a page, and Contribute reads the InstanceBegin template="/Templates/file.dwt" tag at the beginning of HTML documents, it looks for a Templates folder at the HTTP server root, not in /yourfolder/. This prevents Contribute from loading the template while editing a document, and any attempt to edit Template Properties will yield the infamous "Unable to set template properties" dialog box."