5 Replies Latest reply on May 13, 2009 6:34 AM by Phil Frank

    extendscript toolkit won't load

    Phil Frank Level 1

      I'm running CS4 on Windows XP and trying to look at some of the help information in the extendscript toolkit to help with some scripting issues in ID, but for some reason the toolkit simply won't load. I've tried right-clicking on an ID script and then choosing edit script; I've tried running it from the start menu, and the results are the same: sometimes I get a brief hourglass (or not), and then nothing. Has anyone had this experience and figured what to do about it?

       

      Thanks very much.

       

      Phil

        • 1. Re: extendscript toolkit won't load
          Peter Kahrel Adobe Community Professional & MVP

          Try double-clicking the .exe file (\program files\adobe\adobe utilities\extendscript toolkit cs4\extendscript toolkit.exe). I've had problems firing it up from the start menu and using shortcuts, which went away after I had started it by double-clicking the exe.

           

          Peter

          • 2. Re: extendscript toolkit won't load
            Andreas Jansson Level 2

            Try trashing the preferences for ESTK as well. You can do that in the same way as for the main application. Hold down Shift+Ctrl+Alt while starting (trying to start) the application by double-clicking the exe file. I had lots of trouble with the ESTK for CS4 until deleting the preference files using this shortcut. I was not aware that it had to (or even could) be done separately for the ESTK.

             

            Best regards,

            Andreas Jansson

            • 3. Re: extendscript toolkit won't load
              Phil Frank Level 1

              Thank you, Peter and Andreas, for your responses. Unfortunately, neither helps. If I double click in Windows Explorer, I see the hourglass for a second, the Explorer window flashes for a second, then nothing.

               

              If I hold down Shift-Ctrl-Alt and double click, it opens the properties as if I had just held down the Alt key while starting.

               

              I also tried holding down just the shift key while starting so it would start without loading the preferences (as it says in the PDF file), but that had the same effect.

               

              Phil

              • 4. Re: extendscript toolkit won't load
                Andreas Jansson Level 2

                You would possibly have to press those keys while starting... and that's hardly possible when the program quits to quickly. I recognize the error you have, but do not remember exactly how I fixed it. There are probably some preferences files on disk (if they are the problem), which can be renamed in order to let new ones be generated. That has been the case with the main application.

                 

                Look for updates for InDesign (Help menu), so you're sure to have the latest.

                 

                Also try resetting the preferences for InDesign (the main application) by pressing Shift+Ctrl+Alt while starting it. If that makes no difference you could have a look (v. google) for resetting/trashing the preferences by hand for the ESTK.

                 

                A last resort would be to reinstall.

                 

                // Andreas

                • 5. Re: extendscript toolkit won't load
                  Phil Frank Level 1

                  Andreas,

                   

                  That was the ticket! I first clicked on the exe file and then immediately pressed the three keys, and it worked. And after I closed it, I tried in InDesign to right-click on a script name, then edit script, and it came up again. So I'm in business.

                   

                  Thanks again for sticking with it.

                   

                  Phil