1 Reply Latest reply on Sep 15, 2009 11:06 AM by esroberts

    access violation using RestHttpService

    mickey3 Level 1

      Hi

       

      This one completely drove me nuts.

       

      I'm using this library over here: http://code.google.com/p/resthttpservice/wiki/Introduction

       

      because I needed to set PUT and DELETE method requests over to a web service server.

       

      The request is successful but after like 20 seconds Flex would return and alert me with a "Security sandbox violation". What's strange is i am able to make that request but stil flex would throw me that error.

       

      This was the last state of my crossdomain.xml:

       

      [mcfserver@centos-cms ROOT]$ pwd
      /home/mcfserver/tomcat/webapps/ROOT
      [mcfserver@centos-cms ROOT]$ more crossdomain.xml
      <?xml version="1.0"?>
      <!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-poli
      cy.dtd">
      <cross-domain-policy>
         <allow-access-from domain="*" to-ports="*" secure="false" />
      </cross-domain-policy>

       

      and you can see the socket server is running and listneing to port 843:

       

      [mcfserver@centos-cms ~]$ ./flashpolicyd.pl --file=tomcat/webapps/ROOT/crossdomain.xml --port=843

       

      Listening on port 843

       

      But everytime my flex app would start, i know its not hitting the socket server.

       

      Any ideas? I'm willking to try (provided i haven't tried it yet).

       

      Thanks in advance.

        • 1. Re: access violation using RestHttpService
          esroberts

          I posted about the exact same problem yesterday before I saw your post.  This is an incredibly frustrating issue.  I'm beginning to think it might be an issue with the RestHttpService library.  It seems like I've tried every possible permutation of socket policy file configuration and the problem still exists.  Any help would be greatly appreciated.