21 Replies Latest reply on May 16, 2009 7:06 PM by billphifer

    Incorrectly saves as M4V.  I want MPEG movie

    billphifer

      I am using Adobe Premiere Elements 7.

       

      After creating a movie I (carefully) select MPEG and H.264 1920x1080i 30.  I click "Save" and my movie is correctly saved as a "MPEG Movie".

       

      THE ISSUE IS I save the final product as a "project".  Now if I want to re-save the same movie again, or edit the movie, or do anything and save again as described above the final product is saved as a "M4V".  I do not want M4V.

       

      I can only save my original creation as a MPEG Movie, which is what I want.

       

      If I save the movie again or open the project and (carefully) select MPEG and H.264 1920x1080i 30, it saves it everytime as a M4V, which I DO NOT WANT.

       

      Any ideas about how why the second time around it only saves as a M4V and not a as a MPEG Movie?

        • 1. Re: Incorrectly saves as M4V.  I want MPEG movie
          the_wine_snob Level 9

          I think that two things are happening here:

           

          1.) When you Save, you are ONLY Saving the .PREL file. This is your Project and is only an XML list of your media, its location on the system and what you're doing to it.

           

          2.) It appears that when you are Exporting your Timeline, you do not have Multiplexing and Audio turned on. One can Export (Share too) as an elemental stream, i.e. Video-only, or Audio-only. If you DO have Audio & Video checked and Multiplexing is turned ON, then something is stopping the Multiplexing process. What happens from PE in this case is that the elemental streams are created, and there will be a couple of "helper" files also created. In the last step, Multiplexing, those "helper" files are used to combine the Audio & Video, and then they, plus the elemental streams are deleted.

           

          As a test, create a new folder in your Project folder hierarchy. Do your Export again, and be sure that Export Audio and Export Video are checked. Next, check that Multiplexing is on. Do your Export to your new, empty folder. When all is done, look in that folder, and tell us what file(s) are in it. It's also kind of neat to open Windows Explorer and watch that destination folder. You *should* see the process that I outline in #2 above. Files created, then files are deleted to yield one muxed (Multiplexed) file with both Audio & Video.

           

          Please report back and good luck,

           

          Hunt

          • 2. Re: Incorrectly saves as M4V.  I want MPEG movie
            Paul_LS Level 4

            Yes, it will export as M4V if you have no audio... so there is just video on the timeline that you are exporting.

            • 3. Re: Incorrectly saves as M4V.  I want MPEG movie
              the_wine_snob Level 9

              Paul_LS,

               

              I had not considered that the OP might have a Video-only Timeline. Just assumed that anybody wanting a muxed file would have both Audio & Video. You have probably nailed it - nothing to mux...

               

              Good call,

               

              Hunt

              • 4. Re: Incorrectly saves as M4V.  I want MPEG movie
                Paul_LS Level 4

                No so sure Hunt, if he had a multiplexed export first time why is he getting the M4V now??? Strange...

                • 5. Re: Incorrectly saves as M4V.  I want MPEG movie
                  billphifer Level 1

                  Hunt (and everyone else),

                   

                  Thank you for your interest in solving my problem.

                   

                  I did everything you suggested and my issue has NOT been solved.

                   

                  I went to the SHARE TAB and verified that Export Video and Export Audio are both checked.

                   

                  In the Multiplexer Tab  only “TS” is checked.

                   

                  When I select "Save" it continues to save my movie as a M4V.

                   

                  Yet, the first time I create a movie it saves it as a MPEG, which is what I want.

                   

                  I, HOWEVER, THINK EVERYONE IS ON TO MY PROBLEM.

                   

                  After creating my original movie I permanently deleted the audio.  I am a bighorn photographer and do not need audio because all one would hear is wind.  So on my first time save, I select MPEG, then I select a preset H.264 1920x1080i 30, and hit save.  It saves as a MPEG Movie which is what I want (without audio).

                   

                  So, my issue is when I return to the Project without audio -- to add some clips or continue to edit -- (audio has been permanently deleted) and save again it will only save as a M4V.

                   

                  So I guess my question changes to how can I save a Project as a MPEG Movie without audio?

                   

                  Thank you all very much,

                   

                  BillPhifer

                  • 6. Re: Incorrectly saves as M4V.  I want MPEG movie
                    billphifer Level 1

                    You are correct, it is an audio issue.  I returned to an old project that would only save as a M4V and added in a new clip WITH audio and it saved as a MPEG.  Without audio a project saves as a M4V!

                     

                    I, of course, have many hours of time creating projects and my time hasn't been lost because they can now be "saved" by adding in a new clip with audio.

                     

                    Maybe there's something somewhere I need to click or unclick to save to save a project as a MPEG without audio.

                     

                    Certainly Adobe can fix this issue because one should be able to save a Project without audio as a MPEG.

                     

                    Thank everyone for taking the time to consider my problem and suggest solutions.

                     

                    BillPhifer

                    • 7. Re: Incorrectly saves as M4V.  I want MPEG movie
                      the_wine_snob Level 9

                      Bill,

                       

                      Something about the lack of Audio is fooling the media encoder. Instead of deleting the Audio, try just muting it, so that the gain is -∞. You will still have silence, which is what you want, but you *should* be able to get the full MPEG format (with the H.264 CODEC). Please let us know if this works for you.

                       

                      Something else to test would be to take one of your m4v files and rename it MPEG. What you have is an MPEG-4 (H.264 CODEC) and it's showing it as the elemental steam with Video-only. How does that work? [Just a *guess* on my part here, as I work in SD, so I'm almost always going to DV-AVI Type II files (elemental Video-only stream) and AC3 (elemental Audio-only DD 5.1 SS stream). I combine the two in Encore later, for Burning to DVD-Video]

                       

                      Good luck, and please keep us informed. Success is "just around the corner." I can feel it.

                       

                      Hunt

                      • 8. Re: Incorrectly saves as M4V.  I want MPEG movie
                        the_wine_snob Level 9

                        My *guess* would be that something is fooling the media encoder. It is convinced that all that is required is the Video-only elemental stream, the m4v part. Why? What? I have no clue. That it worked perfectly once, but not the next, is puzzling. Again, my *guess* would be one switch/setting has been accidently changed.

                         

                        Persuant to my direct reply to Bill, what do you think would happen if he just changes the file extension from .m4v to .MPEG? I do not work in HD, so I'm not Exporting to MPEG-4/H.264. I know that you do a lot of HD work, and that's why I'm asking for your studied opinion here.

                         

                        Thanks,

                         

                        Hunt

                        • 9. Re: Incorrectly saves as M4V.  I want MPEG movie
                          billphifer Level 1

                          How do I change a file from a .m4v to a .MPEG?  All I know to do is right click on the icon and select properties and then it tells me the ypice of file is "M4V.

                           

                          This is confusing because my initial save before I created a Project is MPEG Movie without audio.  After that the next save has to have audio and any audio length is enough.  On my existing Projects I added a "End" title, then after that I added another video clip with audio.... about 1 second in length and deleted the video part.  This is enough audio to allow it to save as a MPEG Movie.

                           

                          I thought about a changed setting issue to, so before posting here I deleted Premiere Elements and reinstalled.... and the problem persists.

                           

                          I considered muting the audio but decided to delete it thinking my file size would be smaller.

                           

                          Thanks everyone for "wanting to know why" and if I find a solution I will post it here.

                           

                          BillPhifer

                          • 10. Re: Incorrectly saves as M4V.  I want MPEG movie
                            the_wine_snob Level 9

                            Bill,

                             

                            I would Copy your m4v file to another folder. There, Rt-click on the file and choose Rename. Highlight just the file extension, "m4v," and type in "MPEG." You can also do this by clicking the file, then clicking it again - this is not a Dbl-click, but a click-pause-click. The file name will highlight in the Renaming box, and you will still just replace the m4v extension with MPEG. Now, once Renamed, Dbl-click on that file and see if it opens in an appropriate player on your system and plays as an HD Video (obviously silent). This is a test to see if you can get exactly what you want.

                             

                            I do have a question: why do you need a file with the MPEG extension specifically? What about the m4v extension is causing a problem? May be another way to "skin this cat."

                             

                            Good luck,

                             

                            Hunt

                            • 11. Re: Incorrectly saves as M4V.  I want MPEG movie
                              the_wine_snob Level 9

                              Bill,

                               

                              Thanks for that clarification. Good to know that the issue has been narrowed down a bit, and that you have a workaround.

                               

                              Can you do a couple of screen-caps of your Export dialog boxes and attach them? Maybe someone will see something there, that I'm missing.

                               

                              Also, see my other reply to the Renaming part of this thread.

                               

                              Appreciated and good luck,

                               

                              Hunt

                              • 12. Re: Incorrectly saves as M4V.  I want MPEG movie
                                billphifer Level 1

                                The M4V extension does not play on my Windows Media Player so I am unable to see the video I created.  I am able to play MPEG on my PC using Windows Media Player.

                                 

                                And, sometimes I want to upload a short clip to YouTube and M4V is not recognized by YouTube.  MPEG Movie is recognized by YouTube.

                                 

                                I’m not certain what a screen-cap is (I am trying to understand terminology and abbreviations as best I can and then locate same).  I think this is what you want.

                                 

                                EXPORT SETTINGS:

                                Format:  H.264 Blu-ray

                                Preset:  H.264 1920x1080i 30

                                Comments: 1920x1080i 29.97 High Quality

                                 

                                SUMMARY:

                                NTSC, 1920x1080, 29.97 (fps), Upper

                                Dolby Digital, 192 (kbps), 48 kHz

                                VBR, 1 Pass, Target 20.00, Max 21.00 (Mbps)

                                VIDEO TAB:

                                Video Codec:  MainConcept H.264 Video

                                 

                                BASIC VIDEO SETTINGS

                                TV Standard:  NTSC

                                Frame Dimensions: 1920x1080

                                Frame Rate: 29.97

                                Field Order Upper

                                Profile: High

                                 

                                AUDIO TAB

                                Audio Format: Dolby

                                Bitrate Settings: 192

                                MULTIPLEXER

                                Multiplexing:TS

                                 

                                I was unable to rename the file extension.  All I could do was rename the file which would be of no value.  After selecting rename I saw no option to change the file extension.

                                 

                                At least I am able to continue as normal as long as I know that I’ll have to keep the audio.  I sent Adobe feedback on this issue and hopefully they will respond.   And I’ll update everyone.

                                 

                                Thank you for your suggestions and I’ll keep trying various options.

                                 

                                BillPhifer

                                • 13. Re: Incorrectly saves as M4V.  I want MPEG movie
                                  billphifer Level 1

                                  SOLVED!

                                   

                                  Drag your clip into "Video One".  The clip contains both video and audio.  Select combined video and audio clip and RIGHT CLICK. 

                                   

                                  Select UNLINK AUDIO AND VIDEO.

                                   

                                  My tests indicate this solves the problem I described.

                                   

                                  Thank everyone for their persistence in solving this annoying problem.

                                   

                                  I hope someday I can reciprocate.

                                   

                                  BillPhifer

                                  LasVegas

                                  • 14. Re: Incorrectly saves as M4V.  I want MPEG movie
                                    the_wine_snob Level 9

                                    OK, something is very wrong. You should be able to use Windows Explorer/My Computer to change both the file name and the file extension. When you do this, you WILL get an error message, saying, "If you change the file extension, it might not work in some applications... " That is alright. Click OK to accept your new extension. Then, with this test Copy of your m4v file, Dbl-click the file now, with the new extension, and see if it plays properly.

                                     

                                    File extensions are a funny thing. Some are cast in stone. Others merely indicate a "wrapper," and what is inside can be determined by many programs. AVI, MPEG and MOV are such file extensions. WMV is possibly even more so, in that there are even more possible CODEC's that can be inside the file.

                                     

                                    If you cannot change the file's extension, then something is horribly wrong with your system. Do you get some error message, or just experience the inability to change the extension? Now, one caveat: if the Copy of this file is in use by any program, like a player, you will NOT be able to change it. Exit all programs, that might have it in use. By using the Copy, there should be NO programs accessing it.

                                     

                                    Please give this operation another try. I feel that I was just not clear on the exact proceedure.

                                     

                                    Good luck,

                                     

                                    Hunt

                                    • 15. SOLVED!  Re: Incorrectly saves as M4V.  I want MPEG movie
                                      billphifer Level 1

                                      Re: Incorrectly saves as M4V.  I want MPEG movie

                                      SOLVED!

                                       

                                      Drag your clip into "Video One".  The clip contains both video and audio.  Select combined video and audio clip and RIGHT CLICK. 

                                       

                                      Select UNLINK AUDIO AND VIDEO.

                                       

                                      My tests indicate this solves the problem I described.

                                       

                                      Thank everyone for their persistence in solving this annoying problem.

                                       

                                      I hope someday I can reciprocate.

                                       

                                      BillPhifer

                                      LasVegas

                                      • 16. Re: Incorrectly saves as M4V.  I want MPEG movie
                                        the_wine_snob Level 9

                                        Bill,

                                         

                                        Great news! Glad that you got it sorted out. Thank you for reporting.

                                         

                                        At your convenience, please try the file extension Renaming suggestion, as I would really appreciate knowing if my theory is correct, or not. I'd try it myself, but do not shoot HD and do not have any HD footage to test it one. Thank you.

                                         

                                        Hunt

                                         

                                        PS see ya' at Joël Robuchon's L`Atelier at the MGM, or his Joël Robuchon's at the Mansion!

                                        • 17. Solved>  Re: Incorrectly saves as M4V.  I want MPEG movie
                                          billphifer Level 1

                                          Thanks for the MGM suggestion.

                                           

                                          I have tried and tried, but am unable to change the extension as you have suggested.  It's a settings issue of what I am allowed to do, I think.  I don't want to change hard settings I don't understand at this point.

                                           

                                          I am shooting a Canon Vixia HF S10 and am struggling through learning new technology.

                                           

                                          So, any and all help is appreciated -- especially your fast reply... it led me to the solution.

                                           

                                          BillPhifer

                                          • 18. Re: Solved>  Re: Incorrectly saves as M4V.  I want MPEG movie
                                            the_wine_snob Level 9

                                            Bill,

                                             

                                            Would it be possible to do an Export of a tiny piece of your Timeline, the one that yields the m4v files (hint: use the WAB, the Work Area Bar), and then attach that file to a post? Obviously, to meet the size requirements of the Adobe forum, you'll have to limit the Duration, but just a few seconds of the m4v will work perfectly. It will also give me some HD material to test with.  I'd like to experiment with that file and see what happens for me. This will allow me, and others, to test the file.

                                             

                                            I'm away tomorrow, but will have time to work with any test file next week. I'll be glad to report my findings.

                                             

                                            Thank you,

                                             

                                            Hunt

                                             

                                            PS if you ever want food recs., I strongly recommend THIS board. Las Vegas is in the Southwest sub-forum. My posts are under my full name, Bill Hunt, as in my profile here.

                                            • 19. Re: Solved>  Re: Incorrectly saves as M4V.  I want MPEG movie
                                              billphifer Level 1

                                              Thank you for your continued interesting in a complete understanding about what's going on.  I have attached a .m4v file names noaudio that I used for test purposes.  I have deleted all of my other .m4v files because the fix I reported makes things work now for me.  I can't tell you how much time I spent in editing "projects" only to not have them save as a MPEG movie and I had to toss them because they would not show on my monitor and/or upload a few seconds to YouTube for a few close friends to see.

                                               

                                              billphifer

                                              • 20. Re: Solved>  Re: Incorrectly saves as M4V.  I want MPEG movie
                                                billphifer Level 1

                                                It would not attach the file.  So I try again.

                                                 

                                                Thank you for your continued interesting in a complete understanding about what's going on.  I have attached a .m4v file names noaudio that I used for test purposes.  I have deleted all of my other .m4v files because the fix I reported makes things work now for me.  I can't tell you how much time I spent in editing "projects" only to not have them save as a MPEG movie and I had to toss them because they would not show on my monitor and/or upload a few seconds to YouTube for a few close friends to see.

                                                 

                                                billphifer

                                                • 21. Re: Solved>  Re: Incorrectly saves as M4V.  I want MPEG movie
                                                  billphifer Level 1

                                                  I am unable to upload a M4V file that is less than 2MB in size.