11 Replies Latest reply on Jun 18, 2009 5:30 AM by Ansu2000

    How to install Flex Builder?

    JPettersson

      I would like to start using Flex. But I have big problems when trying to install Flex Builder 3. I already have Eclipse (Ganymede, 3.4) installed on my Windows Vista machine so I tried to install the Eclipse plugin, but I got these dependency pronblems:

       

      Cannot complete the request.  See the details.

      Unsatisfied dependency: [com.adobe.flexbuilder.debug.e32 3.0.214193] requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)

      Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.3.100,4.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)] can be satisfied.

      Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.3.100,4.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)] can be satisfied.

      Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.3.100,4.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)] can be satisfied.

      Cannot find a solution where both Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.3.100,4.0.0)] and Match[requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)] can be satisfied.

      Unsatisfied dependency: [org.eclipse.platform.feature.group 3.4.1.r341_v20080731-9I96EiDElYevwz-p1bP5z-NlAaP7vtX6Utotqsu] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.help.feature.group/[1.0.1.R34x_v20080827-7r7xEIxEI6 Zu5nEqN7M3UBpglaat,1.0.1.R34x_v20080827-7r7xEIxEI6Zu5nEqN7M3UBpglaat]

      Unsatisfied dependency: [com.adobe.flexbuilder.debug.e32 3.0.214193] requiredCapability: osgi.bundle/org.eclipse.debug.ui/[3.2.0,3.3.0)

      Unsatisfied dependency: [org.eclipse.platform.ide 3.4.0.M20080911-1700] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.platform.feature.group/[3.4.1.r341_v20080731-9I96Ei DElYevwz-p1bP5z-NlAaP7vtX6Utotqsu,3.4.1.r341_v20080731-9I96EiDElYevwz-p1bP5z-NlAaP7vtX6Uto tqsu]

      Unsatisfied dependency: [com.adobe.flexbuilder.feature.core.feature.group 3.0.214193] requiredCapability: org.eclipse.equinox.p2.iu/com.adobe.flexbuilder.debug.e32/[3.0.214193,3.0.214193]

      Unsatisfied dependency: [org.eclipse.rcp.feature.group 3.4.100.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.ui.workbench/[3.4.1.M20080827-0800a,3.4.1.M20080827 -0800a]

      Unsatisfied dependency: [org.eclipse.help.feature.group 1.0.1.R34x_v20080827-7r7xEIxEI6Zu5nEqN7M3UBpglaat] requiredCapability: org.eclipse.equinox.p2.iu/org.eclipse.rcp.feature.group/[3.4.100.r341_v20080814-989JESIEd AciFYfkZZsBfSwQ2341,3.4.100.r341_v20080814-989JESIEdAciFYfkZZsBfSwQ2341]

      Unsatisfied dependency: [com.adobe.flexbuilder.feature.core.nl1.feature.group 3.0.214193] requiredCapability: org.eclipse.equinox.p2.iu/com.adobe.flexbuilder.feature.core.feature.group/[3.0.214193,3. 0.214193]

       

      And after that I tried to install Flex Builder 3 standalone, but that worked even worse, It just created two empty folders! How to solve all these problems?