3 Replies Latest reply on Sep 22, 2008 7:53 AM by Newsgroup_User

    Template not updating linked pages

    phrarod Level 1
      I've never had this happen before. Any changes i make - mainly to nav doesn't take in any of the linked pages. Even if I make a new page directly from the template, then make a change to the template it doesn't even update the newly created page.

      Using DW MX2004

      Anyone ever hear of this? A fix?
        • 1. Re: Template not updating linked pages
          Level 7
          Here are seven common mistakes that will result in changes not propagating
          from Template to child -

          1. Rename the Templates folder
          2. Move the Templates folder to some other folder level in the site other
          than root level
          3. Move a template out of the Templates folder.
          4. Make changes to an editable region of the template (which will not
          propagate)
          5. Assume that template changes can be uploaded to the server without also
          uploading the changed local files
          6. Corrupt the site cache so that the link between template and child page
          is broken
          7, Improperly create your child pages by simply opening the template,
          adding page specific content, and resaving the template with an *.html
          extension rather that its *.dwt extension. (you can tell if this is the case
          by looking at the code on a child page - if you see anything like <!--
          TemplateBeginEditable... then this is what you have done). If you *have
          done this*, then recreate the child pages (in DWCS3) using FILE | New > Page
          from Template, select the template and click CREATE.

          The 6th problem can be repaired by using SITE | Advanced > Recreate Site
          Cache, and the six others can be fixed by just not doing them. Have you
          done any of those?

          Or, read this -
          http://www.adobe.com/go/dd83ba8b


          --
          Murray --- ICQ 71997575
          Adobe Community Expert
          (If you *MUST* email me, don't LAUGH when you do so!)
          ==================
          http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
          http://www.dwfaq.com - DW FAQs, Tutorials & Resources
          ==================


          "phrarod" <webforumsuser@macromedia.com> wrote in message
          news:gb75q5$mpv$1@forums.macromedia.com...
          > I've never had this happen before. Any changes i make - mainly to nav
          > doesn't
          > take in any of the linked pages. Even if I make a new page directly from
          > the
          > template, then make a change to the template it doesn't even update the
          > newly
          > created page.
          >
          > Using DW MX2004
          >
          > Anyone ever hear of this? A fix?
          >

          • 2. Re: Template not updating linked pages
            phrarod Level 1
            Guilty of #4. Figured it out at 2AM.

            Thanks Murray
            • 3. Re: Template not updating linked pages
              Level 7
              If you search the forum, you will find that this is what catches most of the
              new users. But the LAST thing you want to do on your Template is have the
              navigation in an editable region, you know?

              --
              Murray --- ICQ 71997575
              Adobe Community Expert
              (If you *MUST* email me, don't LAUGH when you do so!)
              ==================
              http://www.projectseven.com/go - DW FAQs, Tutorials & Resources
              http://www.dwfaq.com - DW FAQs, Tutorials & Resources
              ==================


              "phrarod" <webforumsuser@macromedia.com> wrote in message
              news:gb8bac$6vs$1@forums.macromedia.com...
              > Guilty of #4. Figured it out at 2AM.
              >
              > Thanks Murray