7 Replies Latest reply on Jun 3, 2009 12:46 PM by gdl276s

    Contribute 3 Not Publishing Changes

    Pomtree

      Hi, I'm having a new problem that has never manifested before. I'm using Contribute 3 on Mac OS 10.5.7. I'm trying to edit a page on my website and am the Contribue Administrator, thus have publishing rights..

       

      1. I browse to page in Contribute and click "edit Page."

      2. I make my changes.

      3. I click "Publish."

      4. I am greeted with dialogue box which reads "Congratulations! Your changes to (Website name) have been published to the website.

      5. I click OK to close box.

      6. Contribute automatically leaves edit mode and browses to page I just modified to show me changes.

      7. There are no changes. Everything is the same.

      8. Frustrated, I try this again and click "Edit page."

      9. My entire edit is still intact.

      10. I try publishing again--same result.

       

      I'm lost and this seems the simplest detail. I've always been able to make these changes before this week. I'm connecting to my server correctly, so that's not the problem.

       

      Anyone with an idea how to guide me should be prepared to kneel and receive an honorary knighthood. A breathless nation awaits your word of knowledge.

        • 1. Re: Contribute 3 Not Publishing Changes
          gdl276s

          Couple questions ...

           

          1. Have you tried verifying changes in a browser?  If so, are the URLs the same?
          2. Are you using Contribute Publishing Server or Connection Keys?
          3. Have you tried pressing F12 to review your changes before publishing?  Does this show your changes?
          4. What protocol are you using to write to the website ... FTP? WebDAV? Local?
          5. Do you have write permissions to the directory you are writing to?

           

          I might have a better idea after these questions are answered.

          • 2. Re: Contribute 3 Not Publishing Changes
            mistresscra

            Here is something simple to try:  when you go to verify changes in your main browser, hit refresh.  Sometimes you are looking at the old version without knowing it even though it has been updated on the server.

            • 3. Re: Contribute 3 Not Publishing Changes
              jorgepelaez

              I'm having the same problem.

               

              I'm using SFTP, connection keys and write permissions.

               

              I see that my changes are there when I click on edit page but not published.

               

              Any advice is more than welcome.

              • 4. Re: Contribute 3 Not Publishing Changes
                gdl276s Level 1

                Sounds like it is a problem with the configuration of your connection key.  Just a guess.

                • 5. Re: Contribute 3 Not Publishing Changes
                  jorgepelaez Level 1

                  Thank you for the quick answer, any idea to fix this?

                  • 6. Re: Contribute 3 Not Publishing Changes
                    Pomtree Level 1

                    I'm happy to report  the successful solving of my own problem. After weeks of frustration, assuming the issue was Contribute 3, I paid a tech guy tp troubleshoot the issue. Turns out it was very simple (of course) and no fault of Contribute's. My server company which has my website had, at some point, moved my website from one server to another. WITHOUT NOTIFYING ME! In **** so, Contribute was trying to authenticate to the OLD IP address while my website was residing at the NEW IP address. The tech guy figured this out in five minutes.

                     

                     

                    All's well that ends well, I guess. Thanks for the many suggestions this forum offered. None of them worked for obvious reasons, but your efforts are deeply appreciated.

                     

                    So store this problem and its resolution in Contribute's knowledge database for future generations: If you can't publish your changes, perhaps your Internet company moved your website to a new server without the courtesy of a notification.

                    • 7. Re: Contribute 3 Not Publishing Changes
                      gdl276s Level 1

                      Well that is extremely frustrating.  Glad to hear it's fixed now.  Happy publishing!