4 Replies Latest reply on Jun 30, 2009 7:04 AM by GrumpyJoe

    cfdocument to cfpdf bug?

    GrumpyJoe

      Hi all,

       

      I've got a generated cfdocument that I can push to the user with a cfheader/cfcontent combo, but just before I do that I tried to pass the PDF variable (conflict_pdf) to the cfpdf tag, both with and without ## inside the 'source=' attribute for that tag.  CFMX8 docs say I should be able to pass the pdf variable into cfpdf and then perform actions on it (I'm trying to use setinfo to set keywords etc).

       

      I've seen cfpdf work on files read from disk but no examples outside the CFMX8 docs that work directly on in-memory PDF.  Is this a known bug?

       

      I get a variation on 'cannot convert' errors every time I try it.

       

      Error I get when passing in source='#conflict_pdf#' =

           ByteArray objects cannot be converted to strings.

       

      Without ## =

      Error casting an object of type [B cannot be cast to java.lang.String to an incompatible type.  This usually indicates a programming error in Java, although it could also mean you have tried to use a foreign object in a different way than it was designed.

      [B cannot be cast to java.lang.String