4 Replies Latest reply on May 25, 2009 3:58 PM by cv164

    Problem with SWF playback in Director 11.5

    cv164

      Hello, I have a rather vexing problem that I can't seem to wrap my head around, nor find any mention of in the docs or google.

       

      I have a video file imported (SWF) and have a simple behaviour set up so that when the user clicks a button, it jumps 10 seconds forward in the video. I am using this script to make that happen:

       

          currentframe = sprite(5).frame + 150

          sprite(5).gotoframe (currentframe)

       

      The video is 14 minutes long, and runs at 15fps.

       

      The 'skip forward 10 seconds' button works perfectly, until I reach 10 minutes (9000 frames). At this point pressing the button causes the video to start playing from the beginning. Heres the weird bit: if I *don't* press the button, and just let the video play, it continues past the 10 minute mark with no issues. But at any point after 10 minutes if I click the button, the video rewinds to the beginning.

       

      The property inspector for the cast member shows that it contains 9000 frames, which is consistant with what sprite(5).framecount reports. But obviously the video contains *more* than 9000 frames, as director is able to play them. I have tried continuously polling the sprite using sprite(5)frame to see whats happening, and if I just let the video play without skipping forward, it reports frames past 9000 no problem.

       

      I am aware of the 16000 frame limitation on flash video, as I have run up against it before, but I can't seem to find any mention of a 9000 frame limitation, or a 10 minute duration limitation, or anything of the sort.

       

      Looping mode is off for the member, and I have tried DTS on and off, and have turned off all other scripts in the movie. And yet the anomalous behaviour persists. Any insight/suggestions would be very much appreciated, as I am up against a deadline. I am prepared to break the file into 2 parts if necessary, but would very much like to avoid it for various reasons.

       

      Joshua

        • 1. Re: Problem with SWF playback in Director 11.5
          Sean_Wilson Adobe Community Professional

          I suggest you create as small a file as possible that demonstrates this issue, and get in touch with Allen Partridge (Director Evangelist for Adobe): allenp@adobe.com

          Feel free to post a link to your file here, as I'd like to take a look too. Which codec is your video encoded with?

          • 2. Re: Problem with SWF playback in Director 11.5
            cv164 Level 1

            Thanks for your reply, Sean. Because of my deadline, I've had to go ahead with the project using a work around for now (movies segmented at 10 minutes), but I will put together a demo movie this weekend once its done. I am still very eager to solve this issue, not just because I will be running into it again very soon, but also because I love/hate a mystery.

             

            I suspect the issue is that some part of Director is only registering 9000 frames of the video file, so while it can play past the 9000 frame mark, any lingo executed that refers beyond 9000 resets the movie to the beginning. I have a strong feeling that the fact that both the framecount method and the property inspector report all movie clips to contain 9000, even though NONE of them contain that many frames (some more, some less), has a lot to do with this.

             

            The video is flash video (SWF), btw. 

             

            Interesting Note: These clips are all 15fps. When I bring in 30fps clips, property inspector (incorrectly) reports them all as having 18000 frames. Buh.

             

            Joshua

            • 3. Re: Problem with SWF playback in Director 11.5
              Sean_Wilson Adobe Community Professional
              The video is flash video (SWF), btw.

              I think you misunderstood my question. How did you encode the FLV - did you use Sorenson Sparc, On2 VP6 or H.264 (MPEG-4)?

              • 4. Re: Problem with SWF playback in Director 11.5
                cv164 Level 1

                Oops, yeah.

                 

                I used ffmpeg without specifying a codec, so it likely defaulted to Sorenson H.263 (as per ffmpeg man). I'm not at work anymore, so I can't check right now.

                 

                I'll do a quick test tomorrow and see if using a different codec makes a difference.

                 

                Joshua