5 Replies Latest reply on May 22, 2009 10:34 AM by Peter Grainge

    Why would a redirect not work?

    M.aria Level 1

      In what cases would the redirect not work? It worked for some of my topics that had multiple calls from the TOC but inexplicably, completely ignores the redirect for others. It's baffling because the redirects are exactly the same, those that work and those that don't. Any ideas as to what would cause this?

       

      Thanks again,

      Maria

        • 1. Re: Why would a redirect not work?
          Peter Grainge Adobe Community Professional (Moderator)

          Just saw the picture, my goodness, now I know what happens to all the crusts of those crustless loaves of bread. You've been eating them!

           

          Are the topics where the redirect is not working at a different folder level to the ones where it works? If so, did you change the relative path by adding / removing ../ as necessary. Also are you using forward slashes?

           


          See www.grainge.org for RoboHelp and Authoring tips

          • 2. Re: Why would a redirect not work?
            M.aria Level 1

            Sorry, I am not sure that I understand what you mean. I'm creating a redirect topic and implementing the <meta HTTP-EQUIV=refresh CONTENT="0;URL=First_Topic.htm"> from Rick's Tips and Tricks. Does the TOC folder level matter in this case?

             

            And bread crusts?   I must be reallly slow today.

            • 3. Re: Why would a redirect not work?
              Peter Grainge Adobe Community Professional (Moderator)

              The redirect as shown will only work if the topic it is in, is in the same folder as the topic to which it is pointing. Otherwise you need to create the relative path. If you are not sure about that, speak to your developers or come back here.

               

              You obviously haven't heard the old wives tale about eating your crusts to make your hair go curly. http://health.ninemsn.com.au/article.aspx?id=694037

               


              See www.grainge.org for RoboHelp and Authoring tips

              • 4. Re: Why would a redirect not work?
                M.aria Level 1

                Do you mean the same TOC folder? Or project folder? Because all the topics are in the same project folder. I thought it was simply a case of pointing to another topic in the help file. I looked in the Tips and Tricks file again and it doesn't mention anything about folders.

                 

                So, you're saying that the <meta HTTP-EQUIV=refresh CONTENT="0;URL=First_Topic.htm"> has to look more like <meta HTTP-EQUIV=refresh CONTENT="0;URL=.../First_Topic.htm"> or something like that? And you have to specify this for the TOC link?

                 

                I don't know if it was me that ate all those bread crusts but my parents were Italian and I know my mom ate a lot of bread.

                • 5. Re: Why would a redirect not work?
                  Peter Grainge Adobe Community Professional (Moderator)

                  If all your topics are in the same folder, then it is just a case of putting in the name of the file you want. You could try preceeding it with ./ (a single dot followed by the slash).

                   

                  I heard your parents were Sicilian.

                   

                  Long time since I went to Taormina and up Etna, after driving down from Sorrento on the coast road, the autostrada hadn't been built then!

                   


                  See www.grainge.org for RoboHelp and Authoring tips