2 Replies Latest reply on Jul 26, 2006 3:35 PM by burbankbiker

    Is Adobe's Basic Tutorial Broken?

    burbankbiker
      I've installed Flex Builder 2, Data Services with Integrated JRun, and gone through the sample applications which all work beautifully (suggesting that everything installed correctly). However, when I try to do the tutorials on creating FDS applications such as this one, it doesn't work. I get an error on load, which I'll type below. In the tutorial it has you create a destination in your data-management-config.xml file which I've done and all looks fine there. I've checked and rechecked and I can't figure out where I could be going wrong. Does this error message mean anything to anyone? Thanks.

      [RPC Fault faultString = "Send failed" faultCode="Client.ErrorMessageSend" faultDetail="Channel.Connect.Failed error null"]
      at.mx.data::ConcreteDataService/ http://www.adobe.com/2006/flex/mx/internal::dispatchFaultEvent()
      at::DataListRequestResponder/fault()
      at mx.rpc::AsyncRequest/fault()
      at mx.messaging::ChannelSet/::faultPendingSends()
      at mx.messaging::ChannelSet/channelFaultHandler()
      at flash.events::EventDispatcher/dispatchEvent()
      at mx.messaging.channels::PollingChannel/mx.messaging.channels:PollingChannel::connectFailed ()
      at mx.messaging.channels::RTMPChannel/mx.messaging.channels:RTMPChannel.statusHandler()
        • 1. Re: Is Adobe's Basic Tutorial Broken?
          Peter Farland Level 3
          Did you specify a --services command line configuration parameter? Is it pointing to the correct services-config.xml file? Do any of the channel endpoints use uris that have tokens in them? If so, do you have a {context.root} token in there? If so, did you specify --context-root=/yourcontextpath in the command line params too? Did you try a clean rebuild after saving each change to the configuration file to ensure the swf was recompiled?
          • 2. Re: Is Adobe's Basic Tutorial Broken?
            burbankbiker Level 1
            I got it working. Thanks for the suggestions. i think your last idea was the cause. I hadn't rebuilt after making changes to the config files. But I'm not sure that's what solved it because I also uninstalled and reinstalled and redid all the configs from scratch. All-together, it solved it and I'm on my way to learning ColdFusion, Flex, and Data Management Services!

            Thanks again!