2 Replies Latest reply on Mar 3, 2010 12:12 PM by rtalton

    Flex app loads initial view, but no other (blank screen)

    speedy_man

      Hi all!

      I've gotten reports from both a Mac/Safari/Firefox user and a pc/Firefox/Internet Explorer user of a strange problem.

      After going to the web site: https://www.anaheimjobs.com/, the Flex application loads and they see the initial view just fine, with all its components and animations.

      If they then click on any visible navigation component (accordion, menubar, etc.) they get a completely blank screen in the browser, although the address bar updates to show the correct navigation destination (using deep linking in the app).

       

      I was able to fix the problem on the pc user's machine by uninstalling the plug-in and activeX control, then re-installing both. Before that, I tried deleting the Runtime Shared Libraries and the shared objects cache--neither worked to fix the problem.

       

      Has anyone ever seen this problem or know how to prevent it?

       

      Thank you for any advice or help.

        • 1. Re: Flex app loads initial view, but no other (blank screen)
          *Prashant Shelke* Level 4

          I faced this issue in some other way. After doing any change to mxml & given hit to URL, so sometimes it shows some progress but at last "Done" at bottom left & screen is blank.


          I used to close browser remove all history/ cookie/ saved information from FireFox(ctrl + shift + del) & then url succeds to load site.


          You can try one thing from WEB-INF\flex\services-config.xml

               <channels>
                  <channel-definition id="my-amf" class="mx.messaging.channels.AMFChannel">
                      <endpoint url="http://{server.name}:{server.port}/{context.root}/messagebroker/amf" class="flex.messaging.endpoints.AMFEndpoint"/>
                      <properties>
                         <add-no-cache-headers>false</add-no-cache-headers>
                          <polling-enabled>false</polling-enabled>
                      </properties>
                  </channel-definition>

               ..........

          Hope this will work for you,


          Thanks.



          • 2. Re: Flex app loads initial view, but no other (blank screen)
            rtalton Level 4

            *bump*

            Still no resolution to this issue. Searching the web provides other similar examples of the same issue, but no way of fixing it.