11 Replies Latest reply on May 27, 2009 11:20 AM by Harm Millaard

    PP CS4: Error compiling movie. I/O Error

    Dodomeki

      I get this incessant I/O error any time I try to export a movie, regardless what format or

      codec I am exporting to. I've tried this on a BRAND NEW Project with the same result.


      I'm almost convinced that it's a problem or issue with Adobe Media Encoder? I tried to

      export a GIF image with the result of:

       

      ---------------------------------------------------------------
      Error compiling movie.

       

      Unable to create or open output file.
      ---------------------------------------------------------------

       

      Just five seconds ago, this is seriously driving me up a wall as I have my projects due

      very very soon. ANY help would be greatly appreciated.

       

      -jd

        • 1. Re: PP CS4: Error compiling movie. I/O Error
          Harm Millaard Level 7

          Sorry to disappoint you, but I'm almost convinced it is OE. Hard to tell without details however.

           

          If you need help quickly...Guideline for posting an effective question

          • 2. Re: PP CS4: Error compiling movie. I/O Error
            the_wine_snob Level 9

            The "I/O Error," is telling you that something is not quite right with your I/O sub-system. This could be the controller, the HDD's, the cables, or how your OS is addressing the I/O sub-system.

             

            Along with the questions that require answers in Harm's post, the first two places that I would look for possible issues would be:

             

            Event Viewer - check the System tab for errors and warnings. Dbl-click on all of these. Follow any links that might be provided.

            Event Viewer - check the Application tab. Same as above.

             

            Note: the list in each will be long. You only need to look at the errors and the warnings. If you can reproduce this error message, do so and then see Event Viewer, as this will get your errors and warnings up at the top of the list, and you do not have to wade too deeply into the log.

             

            Next:

             

            Control Panel>System>Hardware>Device Manager. Expand every possible section there, and explore all of your I/O, controllers, HDD's, your multi-drives, anything remotely related to your I/O. Does every piece of hardware check out? Any errors or warnings showing?

             

            The results of these two searches, plus the requested info in Harm's link might give someone a real clue as to what could be causing your error.

             

            Good luck,

             

            Hunt

            • 3. Re: PP CS4: Error compiling movie. I/O Error
              Dodomeki Level 1

              @ Harm Millaard

              I'm not really sure what you mean by OE? Are you saying that its something to do with my hardware?

              I had this running great in the past, before we changed buildings, I fired it up today to do some work

              and no dice.

               

              I insert a video, drag it to my time line, file > export and any option therein is wrong. The only thing I've

              been able to export as is a static GIF, no AVI or etc....?

               

               

              @ the_wine_snob
              Actually I already did check out my Event Viewer prior to post, it came out with a clean bill besides

              a few issues with my network not being able to update its dynamic ip (does not effect, has been doing

              it for ages.) I used to be a computer tech so it was the first thing that I looked at. As for addressment

              errors with hardware issues I'll have to wait until I get back to work tomorrow in order to check those

              and make sure that I'm still running a tight ship.

               

              I can tell you BOTH though that I am running a custom built Graphics Workstation put together by

              me with no expense spared. I am running a Quadcore w/ 4gb high latency ram, and a 10k rpm hdd.

              I believe that if there's a problem it would show itself in my other Adobe apps, and PS and AI seem

              to scream, as well as After Effects, EnCore and other resource intense Master Suite apps.....?

               

              This really has me scratching my head, I'm wondering if a full reinstall might be in order......

              • 4. Re: PP CS4: Error compiling movie. I/O Error
                the_wine_snob Level 9

                Harm was joking. What he wanted to get across was that without as much info as possible, it would be impossible to diagnose the problem. Remember, we're sitting at our computers, maybe thousands of miles away. That means that you have to be our eyes and our ears.

                 

                Harm's list of questions is a very good one. I point many to it, and from dozens of other fora, because of its worth. I also added a couple of things that are also important and might not be covered specifically in Harm's list, though it touches on almost everything. The better that you can fill in that list, the more likely that someone will spot your problem and possibly instantly. That's what you want. It is also what we want - happy users with a copy of PrPro that does everything that it can possibly do.

                 

                Looking forward to the answers, and people can get busy helping you sort things out - hopefully.

                 

                Good luck,

                 

                Hunt

                • 5. Re: PP CS4: Error compiling movie. I/O Error
                  Dodomeki Level 1

                  Sorry, I am honestly trying to be as specific as I can but I'm unfortunetly not affluent with the program to say that green is red + blue because.... All that I know is that when I try to export (in any codec, or no codec processing) it throws me IO errors. I'm using digital avi's that were captured via a unnamed 5mp camera. No codec processing was applied to my knowledge and they are raw from the camera. In Process Explorer, my RAM and VRAM are within bounds when running PP (~750mb/~1.2gb), and without a large process overhead for cpu (+/- 30% load). My computer is and was built to do this, and has worked perfectly in the past, that's what gets me.

                   

                  Is there a possibility that a network (addition to / removal from) would cause problems? I know that I was NOT on a network until recently, and recently

                  was when I had these problems. Just trying to track it down by event. I am able to give full disclosure of hardware tomorrow (I can't remember it right now) with a disclosure from CPUZ and DirectX Diagnostic tool.

                   

                  Until then though, and (even general) guessing would help me since I do not have an affinity yet with the program.

                   

                  -jd

                  • 6. Re: PP CS4: Error compiling movie. I/O Error
                    the_wine_snob Level 9

                    Depending on how networking is set up, it can certainly cause problems. The details of this aspect will be very important. As Harm uses more networking than most of us, he'll be a good person to look over those specs.

                     

                    As for the Assets, you comment on "5MP camera," gives me pause. Though this might have no bearing on the I/O error issue (can't see where it would), I'd strongly suggest that you run one, or more, of these files through G-Spot. This will give you all of the details on those particular files, plus it will survey your system and will tell you if you have the necessary CODEC's properly installed on your system. This info can help you down the line. Also, no NLE computer should be without this little utility. It's also nice that it's freeware. Even if you ONLY deal with DV-AVI Type II files, at some time you will use this program.

                     

                    Now, back to your error message. Please tell us about your HDD setup. This is your I/O subsystem (sans controllers). The biggest things to look for will be the # of HDD's, how they are being utilized and also how much defragmented free space you have on each. Knowing how they are allocated, plus this last bit, will tell us of any significant bottlenecks. Please be very specific with this data. Go into as much detail, as is necessary. Things like internal, external, connection, etc. can be very important.

                     

                    Since you say that this error comes up with new, un-populated Projects, I'd put the Assets down the list, though they could be problematic later on.

                     

                    Good luck,

                     

                    Hunt

                    • 7. Re: PP CS4: Error compiling movie. I/O Error
                      Harm Millaard Level 7

                      The unnamed 5 MP camera is the first problem. The camera is a digital STILL camera, not a video camera. The codec used within that AVI wrapper is likely the cause of your problems. As Hunt suggested, use GSpot to identify the codec inside the AVI wrapper. Likely it will be MJPEG or something similar, which may require installation of additional codecs.

                       

                      What project/sequence settings did you use? What export settings? On which OS?

                       

                      For the IP problem, did you go to the command prompt and from the 'Dos' screen type in the command: IPCONFIG /RELEASE and then IPCONFIG /RENEW. That should solve the IP adressing problem.

                      • 8. Re: PP CS4: Error compiling movie. I/O Error
                        Harm Millaard Level 7

                        I had this running great in the past, before we changed buildings, I fired it up today to do some work

                        and no dice.


                        Are you saying that your custom built graphics workstation is getting homesick

                         

                        Seriously, from the looks of it, the source material, in combination with sequence settings and export settings are the cause of your problems. You can try if a normal MS DV AVI type2 video file gives you the same problems when you use a standard DV sequence setting. That way we can concentrate on the source material from the unnamed camera if everything works with normal video material.

                         

                        If I misunderstood that you were having problems with IP adressing, disregard my remarks about IPCONFIG. Maybe I misread IP where it meant IO.

                        • 9. Re: PP CS4: Error compiling movie. I/O Error
                          Dodomeki Level 1

                          I think my computer is Home sick, I like this new office window, but I don't think it appreciates

                          all the glare from the sun (course I don't either at times, lol). I attatched

                           

                          Full disclosure of my work computer.

                           

                          Drive is a SINGLE Western Digital 300GB VelociRaptor (SattaII / 16MB Buffer / 10K RPM)
                          Card is a SINGLE NVIDIA GeForce 9500 GT (1GB GDDR3), I took out of the other one to
                          install on a diff computer about 9mths ago. (Work Post/Prior SLI).

                           

                          DX Diag read out is attatched in txt format

                          CPUZ / GSpot / ProcExp is in JPG format

                           

                           

                          I'll post again in a minute with a full disclosure of your questions above. I just wanted to get

                          this stuff out first.

                           

                          -jd

                          • 10. Re: PP CS4: Error compiling movie. I/O Error
                            Dodomeki Level 1

                            There shouldn't be any bottlenecking in my system I'm running
                            SATAII / 3GB transfers. I'm utilizing my harddrive on a per
                            project basis, then immediatly removing it from there and
                            uploading it to my server (X:) for others to work on or to use.
                            My HDD DOES fragment fast because of this and I Defrag it at
                            least once a week. I missed out yesterday do to complications
                            but what you see in the frag.jpg is one week worth of fragments.
                            Ouch huh? lol.

                             

                            I checked the wrapper for the avi and it looked ok I'd guess?
                            Fully compliant MPEG-4 v2? Like I said before. I've used these
                            videos in the past. I very highly doubt that they "All of a
                            sudden" started giving me problems, I've used the same source
                            files in the past. The only thing I could think of is if they
                            are corrupted. I have over 3k videos though from the same
                            source, and tried atleast 50~ different ones yesterday, even
                            some of my old projects with the same video source and got the
                            same problem.

                             

                            I'm not sure how the same thing can work ONE day, and the next
                            not at all. I am very curious, I know when this computer got on
                            a network I had a ridiculous amount of things disallowed. Prior
                            to gaining admin rights. There are STILL things that are locked
                            on this. I'm wondering, honestly, if there is some vital part
                            of my computer that has an access restriction against it....?

                             

                            I think that this is a very important thing to think over, and
                            will have to talk to the tech who installed the network, and
                            who also grants / denies policies. I am with Admin rights now,
                            but....? Like I said, there are still parts of my computer I
                            cannot access (C:\combofix\ being one of them).

                            • 11. Re: PP CS4: Error compiling movie. I/O Error
                              Harm Millaard Level 7

                              Your video driver is from december last year. I assume there are newer versions available.

                              You have only 1 hard disk. The common rule is to use at least 3 hard disks for editing.

                              You have Nero fully installed, including all the unnecessary parts, putting a large drain on system resources.

                              You have Zune installed, plus all kinds of Canon, HP and other direct show filters.

                               

                              If it used to work, ask yourself what has changed in terms of software (not the relocation to a new building) that can cause this.

                              You can try to (temporarily) remove Nero, Canon, HP, Line21, Zune, Infinite Pin Tee and other direct show filters and see if that helps.