7 Replies Latest reply on Jun 2, 2009 12:39 PM by MergeThis

    RoboHelp Error during compilation

    she2009

      The following error occurred while trying to 'generate primary layout':

       

                htmlproc.cpp(114) : Assertion failure: (pszTmp == m_pCompiler->m_pHtmlMem->psz)

       

       

      Does anyone know what this means?  Or what I need to do to fix it so that I can move forward with this project.

       

      Any help would be greatly appreciated!

       

      Thank you!

        • 1. Re: RoboHelp Error during compilation
          RoboColum(n) Level 5

          This post and the error suggests the problem is with the HTML help compiler. Is the output path you are using long? If so, try a shorter path.

           


          Read the RoboColum(n) for mutterings on RoboHelp, Technical Communication Suite and technical communication.

          • 2. Re: RoboHelp Error during compilation
            she2009 Level 1

            Ok, so I took a look at my output path and it is as short as the system allows....C:\main\...

             

            Next I was contacted by email with the suggestion to download and isntall the newest HTML Help Compiler from the MSDN website.  I did this and it compiled once yesterday afternoon, before calling it a day.  I was so excited and thought my problems were over.

             

            Ok, so reality set in this morning.  It is back to the same error message that was given in the original post I made yesterday.

             

            As I make small tweaks trying to find the problem.  I try to regenerate the primary layout.  Each and every time the error occurs when the 'Output View' shows :

             

            ' Filename_3.2.hhk '

             

            as the last thing prior to the error message being sent to the C:/

             

             

            So....I have went into the  !chm_tmp_folder_1  each time I have tried to recompile to see if something is missing between when it worked and when it didn't.  I see nothing to my untrained eye that sticks out, even though I am sure there is some clue.  Maybe this is the wrong place to be hunting down the error?

             

            Would anyone have any ideas on this one?

             

            Greatly appreciate any help!  Thank you!

             

            Sherry

            • 3. Re: RoboHelp Error during compilation
              MergeThis Level 4

              If your project is named Filename_3.2 (based on the hhk file you mentioned), I'd try File > Rename Project, and get rid of the "." in "3.2". That can't be good...

               

               

              Good luck,

              Leon

              • 4. Re: RoboHelp Error during compilation
                she2009 Level 1

                It doesn't appear that changing these files makes any difference.  When Robohelp tries to compile, it is actually creating these files with the underscores as this is not something that I named in this syntax.

                 

                I thank you for suggesting looking into this, however does anyone else have any other suggestions?

                 

                I would greatly appreciate any help.

                 

                Thank you!

                Sherry

                • 5. Re: RoboHelp Error during compilation
                  MergeThis Level 4

                  There are two issues here:

                  • If your project is named "Filename 3.2", RH is substituting the space with an underscore.
                  • The dot should also be removed: there should only be one dot in file names (your example: Filename_3.2.hhk).

                   

                   

                  Good luck,

                  Leon

                  • 6. Re: RoboHelp Error during compilation
                    she2009 Level 1

                    I have changed the filenames so the syntax is as suggested. This did not change the error messages tha I am obtaining.

                     

                    Any other possible thoughts? 

                     

                    Greatly appreciated

                    Thank you,

                    Sherry

                    • 7. Re: RoboHelp Error during compilation
                      MergeThis Level 4

                      You say you "changed the filenames." Which ones?

                       

                      The proper way to do this is to rename the project from within RH (File > Rename Project menu option). Any other method will be ineffective.

                       

                      edit:

                      Another thing to try would be creating an entirely new SSL (different name, different location). Sometimes that jars something loose from the jaws of RH.

                       

                       

                      Good luck,

                      Leon