1 Reply Latest reply on Jul 4, 2009 4:09 AM by dratndarn

    Known issue publishing to SCORM 1.2?

    dratndarn Level 1

      Are there any known problems with publishing to SCORM 1.2 from Captivate 3?


      Reason for asking: I published to SCORM 2004, but my client ran into some issues when they ran it through the ADL's test suite for SCORM 2004 v3. I researched here and it seems like it was a known issue with a potential work-around. I posted here to get further info/advice, but did not receive any response.


      Meanwhile, my client now suggests publishing for SCORM 1.2 instead just to expedite things. Before I say 'yes, this is doable,' I want to find out if there are any known issues for that version.


      Further, I will upgrade later to Captivate 4. Anything I should know about how the new version performs against the ADL's testing tools for various SCORM versions?


      Thanking you muchly!

        • 1. Re: Known issue publishing to SCORM 1.2?
          dratndarn Level 1

          The following response came from offline discussion with Duncan Rosie, who had researched it earlier and attempted to post the solution here.


          Thank you Duncan! You saved my hide!


          Now the solution – this came from Andrew Chemey, one of Adobe’s Community Experts.

          The “LMSInitialize() never invoked” problem is with the Adobe Flash Player security sandbox.  Flash Player (later versions like 7 and above) prevent by-default, Flash-based files from communicating to JS (the HTM wrapper) when launched locally (e.g. if you double-click on an HTM file from your desktop). 

          To get this to work the Flash security settings need to be changed:

          1.                   Launch *any* Flash-based file in a browser (e.g. double-click on an HTM file that contains a reference to a SWF file).

          2.                   Right-click on the Flash file

          3.                   When the short-cut menu appears, click on "properties" – this is Flash version dependent, the pop-up may say “settings”.

          4.                   Click the "advanced" button in the properties pane.  This should open a new browser to Adobe.com

          5.                   Click the "Global Security Settings" link on the left-side of page.

          6.                   In the security settings panel, click the "Always Allow" radio button; and

          7.                   Click the drop-down arrow next to "Edit Locations".  Select the "Add Location" link

          8.                   In the text entry pane - manually type the location (I am assuming that in your case it will be to the server where the material is run from, for me it was my local hard drive).

          9.                   There is no Save or Confirm – I browsed through the other settings and came back to Global Security Settings and the settings were retained.

          10.               Close all browsers and relaunch the content from the ADL Test Suite.