0 Replies Latest reply on Jun 4, 2009 5:35 AM by cksachdev

    compc not putting component to swc

    cksachdev Level 1

      Hello everyone,

      I am trying to put some component to a swc and I am facing issue with it. Here is what I tried:

       

      <compc output="bin/monkey.swc" locale="en" accessible="true" fork="true">
             <source-path path-element="src" />
             <target-player>10</target-player>
             <debug>true</debug>
             <library-path />
             <external-library-path dir="${FLEX_HOME}/frameworks/libs" >
                
             </external-library-path>
             <include-classes>mx.controls.Button</include-classes>
      </compc>

       

      I am trying to put a Button into the swc. For more details you can have a look at

      http://www.jamesward.com/blog/2009/03/10/flex-monkey-patching-and-framework-rsls/

      and

      http://bugs.adobe.com/jira/browse/SDK-19735

       

       

      This issue is marked resolved but I get the following error:

      Error: could not find source for class mx.controls:Button.

       

      (I also tried putting up all swc files inside external-library-path too.)

      <include name="player/${global.playerglobal.version}/playerglobal.swc" />
      <include name="flex.swc" />
      <include name="flex4.swc" />
      <include name="framework.swc" />
      <include name="rpc.swc" />
      <include name="sparkskins.swc" />
      <include name="textLayout.swc" />
      <include name="utilities.swc" />

       

      Am I doing something wrong here ?

       

      Note: I tried building with Prerelease, Beta and Latest updated sdk.

       

      --

      Best Regards;

      Chetan Sachdev