4 Replies Latest reply on Jun 6, 2009 10:36 AM by voxL

    Turbulent Displace won't render

    voxL Level 1

      Hi all:

      I've applied the turbulent displace plugin to a layer.  It shows up when I drag thur the timeline, but it doesn't render in previews nor when I render the movie.

      AE CS3.  WinXP x64, QuadCore.

      Any suggestions?

      Thanks.

        • 1. Re: Turbulent Displace won't render
          Mylenium Most Valuable Participant

          What kind of footage are you exactly displacing? What settings do you use? Are there any animated parameters in the footage? Do you by any chance use OpenGL for previews and rendering?

           

          Mylenium

          • 2. Re: Turbulent Displace won't render
            voxL Level 1

            I'm just displacing a bitmap by animating the "evolution" parameter.

             

            You hit the nail on the head.

            I had OpenGL turned off because I was getting a "After Effects error: AE_OpenGL: Failed display color channel 5065 :: 0".

            When I re-enabled OpenGL, the turbulence previews and renders.

            So we have a catch 22 situation.  OpenGL errors or turbulence....

            Do you know if there is a way to render the turbulence w/OpenGL turned off?  I haven't encountered this issue w/any of the other filters thus far.  As evidenced by other threads in this forum & on the web, AE and OpenGL don't have a great relationship.

            Thanks much for pointing me in the right direction.

            • 3. Re: Turbulent Displace won't render
              Mylenium Most Valuable Participant

              Mmh, the effect should as a matter of fact render without OpenGL. If it doesn't, then something is up. The way I see it, AE thinks it can use OpenGL because the driver tells it so and it initializes the routines, but the actual processing of commands fails. What graphics card do you have and what driver version? If you can, try to install a different driver/ the latest driver. Also double-check your AE prefs. Setting the Accelerate Effects Using option to Adaptive Resolution should effectively hide any pixel shader features from standard effects and only use OpenGL in 3D comps....

               

              Mylenium

              • 4. Re: Turbulent Displace won't render
                voxL Level 1

                Once again you nailed it.

                Setting the Accelerate Effects Using option to Adaptive Resolution and turning off OpenGL does the job.

                I have a Quadro FX 4600.  Drivers are "ForceWare" v 176.04.

                They probably aren't the latest, but one of the reasons I don't updgrade is that they've been very stable w/AE.

                Some versions of the drivers bring just the simple interface of AE to a crawl:

                http://forums.adobe.com/message/1786744#1786744

                 

                Now that I've discovered that OpenGL can be turned off, I might upgrade the vid drivers more frequently.

                Thanks very much for your quick, helpful response!