2 Replies Latest reply on Jun 7, 2009 10:09 PM by webguy5612

    Multiple effects

    webguy5612

      Hello, I'm trying to run multiple effects in different areas in my app. I'm not getting any errors but its not working. Can some help me? Here is my code

       


      <mx:Move id="showeffect2" yFrom="300"/>
      <mx:Move id="hideeffect2" yBy="600"/>
      <mx:Fade id="fadeOut" duration="1000" alphaFrom="1.0" alphaTo="0.0"/>
      <mx:Fade id="fadeIn" duration="1000" alphaFrom="0.0" alphaTo="1.0"/>

       

      <mx:LinkBar color= "#FFFFFF" height="28"  dataProvider= "{tabNav}" backgroundColor="#e489cd"  borderStyle="solid" width="867" borderColor="#FFFFFF" selectionColor="0xffffff" separatorColor="0xcccccc"  rollOverColor ="0xe489cd" textRollOverColor="0xcccccc"  textSelectedColor="0x000000" x="100" y="28"/> 
          
      <mx:ViewStack id="tabNav" borderStyle="solid" width="867" height="485"  x="100" y="75">
      <mx:VBox id="Home" backgroundImage="@Embed(source='assets/HBoxmain.jpg')" showEffect="showffect2" hideEffect="hideeffect2" horizontalAlign="center" verticalAlign="middle" label="Home"  width="100%" height="100%" borderStyle="solid"  borderColor="#FFFFFF" >
            
             <mx:TextArea id="textArea" width="424" height="296" paddingTop="130" paddingBottom="100" backgroundImage="@Embed(source='assets/textareahome.jpg')"   borderColor="#FFFFFF"  borderStyle="solid" borderThickness="2" color="#FFFFFF"  backgroundColor="#e489cd"   shadowDirection="" wordWrap="true"   horizontalScrollPolicy="off"   fontSize="18" textAlign="left" verticalScrollPolicy="on" editable="false" >
                 
                 
      </mx:TextArea>       
      <mx:Image source="@Embed('assets/Text.png')" hideEffect="{fadeOut}" showEffect="{fadeIn}" >

        • 1. Re: Multiple effects
          Michael Borbor Level 4

          You have to use a parallel or a sequence of effects in order to play

          them at the same time or one after another.

          2009/6/7, webguy5612 <forums@adobe.com>:

          >

          Hello, I'm trying to run multiple effects in different areas in my app. I'm

          not getting any errors but its not working. Can some help me? Here is my

          code

          >

          >

          <mx:Move id="showeffect2" yFrom="300"/>

          <mx:Move id="hideeffect2" yBy="600"/>

          <mx:Fade id="fadeOut" duration="1000" alphaFrom="1.0" alphaTo="0.0"/>

          <mx:Fade id="fadeIn" duration="1000" alphaFrom="0.0" alphaTo="1.0"/>

          >

          <mx:LinkBar color= "#FFFFFF" height="28"  dataProvider= ""

          backgroundColor="#e489cd"  borderStyle="solid" width="867"

          borderColor="#FFFFFF" selectionColor="0xffffff" separatorColor="0xcccccc"

          rollOverColor ="0xe489cd" textRollOverColor="0xcccccc"

          textSelectedColor="0x000000" x="100" y="28"/>

          >

          <mx:ViewStack id="tabNav" borderStyle="solid" width="867" height="485"

          x="100" y="75">

          <mx:VBox id="Home" backgroundImage="@Embed(source='assets/HBoxmain.jpg')"

          showEffect="showffect2" hideEffect="hideeffect2" horizontalAlign="center"

          verticalAlign="middle" label="Home"  width="100%" height="100%"

          borderStyle="solid"  borderColor="#FFFFFF" >

          >

                 <mx:TextArea id="textArea" width="424" height="296" paddingTop="130"

          paddingBottom="100"

          backgroundImage="@Embed(source='assets/textareahome.jpg')"

          borderColor="#FFFFFF"  borderStyle="solid" borderThickness="2"

          color="#FFFFFF"  backgroundColor="#e489cd"   shadowDirection=""

          wordWrap="true"   horizontalScrollPolicy="off"   fontSize="18"

          textAlign="left" verticalScrollPolicy="on" editable="false" >

          >

          >

          </mx:TextArea>

          <mx:Image source="@Embed('assets/Text.png')" hideEffect=""

          showEffect="" >

          >

          >

          • 2. Re: Multiple effects
            webguy5612 Level 1

            This solved my problem thanks

             

            <mx:Sequence id="showEffect">
            <mx:Move  yFrom="300"/>

             

            </mx:Sequence>
            <mx:Fade id="fadeMeIn" duration="1500" />
            <mx:Parallel id="fadeAndSlideMeIn" duration="1500">
            <mx:Fade alphaFrom="0" alphaTo="1" />
            <mx:Move xFrom="350" xTo="200" />
            </mx:Parallel>