9 Replies Latest reply on Jun 10, 2009 8:51 AM by JayStang

    Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin

    JayStang Level 1

      Hey Guys,

      I'm having an issue with using the 3.2 and 3.3 frameworks with the eclipse plugin (not an issue with the stand alone flex builder) (eclipse v3.3.2).  Pretty much everything works but the code hinting and auto importing doesn't work on some items.  For example anything in the "flash" package structure (ie: Event) will not import, and even worse within actionscript files, if the imports are manually typed out, the next time it does auto import something it'll actually run clean up on the file and delete the manually typed imports.  Also when typing out in mxml certain components, for example an mx:Button, the code hinting will not recognize certain attribues such as "click".  At compile time all is well and works fine as long as everything is manually typed in there.  Of course to really be an efficient coder manually typing and retyping certain imports over and over is not the answer.

       

      Thanks in advance!

      ~Jamie

        • 1. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
          *Prashant Shelke* Level 4

          I was also facing same issue, if auto-methods are not coming on ctrl + space, I used to close file & open again or re-compile again to make it available.


          If your imports are getting removed try to apply setting shown in attached image.


          Hope this will work for u.


          Thanks.

          • 2. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
            JayStang Level 1

            Thanks for the response.

             

            The ctrl + space option doesn't seem to help any for me nor does closeing and opening the file.

             

            Turning the import settings off will help with the deleting of imports issue, but frankly I don't think this is something I should have to do.

             

            What exactly is it about the 3.2 and 3.3 sdk's that are different from the 3.0 one, and how could Adobe release two versions back to back that don't support the eclipse plugin properly when 3.0 worked just fine?  We're not suppose to be losing features with new sdk releases!  This is quite frustrating and I would love to find a real solution to this.

             

            Anyone on the Adobe Flex team have any insight here?

            • 3. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
              dglidden-CE

              I've been using the FB Eclipse plugin (with Eclipse 3.4 and SDK 3.2.0) quite a bit and haven't had this problem at all, so I'm just taking a stab in the dark here to try to help.  It sounds to me like there might be an incorrect setting in your Flex Build Path properties or something related.  Make sure your project has the correct Flex SDK selected in the Library path, and make sure all the .swc files are showing up underneath it.  In particular, look for playerglobal.swc (that's the file that contains e.g. flash.events.Event).

               

              If that doesn't help, you really need to provide a little more information in your question, like:

              • What have you already tried doing to fix the problem?  (For example, have you completely uninstalled and then reinstalled the Flex Builder Plugin since switching SDKs?  I didn't need to do this the last time I upgraded the SDK, but I'd say it's worth a try, since the installation process is pretty painless.)
              • Have you changed any of the Flex settings in Eclipse?
              • If you're working with a project you created previously, have you tried creating a brand new Flex project in Eclipse to see if the problem persists in a new project?
              • 4. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
                JayStang Level 1

                Thanks CarLuva,

                I'm wondering if the fact i'm running on v3.3.2 of eclipse could be making the difference here.  I have done many fresh installs on many different machines.  Started over with a fresh workspaces and new projects and the issue is always there unless I switch over to flex builder rather then the eclipse plugin.  I've had co-workers also have this same issue on completely different systems as well.  I pretty much don't have a problem running flex builder vs eclipse however the one system i don't have an option on is a Linux ubuntu platform where no standalone builder is available.  I'll try upgrading to 3.4 however if i remember correctly i had some issues getting that running on Linux w/ the plugin.

                • 5. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
                  dglidden-CE Level 1

                  I thought of that, but the Flex Builder download site claims that either Eclipse 3.3 or 3.4 is supported.  My experience has been that the plugin works great within a typical scope of usage, but can make Eclipse a little unstable if, for instance, you have more than one or two projects loaded within Eclipse at the same time.

                   

                  Incidentally, are you building the FB plugin from source on your Linux box?  I've been interested in installing the plugin on a Linux box for a while and even downloaded the source code at one point, but I never got anywhere with building it.  Do you know of a good guide to building the plugin anywhere?

                   

                  Doug

                  • 6. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
                    JayStang Level 1

                    Nah i'm not building the plugin from source.  Just using the alpha version that adobe released which is in bin format.

                     

                    http://labs.adobe.com/technologies/flex/flexbuilder_linux/

                    • 7. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
                      JayStang Level 1

                      Ah this is frustrating.  So I completely started over...  Reinstalled Linux (ubuntu), installed jdk, eclipse 3.5 following this guide (http://blog.danyul.id.au/?p=68), & flex builder.  Upgraded the flex builder sdk from 3.0 to 3.3, created a new project, and same issue!

                       

                      I'm at a loss here.  I don't know how this isn't a problem for other people, but every machine i try it on has the same troubles.

                       

                      Anyone have any thoughts?

                      • 9. Re: Flex 3.2 & 3.3 Framework Issue w/ Eclipse Plugin
                        JayStang Level 1

                        Even better solution...

                         

                        Copy the "playerglobal.swc" from "/3.3_SDK_ROOT_FOLDER/frameworks/libs/player/10/" to "/3.3_SDK_ROOT_FOLDER/frameworks/libs/player/".

                         

                        This will fix the problem and make it so you don't have to import the playerglobal.swc every time.

                         

                        Note, this is how the 3.0 framework is setup.  It does not have subfolders within the "player" folder based on the version.  Probably because flash player 10 wasn't out yet at that point.

                         

                        I'm assuming the real issue here is the eclipse flex plugin doesn't know what version of the flash player is running so it doesn't know which subfolder to drill into to find the playerglobal.swc.