1 Reply Latest reply on Jun 10, 2009 6:43 PM by dude0404

    Updating 7.1.0 to 7.1.1 using msiexec /quiet fails

    dude0404

      I need to roll-out patches 7.1.1 (and eventually 7.1.2 and 7.1.3) to our entire organization of 7.1.0.

       

      I have two commands which I am testing:

      1. msiexec /quiet /patch 711.msp

      2. msiexec /patch 711.msp

       

      I need to use command 1. as I do not want my users to be faced with any installation GUI's. However after running the first command Reader's Help/About screen reports it as still being 7.1.0 (although Add/Remove Programs reports it as being version 7.1.1).

       

      Furthermore, I use a directory/file comparison tool (binary comparison) it reports the contents of the ...Program Files/Adobe as being no different to before having applied the 7.1.1 update using command 1. from above.

       

      So, it seems, when I add the /quiet switch (or /qn or /passive which I also tried) the only thing which is actually updated is the version number for Reader in 'Add/Remove Programs' but not any of the files themselves.

       

      When I use command 2 from above none of these issues are demonstrated - Help/About in Reader reports it correctly as being version 7.1.1 and my directory/file comparison tool shows changes to a number of .dll's and .api' and other files.

       

      For some reason, whenever I add /quiet or /qn or /passive the update is not being applied.

       

      I have attached the log file outputs (by adding the /log switch to the above two commands). They are both greatly different and they both report a successful patch.

       

      Please note I have tried this on a number of different machines and I do not believe this issue to be isolated to our SOE.

       

      Any help is much appreciated.