5 Replies Latest reply on Feb 18, 2010 7:42 AM by HeinzFretterlech

    new camera at unexpected default position

    dsdsdsdsd Level 1

      hello;

       

      I have a composition and I have added a new camera; but when I do, the camera doesn't seem to line up with any obvious meaningful coordinate;

       

      any thoughts?

       

      please see attached screenshot;

       

      thanks,

      Shannon

        • 1. Re: new camera at unexpected default position
          TimeRemapper Level 4

          I'm not sure I'm understanding you clearly.

          Can you please elaborate? The screenshot you posted will probably be queued for awhile.

           

          The cameras (when created) will probably not be visible themselves at the Origin [0,0,0], but will be "looking" towards it.

          Is that what you mean?

          • 2. Re: new camera at unexpected default position
            dsdsdsdsd Level 1

            that's kind of odd that the screenshot is queued ...

             

             

            in the front view the camera should be centered with respect to the canvas ( I don't know if AE uses the term 'canvas' ); instead it seems to be offset from the center of the front view; position: 160 , 120 , -311;

             

            however, in another composition I did the same set of steps ( setting a new camera ) and the camera is indeed centered on the front view; position: 160 , 120 , 0;

             

            thanks,

            dsdsdsdsd

            • 3. Re: new camera at unexpected default position
              TimeRemapper Level 4
              instead it seems to be offset from the center of the front view; position: 160 , 120 , -311;

               

              It would appear that you're not referring to the camera's position here, but the position of the "Point of Interest".

              I'm guessing your comp is 320x240.

              When you're creating the camera, are you using one of the camera presets in the new camera dialog box? If so, which one?

              • 4. Re: new camera at unexpected default position
                Mylenium Most Valuable Participant

                in the front view the camera should be centered with respect to the canvas ( I don't know if AE uses the term 'canvas' ); instead it seems to be offset from the center of the front view; position: 160 , 120 , -311;

                 

                however, in another composition I did the same set of steps ( setting a new camera ) and the camera is indeed centered on the front view; position: 160 , 120 , 0;

                 

                I think you are confusing a few things here. Without an actual camera in the scene, per se there is no "front view" in AE, it's always the "Active Camera". This means, when you then crteate a camera, it matches the existing view, but not necessarily the alignment of the world coordinate system. Furthermore, it makes a differnce if you have 3D layers or otehr 3D items in your scene. When creating a new camera, regardless of its settings, AE will always try to create it, so the visual appearance of the current view is retained as far as possible. More specifically, the first layer that intersects the view axis is used to determine the placement of the camera. That's why you may see differnt results - placing the camera further away along the Z axis may be required to keep the aformentioned layer in view. If no layer exists, AE can happily place your camera at the origin, which is at Z = 0 and the half height and width of your comp.

                 

                Mylenium

                • 5. Re: new camera at unexpected default position
                  HeinzFretterlech

                  I used to have a similar problem with my "Minikamera" once, I tried top take some motion picture and took one frame to create a picture, but somehow the default position was switched.

                   

                  Lucky a friend of mine helped me...