3 Replies Latest reply on Jun 11, 2009 4:28 PM by murrz

    Getting a simple animation to play in IE

    murrz

         I am having trouble getting a simple animation to play properly, on a site designed by someone else, in IE. It works fine in Mozilla and Safari. In IE, on some computers, it shows up but there is a prompt about downloading a Shockwave add-on. On other  computers it doesnt show up at all. Going from Mac to PC is also presenting problems. I'm freelance, so it's not like I'm in the office with these other people, so I only know what's going on with the 3 pc's I have at my disposal; which is as described above. I tried uploading another .swf with just 1 frame to see what would happen and it did the same thing. I'm starting to think it is a problem with the site and not the Flash.

         If anyone could take a look at it and offer some help, it would be greatly appreciated.

      Thanks,

      Murrz

       

      www.buildingdimensionsnc.com

        • 1. Re: Getting a simple animation to play in IE
          anubia

          This all stems from a lawsuit Microsoft lost years ago. From that point forward, there had to be special code that allowed SWF files to be opened on PC browsers. Though they've recently come to a better agreement eliminating the need for such code, most browsers haven't been updated yet. Look for a discussion of AC_RunActiveContent. Rather than tax your brain, however, just publish a movie and HTML from Flash and you'll see exactly how it's done.

          • 2. Re: Getting a simple animation to play in IE
            anubia Level 1

            Also, remember that people don't always update their plugins or even know how. Export your movies a Shockwave version or two behind, just to be on the safe side.

            • 3. Re: Getting a simple animation to play in IE
              murrz Level 1

              Thanks for your help. I didn't even think about the .html file. Normally I send both but I thought they had that sorted (so I was told) out when it worked in Mozilla and Safari. I won't know until tomorrow if it worked, but thanks again.

               

              Export your movies a Shockwave version or two behind, just to be on the safe side.

               

              This I don't quite get. Normally I publish and send .swf and .html and send them and everything works.

              Murrz