11 Replies Latest reply on Jun 17, 2009 12:38 PM by Mylenium

    AE CS3 Win7 Memory Issue - AE Chokes while having more than enough

    Redsandro

      Hi,

       

      I have been experiencing memory issues in After Effects CS3 running on Windows 7 RC 7201.

       

      When switching to different comps, every frame gets redrawn on switch. Nothing seems to get cached. Most of the time I cannot even make a snapshot, and RAM preview hardly ever works but occasionally animates up to 5 frames, while it used to do almost the entire animation on my other hardware with XP64.

       

      Here's what's changed: My mainboard and proc broke, so I changed from Intel to Asus and Intel Core 2 Duo to Core 2 Quad. My videocard (Nv 7600GT) and memory (4GB) remained the same. After the 'break,' I installed Windows 7 64 instead of XP x64.

       

      I think Windows is not the problem. Because I fixed the x64 installation, which I can now concidered bloatware after installing a bunch of stuff over it to get it to work with my new hardware without reinstalling (I hate to go through the effort because I want to ditch XP), and it experienced similar problems! But before the hardware change, a much bigger scène wouln't even have this problems. Win7 is a pretty clean install btw.

       

      Here's my settings, which were the same back when it used to work:

       

      http://stuff.rednet.nl/rommel/trash/AE_prefs.png

       

      Sometimes even when scrubbing the timeline, it sais:

      http://stuff.rednet.nl/rommel/trash/AE_allocate.png

       

      SOMEtimes, when I quit, I get this message:

      http://stuff.rednet.nl/rommel/trash/AE_dispose.png

       

      And that usually means that After Effects will also crash up on exit:

      http://stuff.rednet.nl/rommel/trash/AE_stopped.png

       

      All of this while there is more then enough memory for After Effects to go around:

      http://stuff.rednet.nl/rommel/trash/AE_taskmgr.png

       

      Also, rendering often fails with memory messages or just plain crashes After Effects. I have a few hundred Gigs free on the cache and user drives. I have a fixed swap file of 6142MB, the Windows recommended value.

       

      I don't know what to try anymore. It feels like editing on my old P4 machine, while this used to go pretty awesome.

        • 1. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
          Redsandro Level 1

          Additional info:

           

          While playing/scrubbing, not a single frame or just one stays green (cache indicator). Sometimes they are cached in blue (disk) when I play back (space) but it skips frames from cache.

          • 2. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
            TimeRemapper Level 4

            Maybe it has to do with the OS not being officially suported for that version of AE?

            Is CS3 patched/updated?

            If you don't want to use XP, or XP64, do you have an installer for Vista, or Vista64?

            You could try trashing your prefs to see if they somehow got corrupted.

            Also, maybe try disabling OpenGL to see if it has any effect, although it seems to be unrelated.

            • 3. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
              Mylenium Most Valuable Participant

              redsandro wrote:

               

              I think Windows is not the problem.

              No. 1 rule of Beta testing: Never prematurely preclude anything. Win7 != WinVista.  Quite possible, you are facing a memory address mapping issue due to a change in the security model of Win7, i.e. AE CS3 pointing to memory areas that are considered off limits by Win7. It may report everything correctly, but nonetheless block sections... So the question is, what you have tried so far on that end. Did you run in compatibility mode? Edit UAC and DEP settings and user policies? Always run as admin? Turn of address block randomization? Also, it is not really a matter of how you were able to revive your XP64. It may not function properly regardless. Several system DLLs are very specific in how they map some addresses and without a complete re-install those values may be considerably off the mark or the wrong version of the DLL on the system (it makes a difference, if it just handles 2 threads or multiple ones...). Anyway, all that  stuff aside - have you checked your BIOS and can you be sure the memory timing and allocation are right there? Your problems sound too severe to be software-only, so I'd definitely investigate that part as well....

               

              Mylenium

              • 4. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                Redsandro Level 1

                Thanks for the responses. Meanwhile, I put back an older image of XP64 which is a lot cleaner but had basic stuff installed and AE definitely worked in here. I only had to install Chipset drivers and soundcard for this image to work with my new motherboard. Still, it has exactly the same problem.

                 

                I tried all mentioned stuff except turning off addressblock randomization because I don't know what that is, but since XP has the same problem with settings that used to work, I think that it's unrelated. I en/disabled OpenGL, other video drivers, something else I wanted to mention but forgot (because I typed the rest of this post first).. if I remember important stuff I will post it.


                Indeed I run (in Win7) with admin privileges. Also, if I run XP compatibility mode, an extra message occasionally pops up:

                http://stuff.rednet.nl/rommel/trash/AE_XPcompat.png

                I cannot seem to spot memory problems in BIOS, but honestly I'm no pro so I just let them default or 'auto'.

                BTW, other 'older' graphic apps such as 3ds Max 2008 work seamlessly in Win7 with current state and memory settings.

                 

                I definitely want to try trashing the prefs, didn't do that yet. How do I do that? Can I just remove After Effects from the Adobe Application Data?

                Though it's odd, because obviously I have a different set of options in XP than Win7. They each have their own Program Files folder and are activated separately (I had to deactivate CS3 on my laptop to get them both to activate).


                PS - I don't run the Windows 7 beta. I run RC which is the thing they will put in the store except for some minor changes in say language or appearance.

                • 5. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                  TimeRemapper Level 4

                  RC stands for "Release Candidate", I believe.

                  This would mean that it's still a "candidate", and not a full alpha release. As such, it's still in beta.

                  The semantics may vary, but it's still not a release version. As Mylenium was indicating, there could be fixes to certain things underway at Microsoft that are buried so far under the hood that we (or at least, I) have no idea they even exist.

                  That's not to say that we definitely can't get it working. Are there and BIOS firmware updates that you may need to install with your new HW config?

                   

                  If you hold down Ctrl-Alt-Shift right after clicking on the icon to launch AE, it will reset the prefs.

                  Check out some other tips Jonas has on his site. Some may prove useful.

                  • 6. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                    Mylenium Most Valuable Participant

                    Mmh, the plot thickens. Bad tracked memory ID definitely means, AE is unable to allocate contiguous memory blocks to store multiple frames for a preview. Memory address randomization is a security mechanism which can be disabled by digging in the depths of your group policies and the registry. It's major black art and not recommended. however it is possible that AE is affected by it somehow. To me, what seems to happen is that some other tools is either enabling that feature (it always kicks in, when certain network ports are accessed) or the external application itself is garbling up the memory blocks and affecting AE. The big if here is, that it would only explain the behavior on W7, because on XP64 these functions don't exist. So this takes us back to your hardware. It definitely feels like your memory suffered damage, is loose in its socked or has a configuration problem. Therefore I'd definitely check again. For the BIOS using Auto is usually right, but nonetheless it is worth checking. I would write down all the current BIOS settings so you can re-instate them (or save them as a user-config, if the BIOS offers this comfort), and then fully reset the BIOS to its factory default. This will enforce a full scan of your hardware and may possibly set some things differently. When then starting Windows, you would see some configuration being updated there as well and you may get some warnings i nyour device manager, but it may fix the memory problem in a weird and wonderful way. Still, take this with a naximum of caution...

                     

                    Mylenium

                    • 7. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                      Redsandro Level 1

                      Thanks for the extensive replies.

                       

                      I think it's not a Win7 thing because XP acts similar, and I think it's not the randomized blocks (Bad ID) thing because it's only in compatibility mode.
                      So unless I'm completely overlooking something I'd agree with it being hardware related.

                       

                      Though I'm convinced my memory is fine, I use extensive Photoshop and 3ds Max, nearly impossible if you have bad memory. But I can run MemTest86 for a while and find out.
                      BIOS is left. I'm still not sure because I haven't really touched it since I got the component new, except fiddle around with the boot order. But I could reset it anyway to find out. Finally I hadn't lookt very recently for a BIOS update, can try that as well.

                       

                      Any other suggestions are welcome, otherwise I'll report back after I tried these things when I get back after the weekend.

                       

                      PS - Steve, I know what you mean but for semantics: Alpha actually comes before Beta, extremely buggy and usually not ever released.

                      • 8. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                        yenaphe Level 4

                        Well Win7 RC 1 is still a beta, a release candidate is just a major milestone. MS will release RC2 to developers before shipping the GM (Gold Master) version to replication factories.

                         

                        Aside of that, it's possible that AE CS3 won't be compatible at all with Win 7. AE have a very particular way of handling and managing it's memory, and having other Adobe software of other memory greedy software run under Win 7 doesn't mean sadly, that there is a way of making it work. (As you may know, each Adobe Product team is independant, so the memory management is not the same at all from an Adobe Product to another)

                         

                        The way memory is managed by Windows inside XP64 and Vista64 is so different (much more different than the difference between XP32 & Vista32) that even CS4 only support Vista 64 (but can run in XP64), so as Windows 7x64 is based on Vista 64 i guess it will be difficult to find a solution.

                         

                        If you really need to use Win7x64 (And i can understand it as it's just a wonderfull Windows version), you may want to upgrade to CS4. I'm using it right now on Win7 without any problems.

                        • 9. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                          Redsandro Level 1

                          I understand the issues about Windows 7. But for the record,  I have the same issues in XP64 so you can forget about Windows 7. I wouldn't upgrade because I bought CS3 last year, I'll try to make some money before I spend some money. If it won't work with Win7 I'll stick to XP. But personally, I think CS3 will work perfectly with Win7; it's only NT6.1 in stead of 6.0 (Vista).

                           

                          We will soon find out I hope. Tomorrow I will try the earlier mentioned options. It has to work in XP at least. So once I get it working in XP, I'll try Win7 and let you know. But for now, something's definitely wrong with my computer. Curious.

                          • 10. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                            Redsandro Level 1

                            I wasted a lot of time today, but I know a bit more now.

                             

                            I ran MemTest86 for two hours, no ball. BIOS default settings, no ball. Upgraded to latest BIOS that came out last month, still no change.

                             

                            Next I decided to grab the biggest project from my backup drive that wasn't archived (compressed) yet, and strangely, it worked perfectly. So for comparison, I'm gonna call that composition 'good', and the biggest current one that has the problem mentioned 'fail'.

                             

                            I compared the two footage-wise:

                             

                            Good:
                            Project file: 9 MB
                            Precomps: 160
                            23 Lagarith HD files
                            36 AviSynth HD frameserved files
                            Data on disk frameserved: 7,8GB

                             

                            Fail:
                            Project file: 2 MB
                            PreComps: 25
                            10 Lagarith HD files
                            10 MPEG2-TS
                            60 AviSynth HD frameserved files
                            Data on disk frameserved: 7,2GB

                             

                            I should have written it down like this earlier because you can probably spot the problem immediately that took me ages to find out. It's not the procomps or the project size. I overlooked it earlier because I compared the amounts of footage data. But it's not the amount of frameserved data, it's the amount of open frameserve handlers that seems to hog After Effects. When I delete half the footage, AE starts acting nice again.
                            There is however three things odd with that. First, none of the RAM cached (green) frames turn to disk cache (blue) ones like they should. Second, more importantly, even this doesn't use up all memory. Like the screenshot in my OP shows, more than 2 gigs of memory can be empty when this behavior shows. Enough for at least a bunch of cached frames. And third, while in 'good' I referenced all footage items, in 'fail' I only referenced about 10 of them. Which means that all handlers are sustained by After Effects even if they are not in use. And even if you delete them. When I delete *all* footage items, I still cannot take a snapshot. Only when I save, close and open the project does stuff work again.

                             

                            So, frameserving has its limits and full proxies to be used during rendering also are to be concidered. I want to thank you all for thinking with me, and I hope this report will catch any searches from people who have similar issues because it could save them a lot of time.

                            • 11. Re: AE CS3 Win7 Memory Issue - AE Chokes while having more than enough
                              Mylenium Most Valuable Participant

                              Interesting find. The behavior about AE not releasing your handlers is normal, though. The program has no concept of this being a virtual file and thus it cannot unload the required routines. It merely would send a "close this file" command, the rest is up to the frameserver software. Anyway, thanks for sharing. this may come in handy some day.

                               

                              Mylenium