9 Replies Latest reply on Jun 22, 2009 11:05 AM by Super_Clark

    Unable to run project

    Handycam Level 1

      Catalyst posts an error dialog, and if I choose to build and run anyway, I get:

       

      Unable to run the project   

      File not found: file:/Users/stevelombardi/Library/Application%20Support/Adobe/Flash%20Catalyst/workspace/ step_design/bin-debug/Main.html

       

      Any ideas?  I Went through a lot of work and now can't run the project.  I'm hoping it's something simple...

        • 1. Re: Unable to run project
          Handycam Level 1

          I looked in the code view and there are 3 of the same flex errors:

           

          Cannot resolve attribute 'marginBottom' for component type spark.primitives.RichText. Main.mxml step_design/src line 74 Flex Problem

           

          These are on 3 of the text objects in my project.  No idea where this comes from, or if it's what's causing the unable to run error.

          • 2. Re: Unable to run project
            Handycam Level 1

            Note:  I fixed all those errors by replacing the text with text created in FC, so there are no Flex errors in code view --

             

            But it still will not run.  What gives?

            • 3. Re: Unable to run project
              Eric Lopatin (Adobe) Level 2

              Thanks for noting the errors you found in code view. The 'marginBottom' error was caused by a "space after" setting in the comp you imported from Illustrator. In Beta 1 marginBottom is an unsupported RichText attribute – as are marginRight, marginLeft, and marginTop. Support for these will be present for the 1.0 release and should be available in a later Beta.

               

              If you deleted the instances of text from the artboard and replaced them with Catalyst text, the original instances may still exist in the project (which could explain why you can't run, but don't see errors in code view). Try using the Layers panel to find the original text layers and delete them using the trash can there. Let me know if this works (or feel free to post the FXP file and I'll check it out).

               

              Otherwise, the best way to keep from getting these errors at runtime is to go back to your design comp in Illustrator and remove the space after values you have associated with the text. Or, in this case you could select the original text layers and choose Edit in Illustrator – then remove the space after value that way.

               

              -Eric

              Catalyst QE

              • 4. Re: Unable to run project
                Handycam Level 1

                Thanks, that was indeed the issue.  I wasn't even aware that the AI text had

                that set on it. I went back and set all text to space after 0 and it

                imported and worked.

                I would suggest that for the real version, you either put up a meaningful

                warning or simply discard incompatible attributes like that.

                • 5. Re: Unable to run project
                  Eric Lopatin (Adobe) Level 2

                  Great, glad that worked for you. We're currently implementing support for margins and space before/after (first line indent works in Beta 1). So these should all be recognized and correctly handled by FC, Builder and at runtime by the next release.

                   

                  -Eric

                  • 6. Re: Unable to run project
                    Handycam Level 1

                    Thanks.  This looks like a great product so far.  I am a Flex developer and

                    getting the art director's look into Flex projects was always tedious.  With

                    even this beta i was able to get a design in one morning, even doing it 3

                    times.

                    • 7. Re: Unable to run project
                      Super_Clark Level 1

                      I get the same error when i run but when i go into code view and find the errors then it says 'assets/amsi web test' does not have a recognized extension, and a mimeType was not provided. Any clues?. Also there is 10 of those errors and then 10 of this error: Unable to transocde assets/amsi web test. I have used flash before but never flex or flexbulder so i am new at this.

                       

                       

                      Thanks

                       

                      super clark

                      • 8. Re: Unable to run project
                        Eric Lopatin (Adobe) Level 2

                        Sounds like you have an asset in your project whose file type is unrecognized by the compiler. What kind of source file was "amsi web test"? Can you let me know how you imported it? (via the library panel, file>import, copy/paste). If you imported an Illustrator file, did it have any linked images?

                         

                        Thanks,

                         

                        Eric

                        • 9. Re: Unable to run project
                          Super_Clark Level 1

                          Yes i have another thread here. http://forums.adobe.com/thread/451857?tstart=0

                           

                          Adam has got my origonal .fxp file. Also it is a .ai file and it is all vector images.

                           

                          Thanks

                           

                          Clark