26 Replies Latest reply on Jun 28, 2009 1:26 AM by juskocf

    Can't make an Upper Field First footage.

    juskocf Level 1

      The original footage is Upper Field First. After some editings, added it to Render Queue. In the output module settings, I selected Format H.264. In Format Options, I selected Preset: Custom and Field Order: Upper.  But the output video was Progressive, not Upper Field First.

       

      I wanted the output video the same as the original footage, i.e. Upper Field First. What settings should I make ? Where is my mistake please ?

       

      Thanks in advance.

        • 1. Re: Can't make an Upper Field First footage.
          Todd_Kopriva Level 8

          Do you have field rendering turned on in the render settings?

           

          Did you separate video fields for your imported footage?

           

          BTW, I strongly recommend the materials about fields and interlacing from Chris and Trish Meyer linked to from the "Interlaced video, noninterlaced video, and progressive scanning" page.

          • 2. Re: Can't make an Upper Field First footage.
            juskocf Level 1

            Thank you Todd.

             

            The original imported footage is Upper Field First and I did checked the "Interpret Footage"->"Separate Fields"->"Upper Field First".

            In the "Render Settings" ->"Field Render", I selected "Upper Field First"

             

            But the rendered footage was Progressive, not upper field first.

             

            What else can I do please ?

             

            Best Regards

            • 3. Re: Can't make an Upper Field First footage.
              Mylenium Most Valuable Participant

              How do you verify your footage? Do you send it to your playbaclk system? Burn BluRay discs? Also, do you really see a reduction in vertical resolution as you would when using just one field?

               

              Mylenium

              • 4. Re: Can't make an Upper Field First footage.
                juskocf Level 1

                Thanks Mylenium.

                 

                Dragging the rendered footage to the Project panel, I can see that the footage is Upper Field First or Progressive. Or by means of Interpreting the footage. My purpose of the footage is mainly for sharing with friends on the web.

                The original footage is taken by an HD camcorder.  The field order is upper field first. I just wanted to keep it as it is.

                 

                But the main concern with me is why AE can't make a footage to my intent? Although I have made all the settings that is intended to make an interlaced footage, the rendered footage is in fact progressive.

                 

                There is no problem with Premiere Pro.  Is it a bug in AE or am I missing something ?

                 

                Best Regards

                • 5. Re: Can't make an Upper Field First footage.
                  Mylenium Most Valuable Participant

                  Well, just re-importing will not necessarily give the correct info. The interpretation rules may override wrong footage flags or apply settings based on very educated guesses by ways of the Interpretation Rules.txt file, if no flags are found at all. I think that's what's happening here. Either no stream flags are embedded or because you are possibly using a wrong PAR or resolution, AE interprets it wrongly. can you post screenshots of your initial footage interpretation and your encoder settings as well as the interpretation of the re-imported files?

                   

                  Mylenium

                  • 6. Re: Can't make an Upper Field First footage.
                    juskocf Level 1

                    Thank you Mylenium for your reply.

                    As per your request, please take a look at the following website showing the screenshots of the footages.

                     

                    http://333.fotoc.com/jusko/AE/

                     

                    Best Regards

                    • 7. Re: Can't make an Upper Field First footage.
                      juskocf Level 1

                      Hi, Mylenium, posted the relevant screenshots on the above website. Any ideas please ?

                       

                      Best Regards

                      • 8. Re: Can't make an Upper Field First footage.
                        Mylenium Most Valuable Participant

                        I'm sorry, your page just doesn't seem to load. Why not simply attach the images here using the camera icon? This should definitely work.

                         

                        Mylenium

                        • 9. Re: Can't make an Upper Field First footage.
                          juskocf Level 1

                          OK, here you are,

                           

                          Original footage :

                          Untitled-1.jpg

                           

                           

                          Original Footage Interpretation:

                          Untitled-2.jpg

                           

                           

                          Render Settings :

                          Untitled-3.jpg

                           

                           

                          Output Module Settings :

                          Untitled-4.jpg

                           

                           

                          Format Options :

                          Untitled-5.jpg

                           

                           

                          Re-imported Footage :

                          Untitled-6.jpg

                           

                           

                          Interpretation of re-imported footage :

                           

                          Untitled-7.jpg

                           


                          The End and Thanks~~

                          • 10. Re: Can't make an Upper Field First footage.
                            Mylenium Most Valuable Participant

                            I think I see what's going on. you are using an out of spec resolution which may not qualify for the flag to be set correctly nor would AE be able to interpret your footage automatically based on that. The MPEG specs are very specific about such things...

                             

                            Mylenium

                            • 11. Re: Can't make an Upper Field First footage.
                              juskocf Level 1

                              Thanks Mylenium for your reply.

                               

                              The resolution is a standard setting as you can see from the "Output Module Settings"->"Stretch" section.  I selected the "NTSC D1 Widescree Square Pixel" from the stretch list.

                               

                              Sorry for my late reply.

                               

                              Best Regards

                              • 12. Re: Can't make an Upper Field First footage.
                                yenaphe Level 4

                                well if you choose Widescreen Square pixel from your strech menu, you should definitly not select Widescreen Par in the h264 settings because it will flag you file as being not square pixel, and as you strech is square pixel, you'll end up with invalid flag.

                                 

                                I would recommand either choose Square pixel for both (Widescreen Square pixel in strech, and square pixel in h264), or Widescreen PAR for both.

                                • 13. Re: Can't make an Upper Field First footage.
                                  Rick Gerard Adobe Community Professional & MVP

                                  There's no way to verify that your footage is interlaced by simply checking interpolation. You must look at each frame to verify correct interpretation. This is especially true with 24 fps footage whether transfered from film or originated with a video camera. You can double the frame rate of your comp to check fields, but there's a much easier way.

                                   

                                  Hold down the Option (mac) or Alt (PC) key and double click the footage in the project window in CS3, or just double click the footage in CS4. This will open up the footage in a footage window. You can then step through the clip one frame or one field at a time using the page up and page down key.

                                   

                                  If you the interpretation is set to separate fields and the field order is incorrect an object moving across the screen will move forward then backward then forward. If the footage is not interlaced but it is interpreted with fields in any order you'll see two frames with no movement then another pair, then another. Adjust the settings until you see smooth movement between each frame and the field interpretation will always be correct.

                                   

                                  I strongly suspect that your footage is not interlaced. It's the only answer that makes sense. If it's not interlaced in the first place then adding fields in at the end won't accomplish anything. You'll just end up with pairs of identical fields. That would also explain the softening because you're only using half of the information in the frame.

                                   

                                  I hope this helps. It should be part of your standard workflow. I always check to make sure that the interpretation matches the actual footage. More than half the time, HD footage that I get from clients isn't what they told me it is. We got in a bunch of DVC Pro 100 compressed 720 I footage that was actually DVC Pro 50 compressed 720 P. The client refused to believe me when I told him. I had to bring him in, show him the examples, then convince him to go and check the settings on the camera. Surprise surprise! The camera was set to 720 I and the guy that captured the footage for me rendered my copy to DVC Pro 50.

                                  • 14. Re: Can't make an Upper Field First footage.
                                    juskocf Level 1

                                    To Sébastien, no matter what I chose, the rendered footage was still Progressive.

                                     

                                    To Rick, I used the method you described in paragraph 3 and confirmed that the original footage is Upper Field First and the rendered video is Progressive.  The original footage was taken by a Panasonic consumer camcorder SD3 with format AVCHD.  I am sure the original footage taken by this camcorder is Upper Field First and no other choice.

                                     

                                    Really no way to make the rendered video the same field format as the original ? Why the result must be progressive ?

                                     

                                    Any ideas please.

                                     

                                    Best Regards

                                    • 15. Re: Can't make an Upper Field First footage.
                                      Rick Gerard Adobe Community Professional & MVP

                                      I think it's time to provide us with a few frames of your original footage.

                                       

                                      If the footage is indeed interlaced and you separate fields properly then drag the footage into the new composition icon, then add it to the render cue and select field rendering in the render settings you will get interlaced footage. I've never seen anything else even going back to AE 3.

                                       

                                      Even if you don't have any interlaced source material in your composition you will produce interlaced footage in the render.

                                       

                                      Start a new comp at any frame size and any frame rate, add a thin line to the comp by creating something like a solid that's 10 pixels by 400 pixels, then rotate it 90º in 4 or 5 frames then render introducing fields you'll see interlacing in the output.

                                       

                                      I'd bet if you added a similar solid on top of your footage then rendered as I described you'd see something like this.

                                       

                                      qtInterlaced.png

                                      If the footage was originally interlaced, IOW you can see the scan lines when you view the footage in your media player, then you should get them back. If the footage wasn't interlaced then you will get back pairs of identical frames when you render.

                                      • 16. Re: Can't make an Upper Field First footage.
                                        juskocf Level 1

                                        Thank you Rick spending so much time on my case. I have upload the original footage to the following website.  Please download it and make a few seconds of footage of resolution about 800x450 H.264 upper field first.

                                        http://www.mediafire.com/download.php?tz2y2onkzm3

                                         

                                        Best Regards

                                        • 17. Re: Can't make an Upper Field First footage.
                                          Rick Gerard Adobe Community Professional & MVP

                                          Ok, I looked at your footage and the screenshots of your rendering setup. Here's the problem. You've properly separated fields. Your comp is standard HD, but you're stretching in the output module, or should I say shrinking in the output module. This means you'll be loosing your original fields and it also means that you will will not be getting the best quality video. What you should be doing is creating a new composition that's the size you want for your final output then scaling the nested HD comp to fit horizontally. Both X and Y scale values should be equal.

                                           

                                          Stretching is OK for quick tests, but for best quality I always use a comp that is the right size for the final output.

                                           

                                          The other problem is that you're not using the right frame size for H264. You should be using 720 X 480 widescreen, which is what the preset is for. You've picked square pixels (non standard size) for this codec and you've chosen to add fields. Square pixel output at smaller than normal HD frame sizes is usually used for output to the web and in that case you should not add fields. All web video should be progressive or without fields.

                                           

                                          All this makes me wonder what you're going to do with the render. If you're planning to output to DVD then don't do the MPEG compression in AE, use something like animation codec and then use your DVD software to compress the footage for output. This is the only way you'll be able to enable multi pass compression.

                                           

                                          So, to summarize, You're having problems because you're using a non standard procedure and rendering to a non standard frame size. I don't know what you're planning to do with the renders so I can't be of much help there. You'll never re-create the original interlacing if you resize the video or move it in the frame. AE will always add fields if you set them up in the render settings. Most codecs do not carry the meta tag info that tells the PAR or the interlacing so you'll have to make sure that all rendered footage is properly interpreted.

                                           

                                          One last point. I'd bet that your rendered footage is interlaced. If you hold down the Alt/Option key and double click it in the project window to open it in a footage window you may not see the combing, but you should not see duplicate frames when you separate fields. I'd be happy to take a look if you can post the rendered footage.

                                          • 18. Re: Can't make an Upper Field First footage.
                                            juskocf Level 1

                                            Thank you Rick for your detailed explanation.

                                             

                                            According to what you said, I had tried using  720 X 480 widescreen (NTSC DV widescreen), but I couldn't make a 16:9 footage. I had also checked the "Fit to comp width", but still couldn't make it 16:9 in letterbox. As my original footage is in 16:9, I had to choose "NTSC D1 widescreen square pixel" in order to make a 16:9 footage.

                                             

                                            I uploaded the rendered footage made according to the screenshots of my previous post.  Grateful if you would download it and check whether it is interlaced or progressive.

                                             

                                            http://www.mediafire.com/download.php?d3zynmizion

                                             

                                            Best Regards

                                            • 19. Re: Can't make an Upper Field First footage.
                                              Rick Gerard Adobe Community Professional & MVP

                                              The footage you sent is not interlaced.

                                               

                                              I'm not sure what you mean when you say you can't make the footage 16:9.

                                               

                                              NTSC DV Widescreen is not letter boxed. NTSC DV would give you a letter boxed 4:3 image if you were to fit a HD project horizontally. Neither would look right in AE unless you were to turn on Pixel Aspect Ratio Correction in the Comp Window. Turning this switch on and off has nothing to do with the actual pixels in the video, it just changes the way they are displayed on the screen.

                                               

                                              It's exactly the same when you're watching a DVD. With many machines you can choose to watch letterboxed or to watch wide screen. The pixels don't change, just the way they are displayed.

                                               

                                              I still don't know what you want to do with this rendered footage. If you're intending it for the web then you should not be adding interlacing and you should be rendering from a square pixel comp. If you're going to DVD for playback then you don't want to send the DVD authoring program footage that's all ready highly compressed. You'll end up with junk. Render to a lossless codec (animation QT) or a nearly lossless (motion JPG high quality) and let the DVD authoring program handle the compression. The best results are had with multi pass rendering. You can't do that in AE.

                                               

                                              I'd love to see your project. I could check out the settings and figure out why you're not getting interlaced output.

                                              • 20. Re: Can't make an Upper Field First footage.
                                                juskocf Level 1

                                                Thanks Rick.

                                                 

                                                My rendered footage is not interlaced, thats my question. As you can see from the screenshots of my previous post, I had made every settings intended for an interlaced video. But still I couldn't make it interlaced.  If there are settings that you can choose from in order to make an interlaced footage, I assume that an interlaced footage should be made after rendering.  But its not the case, thats why I asked this question.

                                                 

                                                Why I wanted to make an interlaced video ? Its because an interlaced video is much "fluid" than a non-interlaced or progressive video. I confirmed that by making a lot of comparison myself.  I usually make lower resolution videos and share them with my relatives and friends, either share the videos on the web or send them as video files.

                                                 

                                                OK, now back to my question, Rick, could you download my original footage which is a 16:9 HD footage, and make a lower resolution (say, 800x450) interlaced footage with AE please ? And tell me how you can create a lower resolution and interlaced video please.

                                                 

                                                Your help is much appreciated.

                                                 

                                                Best Regards.

                                                • 21. Re: Can't make an Upper Field First footage.
                                                  Rick Gerard Adobe Community Professional & MVP

                                                  Most agree that interlaced video does not look good on the web. I've already got the original shot you posted. Let me see your comp and I can probably figure out where you went wrong.

                                                   

                                                  Again, if you're making videos for sharing through the web then you should probably render to a lossless codec first then use something like QT pro to do a multi pass render for sharing. You'll get smaller files with higher quality than you can ever get directly out of AE.

                                                   

                                                  Take a look at this CS4 project.

                                                  • 22. Re: Can't make an Upper Field First footage.
                                                    juskocf Level 1

                                                    Thank you Rick for your project attachment.

                                                     

                                                    But your rendered footage 00001.mov was in full HD 1920x1080, how about in lower resolution such as 800x450 ? I have problem making an interlaced footage in lower resolution.

                                                     

                                                    There is no problem if I select "HDTV 1080 29.97" in the "Stretch" of "Output Module Settings".  The rendered footage will be Upper Field First.  But once you make it in smaller size, the rendered footage will be non-interlaced.  Thats the problem.

                                                     

                                                    Best Regards

                                                    • 23. Re: Can't make an Upper Field First footage.
                                                      Rick Gerard Adobe Community Professional & MVP

                                                      Try dropping the comp in a smaller one then scaling horizontally. If you pick the same codec that I used then you'll get interlaced footage. If you send me your comp I'll figure out what you're doing wrong. I think it's using the h264 encoder in AE. I never use that.

                                                      • 24. Re: Can't make an Upper Field First footage.
                                                        juskocf Level 1

                                                        Thank you Rick for spending so much time on my problem. I think its a bug of H.264 of AE. There is no way to create interlaced video if the footage is scaled down. I have tried every possible ways but still in vain.

                                                         

                                                        Best Regards

                                                        • 25. Re: Can't make an Upper Field First footage.
                                                          Rick Gerard Adobe Community Professional & MVP

                                                          I hope that you get this this time.

                                                           

                                                          If you want an h264 encoded movie from AE's built in encoder you MUST use one of the preset sizes. In your own screenshots you're instructed to stretch the video to 720 X 480. Do that and you'll get interlaced output from AE. but then you'll have to go into the Movie properties settings of QT and fix the display so folks that view the movie in QT will get the wide screen version. This is no bug. This is the way that the H264 encoder built into AE is designed. It's trying to help you create Standard outputs. Here's where you set the movie to look right in QT Pro.

                                                           

                                                          Picture 1.png

                                                           

                                                          If you use this technique then you'll have to re-interpret the footage in AE because you've fouled things up to get a movie not intended for playback on a strictly square pixel device to look right.

                                                           

                                                          If you really want to go off standards then do as I've suggested, export a lossless odd sized movie then use QT pro to encode that movie to the H264 codec using QT pro. This will give you the small file size you requested but the movie may have trouble playing back on some devices because it doesn't comply with the standards. You'll end up with a square pixel interlaced version of the original at a smaller size.

                                                           

                                                          Interlaced movies don't look very good on web devices because of the comb effects. Motion artifacts are different depending on frame size and frame rate. I design movement differently for web, hd, sd, podcast because each delivery format has it's optimum settings. Progressive is always best for web or e-mail delivery.

                                                           

                                                          Here's a zip file with an ae project showing some settings and some rendered movies. Customizing your video output is a lot like customizing a car. It takes a lot of fooling around and you may end up with something that no one else can work on.

                                                          • 26. Re: Can't make an Upper Field First footage.
                                                            juskocf Level 1

                                                            Rick, thank you very much indeed for helping me on my problem for the past week.


                                                            I have made many render testings for different settings. You are right in saying that I have to use the preset sizes. If I customized the sizes, I wouldn't get an interlaced footage.

                                                             

                                                            Thank you once again for your precious time and patience with me.

                                                             

                                                            Best Regards