3 Replies Latest reply on Sep 17, 2008 8:19 AM by Kutra

    Corrput CPD file and no HHP file.

    Kutra
      Hi:

      We are trying to upgrade a version controlled project (Visual Source Safe) RoboHelp 6 project to RoboHelp 7 and we keep getting the error that the CPD file is corrupt. So we tried deleting it, but kept getting the same error. It appears that RoboHelp 7 is creating a corrupted CPD file (2MB). Also, this CPD file is not a version controlled file. FInally, RoboHelp 7 is installed on a clean machine where there was no earlier instance of RoboHelp. Thus, whe we got the latest files from SourceSafe, there was no CPD or HHP file; only an XPJ file that we clicked to upgrade.

      We looked at Peter's article [ http://www.grainge.org/pages/authoring/opening/opening_projects.htm about trying to launch the project from the HHP file, but there is no HHP file that is created in the project either! What do we do?

      Please help.

      Thanks,
      K
        • 1. Re: Corrput CPD file and no HHP file.
          lmarden Level 2
          I had some major issues moving from v5 to v6 - after countless tries (uninstalls / installs, registry edits, offerings to the gods, etc.), I gave up and reverted back to 5. Then, when I got 7, it didn't want to cooperate either. There are some threads of discussion I took part in about this, but they are to painful to dig up and relive!

          Very long story short, I ended up rebuilding the CPD file in v5 BEFORE running the upgrade against my projects, then installed v7. Even now, I occasionally have to rebuild the CPD, when it gets bloated. But doing the initial repairs in v5 was the solution.

          And this is without the whole SourceSafe layer to contend with.
          I feel your pain.
          • 2. Re: Corrput CPD file and no HHP file.
            Gravenstein Level 2
            Hi Kutra -

            Check Snippet 79 on Peter Grainge's site. That might be your issue. (You would need to fix the rhvariable file, delete the cpd file, and then reopen.)

            G
            • 3. Re: Corrput CPD file and no HHP file.
              Kutra Level 1
              I went the following route to fix this problem:

              1. Made a copy of the RH6 project (for back-up porposes)
              2. Removed the RH6 project from version control.
              3. Upgraded the project using RH7. (CPD and HHP files successfully created)
              4. Added the upgraded RH7 project to version control (in new location).
              5. Life was business as usual.

              Thanks,
              K