6 Replies Latest reply on Aug 27, 2008 1:37 AM by Peter Grainge

    Em Dashes Revisited

    km_canney
      When I first upgraded to RH7, I noticed that all the em dashes in the projects I converted from RH2002 to RH7 displayed as &emdash; in my compiled help.

      The updates seem to have fixed that problem when converting/upgrading projects, but em dash support is still horribly (and frustratingly broken) for em dashes that I add when writing new content in RoboHelp 7.

      To add an em dash, I hold ALT and press 0151 on my numeric keypad. It's quick, and it works in every other application I've ever used. In fact, RoboHelp 7 makes me think it'll work in RH7, too, because the em dash displays correctly in the Design pane. However, when I run my compiled help, I see the dreaded &emdash; instead of my em dash.

      Yes, I could go to Insert > HTML > Symbol and then choose Em Dash, but that's incredibly clunky. I could also do a universal find/replace to replace &emdash; with <symbol name="Em Dash"><robohelp>&#8212;</robohelp> before I ship a help file, but that seems silly.

      If RoboHelp needs <symbol name="Em Dash"><robohelp>&#8212;</robohelp> why can't it just add that tag set when I hit ALT+0151?

      Frustrated,
      -kmcanney

      P.S. I know we were all glad to see Kadov tags go away, but how are these <robohelp> tags any better?
        • 1. Re: Em Dashes Revisited
          Peter Grainge Adobe Community Professional (Moderator)
          I suspect it is the font you are using.

          I just tried inserting using ALT 0151 and it works fine with both webhelp and CHMs. That was using Arial.

          The kadov tags ended up in the output, the robohelp tags don't. That's the important difference. Other tools use similar tags in the same way.

          • 2. Re: Em Dashes Revisited
            km_canney Level 1
            Thanks for checking in, Peter.

            It's definitely not the font. I used every available font on my system, and I was still seeing &emdash;.

            Interestingly enough, we have another RH installation that doesn't exhibit the em dash problem (nor the problem I noted in another post that prevented me from typing a numeric value in the Font Size combo box).

            The combination led me to suspect that my installation might be corrupt, so I uninstalled RH7 using Control Panel > Programs and Features. After uninstalling, running the RH installer prompted me to repair or remove my installation, and I saw that all the installation files had been left behind. I let RoboHelp do the uninstallation this time, reinstalled, and then applied the 7.0.1 and 7.0.2 patches. The problem persisted.

            I uninstalled again, deleted left-behind files again, reinstalled and went straight to the 7.0.2 patch. The problem persisted.

            We shared my coworker's program folder across the network, and I ran Beyond Compare on the two installation folders. Since we both had 7.0.2, I expected to see most files in sync. Not so. Many of the files in my C:\Program Files\Adobe\Adobe RoboHelp 7 folder were from 9/2007. It seems that the updater hadn't updated many of my files (including many DLLs in the C:\Program Files\Adobe\Adobe RoboHelp 7\RoboHTML folder).

            Using brute force, I updated my installation with the files from my coworker's, and all is now shiny and happy.

            Seems that something's quirky in the install/update behavior. We'll have to see what happens if/when a 7.0.3 patch is released.

            Thanks,
            -Kevin
            • 3. Re: Em Dashes Revisited
              WillieGWilliams
              Hi Kim,

              Did you solve this "emdash" problem? We, too, are running into it. We have a large help system (several hundred topics), and in the two releases we've used RoboHelp 7 for, these "&emdash;" strings have polluted our output in what almost seems a random, sporadic fashion. It's not just emdashes, it's other entirtes too (quotes, en dashes, etc.).

              At first I thought it was confined to topics we imported from FrameMaker. But it also happens with files that originated as RoboHelp files. I've been using the same remedy as you (Insert > HTML > Symbol). I think this has to be a RoboHelp bug.

              Please let me know if you solve this.

              - Willie
              • 4. Re: Em Dashes Revisited
                Peter Grainge Adobe Community Professional (Moderator)
                Willie

                Did you pick up that in Kevin's case it was just his PC that had this problem? For his colleagues it was fine. Do you have the patches applied as that is critical?

                • 5. Re: Em Dashes Revisited
                  WillieGWilliams Level 1
                  Doh! Not only did I miss the patch info, but I mistook Kevin's name (thinking kmcarney was "Kim").

                  We are on 7.0.2.001 (AdobeIP#0000370). We share a server, reserving timeslots and going in one-at-a-time. I'm pretty sure the problem isn't being caused by just one of us--many files in different areas of the help are showing "&emdash;" instead of the emdash symbol, and we're having the quote entities problem I saw in another post.

                  I'll talk to the boss about applying the 7.0.3 patch on the server (is it available yet?).

                  - Willie
                  • 6. Re: Em Dashes Revisited
                    Peter Grainge Adobe Community Professional (Moderator)
                    Kevin was speculating that a patch 7.0.3 would be issued and there is no such patch yet.

                    The existing patches do not repair the problem with projects upgraded before they were installed. You have to upgrade again or clean up manually. See Using RH7 on my site.