3 Replies Latest reply on Jun 18, 2009 9:46 PM by Adolfo Rozenfeld

    Trapcode Particular: Keeping the same amount of particles from start to finish?

    RaycerX Level 1

      I'd like to move some particles along a motion path, but I need them to start and finish with the same amount.  What I'm doing is moving a "comet" along a motion path. The particles making up the comet are custom particles of a logo element that I want to move throughout a specific scene.

       

      That part is no problem. I'm just having problems creating - say - 50 particles - and keeping that number from start to finish. Right now the comet keeps emitting new particles. Any setting I've tried either removes or adds too many particles or changes the shape of the emitter. Nothing I've tried seems to work.

       

      Any advice would be much appreciated.

       

      Thanks,  Ray

        • 1. Re: Trapcode Particular: Keeping the same amount of particles from start to finish?
          Mylenium Most Valuable Participant

          Should be no problem by keyframing the parameters, so it's not clear to me where you are having problems. The simplest way to get an exact number would be to use a Layer Grid emitter - set it to the desired x and y density in the Options, then set the number of particles to match that value (which apparently only can be x multiplied with y), then animate the Particles/sec. property to only give one burst, e.g. by setting the number to a few 100 first and after only 5 frames animating it to zero. During those five frames all particles should have had a chnace to be born. For the actual path simply use the Motion Path option in the Air physics model based on a light. Either that or you will have to balance out the Inherit Velocity from Motion option with Air Resistance so the particles seem to swarm around the emitter. Likewise, you could use a Radial Field to capture and constrain them...

           

          Mylenium

          • 2. Re: Trapcode Particular: Keeping the same amount of particles from start to finish?
            RaycerX Level 1

            Thanks for the advice, Mylenium.

             

            Before you replied I think I was able to figure the problem out. What I did was 1) Create a keyframe for particles per second. I set it to 75. I then jumped ahead one frame and changed the particles per second to 0. That seemed to do the trick. I then started my animation from that second keyframe and all was well.

             

            I still having issues trying to bend Particular to my will, but each day I learn a little more.

             

            Thanks again for your help.

             

            Ray

            • 3. Re: Trapcode Particular: Keeping the same amount of particles from start to finish?
              Adolfo Rozenfeld Adobe Employee

              I just found out that I don't have Particular installed right now, so I can't check the actual terms.

              But in the options dialog there's something like a "pre-run"  of particles, ie a number of particles that exist before frame 0.

              So, you should be able to have just those particles and not spit any more.