17 Replies Latest reply on May 30, 2011 3:57 AM by EileenPalsson

    BugHunter Woes

    RHGrace Level 1

      Please help me solve this problem. I've used RH7 to convert a Help project from WinHelp to HTML Help. BugHunter worked fine for the WinHelp project. I have now enabled it, and the Test HTML Help API function seems to work fine. However, when I open the application and call up CSH, the Help topics appear but the Output View shows no details about the call. Any ideas?

       

       

       

       

      Lacona

        • 1. Re: BugHunter Woes
          Peter Grainge Adobe Community Professional (Moderator)

          No other solution has been posted and it doesn't always work. I am suffering this too.

           

          The more people who report a bug or request a feature, the more likely it is to be actioned. Please follow this link.

           

          http://www.Adobe.com/cfusion/mmform/index.cfm?name=wishform&product=38

           

          I hope this one gets fixed soon.

           


          See www.grainge.org for RoboHelp and Authoring tips

          • 2. Re: BugHunter Woes
            RHGrace Level 1

            Peter,

             

            Am I reading your response incorrectly? When you say, "No other solution has been posted, and it doesn't always work," it sounds like one solution was posted that works sometimes. If so, I didn't get that solution.

             

            Yes, I'll be glad to report this as a bug. I also hope it's gets fixed soon!

             

            Lacona

            • 3. Re: BugHunter Woes
              Peter Grainge Adobe Community Professional (Moderator)

              Right reply to the wrong post. Sorry.

               


              See www.grainge.org for RoboHelp and Authoring tips

              • 4. Re: BugHunter Woes
                RHGrace Level 1

                No problem, but is there no response to my post? No one has responded, and

                no one responded to the question when someone else posted it last

                year either.

                • 5. Re: BugHunter Woes
                  RoboWizard Level 4

                  Hi there

                   

                  Sorry, but dem's de breaks! Some of us are intimately familiar with most of the features. BugHunter appears to be one of those features that falls into the "more obscure" and not many folks use it and are able to offer help. Or perhaps the folks that DO know how to use it and do what you want are simply busy and not looking at the forums.

                   

                  This is, after all, user to user support for the most part. And it is also Friday afternoon!

                   

                  Cheers... Rick

                   

                   

                  • 6. Re: BugHunter Woes
                    RHGrace Level 1

                    Thanks, Rick! Good points about obscure feature and Friday afternoon. I'll be more patient and try work-arounds as well.

                     


                    Have a great weekend!

                     


                    Lacona

                    • 7. Re: BugHunter Woes
                      RoboWizard Level 4

                      Hi there

                       

                      You have a good one too!

                       

                      FWIW, I'd love to help you out. The problem is, I've been using RoboHelp since 1992. In all that time I think I've opened the BugHunter two or three times. It's certainly not something covered during a typical RoboHelp HTML class.

                       

                      Cheers... Rick

                       

                       

                      • 8. Re: BugHunter Woes
                        RHGrace Level 1

                        In case anyone else has problems with RH HTML Help BugHunter capturing data, it has begun to work for me. After enabling BugHunter, accessing the Help in the app and finding BugHunter showed no data, I right-clicked and opened and closed the Annotation, Test HTML Help API, and Options dialogs. I then accessed the Help in the app again, and there was data on the BugHunter pod! Somehow playing with it awhile "wakes up" the tool.

                         

                        Cheers,

                        Lacona

                        • 10. Re: BugHunter Woes
                          Mary Ditter

                          Bug Hunter, although enabled, won't report anything for me. Right click menu choices had no effect on the performance.

                           

                          This is a feature that I used all the time in WinHelp, and really need it to work here. We have a pretty complex application with many ids. Trying to weed through these ids in the *.h files provided by developers is not quick or easy. It would be so much nicer to be able to trap the id with bug hunter.

                           

                          I also reported this as a bug, as suggested by Peter.  Any further clues on how you got this working Lacona?

                           

                          Looking for answers,

                          Mary

                          • 11. Re: BugHunter Woes
                            RHGrace Level 1

                            Well, this is odd, but I downloaded a free version of Microsoft Help to see

                            if their similar tool would work with RH. It didn't, but after that

                            BugHunter worked! I have no idea if there was a missing file in RH that the

                            Microsoft Help supplied or what. You might try it.

                             

                            Let me know if you can get it work, Mary. Best wishes,

                             

                            Lacona

                            • 12. Re: BugHunter Woes
                              Mary Ditter Level 1

                              Alas, downloading Microsoft Help made no difference. Thanks for the input, tho.

                               

                              Enjoy your weekend,

                              Mary

                              • 13. Re: BugHunter Woes
                                Eager Beager Level 1

                                Okay, I believe that I have a solution that people can try. Unfortunately, I’m working on deduction here, rather than an explicit technical note.

                                For the microsoft link, it might be subject to change. The keywords that I used to find the information were: “html help workshop download”

                                 

                                1.  Download the latest approved HTML Help Workshop ( Htmlhelp.exe )

                                http://msdn.microsoft.com/en-us/library/ms669985(VS.85).aspx

                                Note their comment: The latest version of HTML Help Workshop is 1.3. As of June 2009 there is no HTML Help Workshop 1.4

                                 

                                2. After installing the Htmlhelp.exe, go Start menu >> All Programs >> HTML Help Workshop >> HTML Help Workshop.

                                 

                                3. From the View menu, choose Compiled Help File, and then use the Browse button to indicate your CHM file.

                                 

                                4. Again from the View menu, choose HTML Help Messages. This will open a “bughunter”-like pane that many of you should recognize the purpose thereof.

                                Note that after you open this pane, the View menu >> HTML Help Messages item will be hidden (source of confusion).

                                 

                                5. Launch the application for which you had compiled your CHM help project, and test a few help calls. The “bughunter”-like window should capture and display the help call IDs.

                                 

                                6. Okay, now close HTML Help Workshop. RoboHelp will complain if the workshop window is left open.

                                7. Launch your RoboHelp project.

                                8. Now, BugHunter might appear to be enabled, though it isn’t. So right-click the BugHunter pane and choose Enable BugHunter a couple times. Just toggle it OFF and then back ON again to be certain.

                                9. Finally, go to your application and test a few help calls. The BugHunter should be capturing the calls now.

                                 

                                If I were to posit a theory, then I’d say that HTML Help Workshop is updating something in the Windows Registry that is overlooked during initialization of the RoboHelp BugHunter. I seem to recall years ago having to at least install the workshop to get the functionality working, though it’s only in recent terms that I encountered this issue with a new laptop.

                                 

                                Hope that helps….

                                • 14. Re: BugHunter Woes
                                  Mary Ditter Level 1

                                  Thanks Eager Beager;

                                   

                                  Your suggestion worked very well for me. It also never occurred to me that I
                                  could trap the CS IDs using HTML Help Workshop, too. So now I have two ways
                                  to get the job done.

                                   

                                  I agree with your theory on what is happening, although I didn't check the
                                  Registry before and after to verify it. Your theory might also be applied to
                                  other programs with registry issues on Vista.

                                   

                                  Thanks also for taking the time to write down the solution and post it. It
                                  has solved this issue for me and helped me very much!
                                  Mary

                                  • 15. Re: BugHunter Woes
                                    RHGrace Level 1

                                    I also got a new laptop and am finally getting back to this problem and testing your solution, which is similar to what I stumbled upon the first time. Thanks for taking the time to document everything for the rest of us!

                                     

                                     

                                    I do seem to have a couple of wrinkles here, though. First, I guess I had previously installed Workshop 1.4 and cannot seem to uninstall it. When I attempt to install 1.3, I get the message that there is a newer version installed on my computer. I uninstall Workshop and delete all remaining files, and yet I get the same message again. 1.4 does not work, and BugHunter does not work after I've attempted to use 1.4. I cannot find any info on any Microsoft site to troubleshoot uninstalling 1.4. I know it's not a RH issue and don't expect any help from this forum. I just wanted to mention it in case others have the same difficulty.

                                     

                                    I don't have to use BugHunter right now, so I'll wait and see if Microsoft resolves this in a future 1.3 update.

                                     

                                    Cheers,

                                    Lacona

                                    • 16. Re: BugHunter Woes
                                      Eager Beager Level 1

                                       

                                      Okay, it looks like you uninstalled HTML Help Workshop in the correct manner, i.e., per the following:

                                       

                                      1. Go Start menu >> Control Panel >> Add or Remove Programs.
                                      2. In the list of installed programs, select "HTML Help Workshop" and remove it.

                                       

                                       

                                      The only simple thing I could suggest at this point is to restart Windows after uninstalling 1.4, and (again) restart Windows after uninstalling the 1.3 version. Thereafter, ignore the "Workshop 1.4 already installed" warning, and methodically work through my steps again.

                                       

                                      My (overly) cautious reasoning is that this help building functionality has been in Windows for a long time, and there might be something in the system that isn't getting updated properly.

                                       

                                       

                                      The other thing to try is simply rebuild your CHM project. My apologies if my thoughts sound simplistic, as I am in the habit of trying to catch the simple steps.

                                       

                                      Regards...

                                      • 17. Re: BugHunter Woes
                                        EileenPalsson Level 1

                                        There is a solution to the problem described by the original poster in another thread:

                                        http://forums.adobe.com/message/3708620#3708620

                                         

                                        At least, it worked on my PC (RoboHelp 8.0.2 on a 32-bit Windows 7 machine).

                                         

                                        /Eileen