1 Reply Latest reply on Jun 21, 2009 5:49 PM by Ned Murphy

    Help with buttons/actionscript

    bschneid

      I've got a movieclip acting as a button.  Code on the button itself handles roll-over/-out states, and I define an onRelease function in the main timeline as follows:

      backBut.onRelease=function(){

           gotoAndPlay(1);

      }

       

      This code takes the movie back to the first frame and works on the third frame.  For some reason, though, the same code on the fifth frame has no effect.  The button doesn't do anything.  I have tried using the same button, I tried inserting a new keyframe with a new button, renaming the button, etc. and for some reason I just can't get it to work on the fifth frame.

       

      If it helps to visualize, I am essentially making a menu.  The first frame contains buttons to take you to submenus, located on following slides.  This button to go back to the original menu is on each frame with a submenu, but for some reason only works on one of them.  Thanks in advance for your help.

        • 1. Re: Help with buttons/actionscript
          Ned Murphy Adobe Community Professional & MVP

          Try moving that button in frame 5 to it's own layer.  If it's the same llibrary symbol, what happens is the name from the preceding instance gets inherited, along with other characteristics.  If frame 4 doesn't do anything, instead of a new layer, just try putting a blank keyframe between the buttons in frames 3 and 5.  This may not be the problem at all, but it's my first guess at the possible problem.