9 Replies Latest reply on Jun 26, 2009 1:24 PM by the_wine_snob

    Generic error with Photoshop files

    LSLawler

      I'm encountering the "generic error" message when trying to re-link simple layered Photoshop images to my PPCS4 file. This has happened only starting today after using the "Edit Original" command. I am still on version 4.0.0.

       

      Thanks for your help in advance.

        • 1. Re: Generic error with Photoshop files
          Harm Millaard Level 7

          Maybe updating will help.

          • 2. Re: Generic error with Photoshop files
            the_wine_snob Level 9

            What was the process that you used, when you did the Edit Originals in PS? After the changes, did you just do a Save, or a Save_As? I'm trying to find out why you are having to re-Link the files, as they should stay linked.

             

            What is the size of the PS files in pixels? Since you mention Layered PS files, did you Import as a Sequence?

             

            Maybe something in the workflow will throw up a red flag. Also, have you considered updating to 4.1?

             

            Good luck,

             

            Hunt

            • 3. Re: Generic error with Photoshop files
              LSLawler Level 1

              I found that several others had similar "generic error" problems after updating to 4.1, so I wasn't sure if I should do that yet.

               

              Hunt: After editing the original Photoshop file, I just did a save, not save as. The file was imported as separate layers, as I need each layer separately (these are lower thirds wherein I use a common bar and use text from different layers).

              • 4. Re: Generic error with Photoshop files
                the_wine_snob Level 9

                OK, sounds like you're doing the right thing, regarding Edit in Photoshop and then Save.

                 

                Hm-m, maybe someone else will see an issue with this.

                 

                Good luck,

                 

                Hunt

                • 6. Re: Generic error with Photoshop files
                  LSLawler Level 1

                  I've had the updates installed, but am still having the problem. I've passed on the troubleshooting link to our IT department, and hopefully they will be able to help.

                   

                  Thank you very much for all of your input.

                  • 7. Re: Generic error with Photoshop files
                    the_wine_snob Level 9

                    Just a shot in the dark here. Back in Photoshop, when you did a Save/Save_As, did you check "Compatibility?" Many say that with later versions of PS and also later programs that use the .PSD files, one should not have to worry, as this ONLY affects backward compatibility with older versions of PS. Well, I have issues with InDesign of the same version # as my PS, and it demands that I have Compatibility checked, before it'll Import/Place .PSD's. Everyone says that I'm crazy, and it cannot work this way, but when I do have Compatibility on for the Save/Save_As, they work, and without it, they do not. Might be worth a try, while you're waiting for IT.

                     

                    Good luck,

                     

                    Hunt

                    • 8. Re: Generic error with Photoshop files
                      LSLawler Level 1

                      I don't know whether I do, but I'm only having this problem with some of the layers in this file. The other layers are acting as they should be.

                      • 9. Re: Generic error with Photoshop files
                        the_wine_snob Level 9

                        OK, I did not remember that. What is different about those Layers? Any SmartObjects, or similar? I've had some SmartObjects that worked fine, and other that I had to rasterize for PrPro. Do you have any Adjustment Layers attached to any of those? Might have to Merge the Adjustment Layers and do a Save_As (try with Compatibility), so you still have the version without the Merged Adjustment Layers. Any heavy Styles on those Layers?

                         

                        If you're still stuck, don't hesitate to e-mail me one of the offending PSD's and I'll try an Import/Edit_in_Photoshop, and will look to see if I can find something amiss with it. You can send it as an attachment to info AT huntphoto.com. [Obviously, the "AT" becomes the @ symbol and no spaces before, or after it.]

                         

                        Just thinking here,

                         

                        Hunt

                         

                        [Edit] More just thinking, after re-reading the entire thread: what happens if, instead of doing the Edit_in_Photoshop, you do the edits manually, but opening the file from the HDD in PS, editing, and then do a Save_As with an incremented file name, then Import the new PSD and replace the original one in the Timeline? Same error?

                         

                        I'd forgotten that you were doing the Edit_in_PS. Says so right in your original post, duh!