3 Replies Latest reply on Jul 20, 2009 8:06 AM by Amal Elaine

    embedding a schema discoveries

    Amal Elaine Level 1

      We are starting to poke around with processes, and we ran across the following issues:

       

      1)  Adding a schema:  When we added a schema to a form that contains fragments, suddenly the fragment fields became visible and editable from the form.  The fields in the fragment are normally not editable unless you edit the fragment. (Designer)

       

      2)  Embedding a schema:  While we were testing a process we had the schema embedded.  Then we wanted to remove the schema entirely.  So we opened the form and deleted the schema data connection.  However when we examined the xfa form variable (and selected the reload schema from form option), we received a pop-up error (sorry, can't remember what it said at this point).  We ended up having to delete the xfa form variable and create a new one.  Which is not fun when you are using a custom render and have to reassign all of those service inputs.  But that's for another thread.

       

      Any thoughts?

       

      Thanks,

      Elaine

        • 1. Re: embedding a schema discoveries
          Amal Elaine Level 1

          Well, the question below was posted to this forum and to adobeforums a few weeks back, and there's been no response from the pro's...just wondering if anyone can either acknowledge it as a problem or tell me that I'm all messed up.  I'll take either.  This is still a problem that we can duplicate and leaves us highly uncomfortable.  Please see original question below, thanks friends...

          • 2. Re: embedding a schema discoveries
            Ryan Lunka Level 3

            It's difficult to tell from your description exactly what you are doing to cause your problem.  It seems like your post is regarding two seperate issues dealing with schemas.  From what it sounds like to me, you may get a better response for #1 in the LiveCycle Designer forum, because that is definitely not a Workbench issue (remember, Workbench just runs Designer inside itself).

             

            Issue #2 seems to be a Workbench issue, but I'm not sure what exactly you are trying to say.  Could you try to explain that issue in more detail?  I (or someone) may be able to help you more.

             

            Ryan D. Lunka

            Cardinal Solutions Group

            rlunka@cardinalsolutions.com

            • 3. Re: embedding a schema discoveries
              Amal Elaine Level 1

              Thanks for your reply Ryan, I am currently off on family leave due to the

              passing of my father.  Next week I will respond more detailed to you.  I

              appreciatre your reply!

               

              Amal Elaine