5 Replies Latest reply on Jun 26, 2009 12:48 AM by Peter Grainge

    Index does not get generated in WebHelp output

    DerryWriter

      The index in my RoboHelp project was created using the Index Wizard. It looks fine in the project but does not show up in the output.

      When I Generate Primary Layout, the dialog box, WebHelp General...  shows the name of the index file (although it is grayed out).

      I am using RoboHelp 7.03.001 to generate a help system created from FrameMaker 8.0 files which are added to the project by reference.

       

      Any help would be appreciated!

       

      Thanks

        • 1. Re: Index does not get generated in WebHelp output
          Peter Grainge Adobe Community Professional (Moderator)

          The index is greyed out when there is only one index, same for TOC etc. So as long as your project does only have one index, that is normal. Check RH is only showing one index.

           

          When you add the FM topics, the dialog had an option to import the FM index. Did you tick that? Could there be a conflict there? Sorry I am not a FM user but that is one thought that occurs to me.

           

          Are you generating the output to a local drive?

           

          When you open the help, is there a yellow information bar above it?

           


          See www.grainge.org for RoboHelp and Authoring tips

          • 2. Re: Index does not get generated in WebHelp output
            DerryWriter Level 1

            Thanks for your suggestions.

             

            I tried to get the RoboHelp default project  index to be populated with entries from an Index of a FrameMaker book. This is what I did:

            When  importing an  ExampleBookIX.fm file, in the Contents Settings dialog box, I check mark Convert Index (and beside this selection is the name of the RoboHelp default index for my project) and then I selected Add to Existing Index.  Next the Style Setting dialog box opened. I checked to see whether the FrameMaker index Paragraph Styles might have been shown as "no output". But these seemed to be OK as .  The Import did not display any index entries from the FrameMaker book.

            Next I tried to populate the RoboHelp default project  index by importing a FrameMaker ExampleBookIX.fm file and use the option, Create New Associated Index, in the Content Settings dialog box. RoboHelp created the new index file in the project but it was blank.

             

            Yes I am generating the output to my hard drive.

            Yes when I open the help, there is initially a yellow information bar saying "To help protect your security, Internet Explorer restricted..." And then I select the option to Allow Blocked Content.

            • 3. Re: Index does not get generated in WebHelp output
              Peter Grainge Adobe Community Professional (Moderator)

              In an example I was sent recently, there was a .book file that referenced the .fm files that included an index. That worked OK when adding by reference. I am not sure if that approach makes a difference. I don't work with FM so not sure.

               


              However, you are importing so RH is creating topics and then you are auto generating an index. You see the index in RH Project Manager with entries but you don't see them in the output. Is there an index button / tab in the output?

               


              See www.grainge.org for RoboHelp and Authoring tips

              • 4. Re: Index does not get generated in WebHelp output
                DerryWriter Level 1

                In the output of my WebHelp project there is an index button on the toolbar and there is also a text box under it with the text: Type in the keyword to find:.

                 

                I did a test RoboHelp HTML project with one book from my real project which contains 16 books. The index was created using the Smart Index Wizard and after generated the Index pane in the output is showing all the entries.

                 

                It seems that the size of my project may be the issue? My project folder is 189 MB with 9116 files, and 304 folders.

                • 5. Re: Index does not get generated in WebHelp output
                  Peter Grainge Adobe Community Professional (Moderator)

                  Yes that is a large project but it should not prevent the index from working, albeit slowly.

                   

                  Am I right in understanding you get an index if you create a small project but not in the full project. I am tempted to suggest you import some more books and keep testing after each two or three books to see if it falls over or fixes the problem.

                   

                  Did you try renaming the CPD file and then reopening the original project at any point? Worth a shot given the alternative work.

                   


                  See www.grainge.org for RoboHelp and Authoring tips