6 Replies Latest reply on Jun 27, 2009 12:50 PM by ElliR

    Problem with Elements 5 and DNG 5.4 converter.

    copa1970

                     Never been in this forum, but in a photo site that i do participate they told me i could ask it here...So, can anyone tell me if the new dng converter-5.4, convert dng files that cannot be open in photoshop elements 5? The previous version converted raw from panasonic G1 fine(but turned the files into 40MB ones)...now it converts into 12mb files, but photoshop is not opening them....Thanks a lot for any inputs...

        • 1. Re: Problem with Elements 5 and DNG 5.4 converter.
          Thomas Knoll Level 2

          In the DNG Converter 5.4, press the "Change Preferences..." button.  Change the "Compatibility" popup to "Camera Raw 2.4 and later".  The resulting DNG files will then open just fine in Elements 5, for all camera models.

           

          For some camera models (such as your G1), this will result in larger DNG files (like previous versions of the DNG converter) because more processing needs to be done on the file before saving.

          • 2. Re: Problem with Elements 5 and DNG 5.4 converter.
            ElliR Level 2

            Thomas, I wonder if you would be so kind as to explain the reasoning behind the need for this compatability option? This option is also buried away in the Lightroom preferences and a user might easily be forgiven for not noticing it during the simple version upgrade proceedure. Surely most users (those that notice it that is) are going to opt for the 2.4 and up option if they want to guarantee being able to open their DNG files some years along the line so what purpose do the other three options fulfill?

            • 3. Re: Problem with Elements 5 and DNG 5.4 converter.
              Thomas Knoll Level 2

              For some camera models, setting the Compatibility popup to an older version of Camera Raw will force it to convert the file to linear mode (a fully demosaiced image), so that an older version of Camera Raw will be able to open the image.  If this happens, the resulting DNG file is larger than it would otherwise be, and you lose the ability to take advantage of newly developed demosaic algorithms, which might result in better results in the future.

               

              So don't set the Compatibility popup to a version lower than you need to.   Unless you are in the habit of installing older and older versions of Adobe software as time goes on, I don't see any reason to worry about future compatibility.

              • 4. Re: Problem with Elements 5 and DNG 5.4 converter.
                ElliR Level 2

                Thanks for the further explanation Thomas. Just a final point, I would just like to be reassured that by setting 5.4 and above I shall be able to open any RAW files taken with my Canon 40D and SX1 IS that have been converted to DNG in future versions of Lightroom (presently running v2.4) and Photoshop (currently running CS4).

                • 5. Re: Problem with Elements 5 and DNG 5.4 converter.
                  Thomas Knoll Level 2

                  The popup contains the words "and later".  This means this version, and any future version with a higher version number.