10 Replies Latest reply on Mar 24, 2010 1:49 PM by Scott Townsend

    RoboHelp 8 crashing with SQL Server Express error

    MDBennet Level 1

      RoboHelp 8 appears to start up and run, but then hangs after the project is loaded.


      When I first recreate a project and open it in RoboHelp 8, I can work with it, and then generate it. Once the project has been generated, however, RoboHelp hangs and deletes numerous .html files from the source directories on my hard drive.


      Error message:


      The Event Viewer message says:


      The SQL Server (SQLEXPRESS) service terminated with service-specific error 17051 (0x429B).






      What I've tried so far:


      Deleted the .xpj file and recreated the project by copying in an .xpj file from an earlier project. Project appears to run until after it's generated. Once it's generated, RoboHelp hangs and deletes .html files.


      Deleted the .cpd file


      Uninstalled and reinstalled RoboHelp 8

        • 1. Re: RoboHelp 8 crashing with SQL Server Express error
          RoboColum(n) Level 5

          Hold on! You seem to have RH installed over a network. Is that correct? If so, not only is this against the licence agreement but I'm also not surprised you are running into problems. RH must be installed on a local PC. You can always backup your source files to a network drive if this is what you are concerned with.


          Read the RoboColum(n) for mutterings on RoboHelp, Technical Communication Suite and technical communication.

          • 2. Re: RoboHelp 8 crashing with SQL Server Express error
            MDBennet Level 1

            RoboHelp is not installed over a network. Technical Suite 2 is installed on my local hard drive with a fully legal, paid-for license.

            • 3. Re: RoboHelp 8 crashing with SQL Server Express error
              Peter Grainge Adobe Community Professional (Moderator)

              I have a nagging feeling someone else reported a similar situation in the last month or so.


              Try some searching and see what you can find. Post back if no luck.


              See www.grainge.org for RoboHelp and Authoring tips

              • 4. Re: RoboHelp 8 crashing with SQL Server Express error
                MDBennet Level 1

                Yes, I've read several posts about similar issues. I am experiencing the same problem -- RoboHelp works fine until a project is generated, then hangs afterward and deletes source files. None of the possible reasons from the other posts fit my circumstances, however.


                Just before this happened, I had updated an older project in RH 7, and then worked in a different project in RH 8. The crashes began after that. Maybe this is an incompatibility problem with earlier versions of RoboHelp?


                The xpj file is now corrupt -- RH 8 can't recognize it.


                I created an entirely new project from scratch with only a few imported topics and 2 template files -- all was well. Then I generated the project, closed and reopened RoboHelp. Crash.

                • 5. Re: RoboHelp 8 crashing with SQL Server Express error
                  Captiv8r Adobe Community Professional & MVP

                  Hi there


                  Personally, I'd be heavily scrutinizing exactly WHERE you are generating the files to. I'm getting a sense that maybe this is part of the issue.


                  By default it should be generating to a specific folder inside the !SSL!. I personally don't recommend changing that unless you have good reason to do so, but you may point that anywhere.


                  Can you post a screen capture of the first page of the generation wizard? Please insert using the Camera icon as shown below.




                  Cheers... Rick



                  Helpful and Handy Links

                  • 6. Re: RoboHelp 8 crashing with SQL Server Express error
                    MDBennet Level 1

                    I am generating the project to the default !SSL! directory location.



                    • 7. Re: RoboHelp 8 crashing with SQL Server Express error
                      johndaigle Level 4

                      Hi, MDBennet

                      I hope I'm not creating a wild goose chase here, but what is nagging me is why it is throwing an SQL Server Express error in the first place.

                      To my knowledge, the RH authoring client does not use SQL Server Express.


                      However, if authors elect to use the optional RoboSource Control, they often use SQL Server Express (the MS freebie) for the database that serves RoboSource Control. You mentioned that this RH 8 project originated in RH 7. I was wondering if the original project was somehow part of RoboSource Control and perhaps some references/links to that source control came in as artifacts from that project are conflicting with the new project?


                      Couple other questions. When you say Event Viewer I'm assuming you're referring to the Windows Event Viewer and not referring to the Output View text in RH itself. Also, could you clarify "copying in an .xpj file." Normally you would not copy an .xpj file from one project to another. You would simply back up the project and open the .xpj in RH 8 and be good to go.


                      Just grasping here...


                      • 8. Re: RoboHelp 8 crashing with SQL Server Express error
                        MDBennet Level 1

                        Yes, I am referring to Microsoft Administrative Tools > Event Viewer.


                        I am not using RoboSource Control. I do not even have it installed. I am using SourceGear Vault for source control.


                        By copying an xpj file -- I mean that I had a nearly duplicate project that appeared to be working correctly in RoboHelp (all of my projects have the same name, but are in separate version folders). After my newer project crashed, I "rebuilt" the newer project by copying the xpj file from the first folder into the second folder (all of the project naming conventions are the same between projects). I opened the newer project (using the copied xpj file), and imported the new .htm and .hts files into the project. All was well until I generated the project.

                        • 9. Re: RoboHelp 8 crashing with SQL Server Express error
                          Gravenstein Level 2

                          If you are using *any* source control, your xpj file might still have been carrying the original source control connection information from the other project. Same with your cpd file. Try following the instructions below for removing a project from source control, and then try generating your output again.




                          Removing a project from (Robo)Source Control:


                          1. Make a backup of the project.

                          2. Delete these files:

                              - pblsvrs.sss

                              - projectname.cpd

                              - mssccprj.scc (this is present in older projects only)

                          3. Using Notepad, open projectname.xpj.

                          4. Delete all entries between <miscproperties> and </miscproperties>, but leave both tags.

                          5. Save and close the xpj file.

                          6. Open the project in RH.

                          • 10. Re: RoboHelp 8 crashing with SQL Server Express error
                            Scott Townsend Level 1

                            SourceGear Vault is using SQL Server 2005 Express as its back-end for source file storage. That's the connection between RoboHelp, Vault, and SQL Server.


                            SourceGear's official policy is that Vault does NOT support RoboHelp. In fact, RoboHelp 7 or 8 crashes down in the VaultIDE.dll when you try to Add to Version Control from within RoboHelp. The funny thing is that RoboHelp works fine with other SCC providers (SourceSafe, Surround SCM). Hopefully SourceGear will fix this soon?