4 Replies Latest reply on Jul 9, 2009 5:21 PM by DawMatt

    2.4 Vista

    john beardsworth Adobe Community Professional & MVP

      Is there a known problem installing plug-ins under 2.4. A user has reported this error in the Plugin Manager:


      Could not add menu item for this plugin

      assertion failed!

       

      Anything known?

       

      John

        • 1. Re: 2.4 Vista
          john beardsworth Adobe Community Professional & MVP

          And as I posted, the user reported:

           

          I un-installed in LR and Added it back and the Plugin is happy with no error messages.

           

          Something isn't quite right

           

          John

          • 2. Re: 2.4 Vista
            escouten Adobe Employee

            This isn't something I've heard of before. If you (or anyone listening) gets more details on how to reproduce this, I'd love to hear about it.

            • 3. Re: 2.4 Vista
              john beardsworth Adobe Community Professional & MVP

              Thanks Eric. I phrased it as I did because I'm sure I heard someone else's plug-in had hit a similar issue. If I can find where I read it, I'll update you. In my user's case, it was a first time install under 2.4 and I'll ask him to install another of my plug-ins to see if it recurs.

               

              John

              • 4. Re: 2.4 Vista
                DawMatt Level 3

                I recently had a user report an error that sounds related. He was using Vista + LR2.4.  The menu items appeared in Plugin Extras but he received an error when trying to access the menu item.  It was one of those error messages that are next to useless (can't pass nil to parameter ?, or some such) and no logging information was logged to file so it seemed outside of the scope of my code.  Restarting Lightroom didn't help.  Uninstalling and reinstalling the plugin fixed the problem.

                 

                I hadn't thought anymore about it because he had accidentally installed the beta originally, then when he uninstalled then installed the final version everything worked.  So obviously the upgrade had fixed it somehow (though I couldn't see how).  Reading this it sounds like this is another manifestation of this same issue.  No idea how to reproduce it though short of trying to install our plugins on clean machines until you stumble over the issue (not a very helpful suggestion, I know).

                 

                Matt