2 Replies Latest reply on Jun 27, 2009 2:34 AM by Mylenium

    CS4 will not create poly areas in image maps


      How do I create an image map which will contain polygonal areas? I've selected my shape and chosen "polygonal" in the Attributes palette and then given it a URL. When I create an image map from the file, all my map areas (in the HTML) are "rect" (rectangles), which is not what I want. Can someone talk me through how to create a polygonal image map area which successfully gets exported into the HTML?



        • 1. Re: CS4 will not create poly areas in image maps
          Wade_Zimmerman Level 7

          I am not an expert at this but I just created a polygon shape over a rectangle selected the polygon shape and added the url in the image map url field.

          then I used the slice to to make the rectangle a slice and then selected the polygon shape and made that a slice and exported as jpeg from the Save for Web and Device as both html and image in the jpeg format.


          all seemed to work the rectangle and the polygon are the same color so you can not see the shape but only the polygon shape seems selectable.


          I just changed the color and it does only make the polygon shape selectable


          here is a little video perhaps this will help.




          so let me see if I can summerazie what I did.


          I made a rectangle then I made a polygon shape over it. I selected the polygon and gave it the image map attribute with the url
          and save the file, I then  sliced the art first selecting the rectangle and clicking on the rectangle with the slice tool then select the polygon and clicked on that with the slice tool as well and save for the web as jpeg with image and html as the option.


          S that is what i did and it seems to work fine.

          • 2. Re: CS4 will not create poly areas in image maps
            Mylenium Most Valuable Participant

            Never tried in AI, I must admit. On a guess I would say that you haven't ungrouped/ released the paths in question, so to the exporter they appear as a normal boundíng box objects and it uses the rectangle type. You may also need to change the layer order to make the hotspot sections the topmost ones...