4 Replies Latest reply on Jun 30, 2009 8:23 AM by 988hfas9fhaf8

    Photoshop as primary editor

    988hfas9fhaf8

      Hi,

      I have Flash CS4 and whenever I right-click on an image to select "Edit with..." I get that annoying Micro$oft photo editor. Where do I change this so it will open images in Photoshop for editing?

        • 1. Re: Photoshop as primary editor
          kglad Adobe Community Professional & MVP

          use google to search for:   <your operating system> default programs

          • 2. Re: Photoshop as primary editor
            988hfas9fhaf8 Level 1

            This has to do with Flash, not my operating system.

             

            In Dreamweaver, there is a setting for the default photo editor.It appears to be the same in Flash, I just don't know how to change it to Photoshop.

            • 3. Re: Photoshop as primary editor
              kglad Adobe Community Professional & MVP

              when you click "edit with..", don't you get a file dialogue that lets you navigate to the executable of your choice?

              • 4. Re: Photoshop as primary editor
                988hfas9fhaf8 Level 1

                Of course not. It appears to be more complicated than that. That's why I was hoping the same company's forum could give me some insight on this issue.

                 

                I do apologise. Earlier, I misspoke about the exact option within the right-click menu. When right-clicking on an image in Flash CS4 to bring up the short menu, the only option for editing I see is "Edit with PHOTOED." I'm assuming Adobe knows of this, otherwise they wouldn't have given people the option. It was programmed that way. I thought they (Adobe) would easily allow one the option to change this, especially to a program that is within the CS4 suite.

                 

                I do know that some programmers didn't consider that operating systems sometimes override the program choices by default, much like with Microsoft Photo Editor which is a part of the MS Office Suite. However, this can be changed by going into the control panel settings and making that particular program unavailable, which I did. Unfortunately, this only works part of the time.

                 

                Maybe they just didn't code the program to handle images the same way they did with Dreamweaver?