10 Replies Latest reply: Aug 11, 2009 7:51 AM by Stewart Design RSS

    Acrobat Pro 9.1.2 dog-slow and using 100% CPU

    Stewart Design Community Member

      Any idea why Acrobat is so dog-slow? Is this a known issue or do I need to delete preferences or reinstall it? I can't seem to find any info on this from Google or on this forum.

       

      Also, if this can be resolved through deleting preferences, can someone please explain how?

       

      Mac 10.5.7

        • 1. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
          Phillip Jones Community Member

          Was it previously installed before switching to OSX.5. If so it may be using Rosetta compatibily.

           

          It possible you might have to remove and reinstall so that it runs in antive mode. Rossetta slows things down its PPC emulator for Intel Machines. I understand Rosetta can be turn of in th get info box for each application. Some will not run with it turned off but those written to take advantage of Intel Processor will notice a significant speed boost.

          • 2. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
            Stewart Design Community Member

            Thank you for your reply. I installed it originally on 10.5.4, and I hadn't had any issues prior to this latest update. (I'm not sure if the OSX 10.5.7 update might have done it, or if it's the fault of the latest Acrobat 9.1.2 update). I don't see any option to disable rosetta emulation. Every action or click has a 10 second or more delay in response.

             

            Can anyone explain how to 1) delete Acrobat preferences, 2) disable Rosetta emulation, or 3) are there any other suggestions short of 4) reinstalling to fix the slowness?

            • 3. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
              Phillip Jones Community Member

              Stewart Design wrote:

               

              Thank you for your reply. I installed it originally on 10.5.4, and I hadn't had any issues prior to this latest update. (I'm not sure if the OSX 10.5.7 update might have done it, or if it's the fault of the latest Acrobat 9.1.2 update). I don't see any option to disable rosetta emulation. Every action or click has a 10 second or more delay in response.

               

              Can anyone explain how to 1) delete Acrobat preferences, 2) disable Rosetta emulation, or 3) are there any other suggestions short of 4) reinstalling to fix the slowness?

              Here is some info on Rosetta:

               

              http://guides.macrumors.com/Rosetta

               

              http://blogs.zdnet.com/Apple/?p=176

               

               

              at to finding Preferences go to finder nd eithe click spolight and type in Acrobat everything related to Acrobat will show up including Preference and .plist files.

               

              IF Find file (which I like better) is still in X.5 click on File menu go to find and type acrobat. It shows where various files re located. While acrobat is closed:Pull the preference of .plist files out on to desktop. and restart  Acrobat. see if it improves speed. if no difference place back in original positition the file pulled to finder and allow it replace any newer files created.  another thing that slows down Acrobat is the font cache.  for acrobat or adobe. just throw that awy and empty trash it will be rebuilt. Sometimes minor corruption the cache can cause the problem.

               

              Also try going to Disk Utility and Try repairing permissions might help.

               

              Finally Download and install the Utility AppleJack and then run it in single User Mode Command-S (Apple or Cloverleaf key)-S. Note: besure to download specific version for OSX.5.

              run through all processes in order.  3 nd 4 you must run for both system and user.

               

              This may clear up problem as well.

              hope some of this info helps.

              • 4. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                Stewart Design Community Member

                Thank you for your recommendations. I tried each thing on your list, but it was still just as slow.

                 

                So I uninstalled it, and then reinstalled it to Acrobat Pro 9.0.0 - the version that came on the CD. It is STILL unusably slow!

                 

                Could this mean it has something to do with the Mac OS updates? Anyone have any other ideas?

                • 5. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                  Phillip Jones Community Member

                  I'll ask a question for you to answer here, then leave it up to someone else to chime in I am out of ideas.

                   

                  what do you mean by slow? Slow in general everything is slow? Or just creating PDF'? or Opening Pdf's

                   

                   

                  If you have Disk Warior (needs to be for X.5) or TechTool version for OSX.5 , You might try running and see if that will speed up matters.

                   

                  If that doesn't work, sounds like it could be some issue with X.5.7.

                   

                  BTW: What machine, and how much Hard drive space available? Also how much RAM.

                   

                  OSX.5 is fairly Ram intensive program. Maybe some additional memory is needed.

                   

                  I don't have any other suggestions, after these. Someone else will have to take over.

                  • 6. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                    Stewart Design Community Member

                    Phillip,

                     

                    thank you so much for your efforts to help. I have noticed a few strange things since reinstalling Acrobat 9.0.0:

                     

                    - If I launch Acrobat 9 Pro on its own without opening a file at the same time, it launches normally.

                     

                    - If I mouseover the menu options at the top of the screen without having a document open, it is responsive UNTIL I hit the "Help" menu, at which point it becomes very slow and unresponsive.

                     

                    - If I double-click a file to open in Acrobat 9, it takes ages to open the file, and is very sluggish.

                     

                    - If I mouseover the menu options at the top of the screen while a document open, it is very sluggish and unresponsive on each menu option.

                     

                    It seems that having ANY document open in Acrobat is causing it to slow down.

                     

                    My system:

                    Macbook Pro late 2008 model

                    4gb RAM

                    Acrobat 9.0.0

                     

                    I really appreciate all your help today. I'll probably have to call Adobe tomorrow for tech support help if I can't find any answer. This is very weird. I suspect it might be related to something in 10.5.7.

                    • 7. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                      Phillip Jones Community Member

                      Stewart Design wrote:

                       

                      Phillip,

                       

                      thank you so much for your efforts to help. I have noticed a few strange things since reinstalling Acrobat 9.0.0:

                       

                      - If I launch Acrobat 9 Pro on its own without opening a file at the same time, it launches normally.

                       

                      - If I mouseover the menu options at the top of the screen without having a document open, it is responsive UNTIL I hit the "Help" menu, at which point it becomes very slow and unresponsive.

                       

                      - If I double-click a file to open in Acrobat 9, it takes ages to open the file, and is very sluggish.

                       

                      - If I mouseover the menu options at the top of the screen while a document open, it is very sluggish and unresponsive on each menu option.

                       

                      It seems that having ANY document open in Acrobat is causing it to slow down.

                       

                      My system:

                      Macbook Pro late 2008 model

                      4gb RAM

                      Acrobat 9.0.0

                       

                      I really appreciate all your help today. I'll probably have to call Adobe tomorrow for tech support help if I can't find any answer. This is very weird. I suspect it might be related to something in 10.5.7.

                      You have plenty of Horsepower.

                       

                      Have tried that new backup feature in X.5 to rewind back to X.5.6. If so try rewinding back to OSX.5.6  and see  that improves matters. if so X.5.7 may indded be the problem. I don't how it works because I'm still usin X.4.11. If that is not the problem I have no more suggestions.  Sorry

                      • 8. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                        Stewart Design Community Member

                        I am coming back to this issue in the vain hope that someone will be able to help. I continue to have the same painfully slow performance problems in OSX 10.5.8 with Acrobat 9.0.2.

                         

                        Every click takes 30 seconds to register. Activity monitor shows 98% of CPU is taken by Acrobat. If I shut down every other running process and app, it doesn't help.

                         

                        After researching other peoples' slowdown problems, I have also tried:

                        - disabling "Check for Updates" under Preferences/General

                        - choosing "Don't Remember PDFs" under Preferences/Documents

                         

                        I've tried every other suggestion on this thread as well, to no avail. Anyone? Please?

                        • 9. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                          Phillip Jones Community Member

                          first, Acrobat is now up to 9.1.3.


                          You might need to a Utility such as, Oynx, or AppleJack.

                           

                          AppleJack is my Prefered Utility (Google to Find).

                           

                          once installed restart and hold down Command(cloverleaf/apple key) - S.

                           

                          This puts into sigle User Mode: once the black screen comes up and after text stops and you see a blinking cursor type AppleJack

                           

                          Follow menu Directions. you do 3 and 4 twice, onece for system and once for each User account.

                           

                          once out and restarted, will take a long time for computer to boot up as new cache files have to be created.

                           

                          This will fix strange problems.

                           

                          Make sure you download the version for X.5 (10.5) each version is customized fot each version of OSX.

                          • 10. Re: Acrobat Pro 9.1.2 dog-slow and using 100% CPU
                            Stewart Design Community Member

                            Phillip,

                             

                            Thank you for your reply. In the meantime, I called Adobe Tech support and they referred me to this technote: http://kb2.adobe.com/cps/403/kb403918.html

                             

                            And I'm pleased to say that thanks to that technote's list of troubleshooting tips, I have finally found the problem! The culprit is the Updater plugin. I disabled that in the plugins (Cmd-I on AcrobatPro, and uncheck "Updater.acroplugin" from the Plug-ins list. Now, it pops up just fine.

                             

                            I am SO RELIEVED this problem is finally resolved!