0 Replies Latest reply on Jul 2, 2009 3:17 PM by Nancy Gill

    load external url into browser from xml file consumed in a textarea component (AS2)

    Nancy Gill Level 1

      I have an application that I built around 2006 that has a Flash interface with a menubar, loader which loads jpgs into the page and a textarea component that loads an xml file depending on the menubar choice.  My client put in a ton of links to load different xml content onclick and I accomplished all of that using asfunction.  Now, my client has added some logos to an internal xml page to display gifs (which work fine with just the regular img tag) but now insists that they link to an external xml and open that site in a second browser.

       

      Here is what I have and it works .. sort of.  What is happening is that the first image that displays as a link is barely visible and the rest of the page is missing .. which tells me there is an error in code that is keeping the page from further rendering.

       

      The function I created in the FLA file is this:

       

      function launchSite(arg) {
        if(arg == "agri") {
          getURL("http://www.usda.gov/wps/portal/usdahome", "_blank");
        }
      };

       

      and in the xml file, I have this to form the link:

       

      <a href='asfunction:_root.launchSite,agri'>

       

      I originally had _parent rather than _root because it doesn't actually launch within the swf, but it doesn't seem to make a difference.  What I can see of the link actually does work if you click on the part you can get to, but the rest of the page is not displaying below the problem.

       

      Anyone have an idea how to fix this?

       

      Thanks,

      Nancy