7 Replies Latest reply on Mar 20, 2012 9:28 AM by sinious

    Flash file will not publish SWF

    Travis444 Level 1

      I am a novice when it comes to flash so please bare with me on this one.

      I have recently taken over a project started by another person who has been let go due to lack of performance and other issues.

       

      He has created a FLA file and an .exe file. But I am have been asked to place the movie on to the internet.

      The FLA file that I have will not let me publish an SWF file to be uploaded to the internet, in fact it will not let me publish anything.

      I have changed the publish setting but when I go to publish it the SWF file is not created.

       

      I just want this file in SWF format and for it to autoplay when the website is loaded.

      Let me know what I am doing wrong.

       

      Thanks for your Help in advanced

       

      Travis

       

      Extra Information:

      I have used a exe to swf converter to convert the EXE file that was already made into a SWF file for the internet.

      This does make an swf file but the file is not editable and will not autoplay once it is uploaded.

        • 1. Re: Flash file will not publish SWF
          Ned Murphy Adobe Community Professional & MVP

          The only thing I can currently imagine is that the swf file is being directed to some folder other than where you are looking for it.  Check the front page of the Publish Settings to see if the swf file path is where you expect the file to be created.

          • 2. Re: Flash file will not publish SWF
            Travis444 Level 1

            I have it directed to my desktop.

             

            When I hit publish a Demo.swf incon apperars then dissapears off the desktop before the file finishies publishing.

             

            I would upload the file to this forum but the file size is too large.

             

            I am able to edit the flash file but I am unable to publish the file in any format much less in swf.

             

            Thanks,

             

            Travis

            • 3. Re: Flash file will not publish SWF
              Travis444 Level 1

              I have the FLA file but it will not allow me to publish it in any format.

              I also have the ability to edit anything I like but I am still unable to publish the file.

               

              What should I do?

              • 4. Re: Flash file will not publish SWF
                marcy_ssss

                Any suggestions here? I am having the same problem (minus the part about .exe's):

                 

                http://forums.adobe.com/thread/465031?tstart=0

                 

                Double checked my publish settings, the path is correct. I have tried exporting a movie to my Desktop, does not work. Tried copying content to a new file, same problem. When I publish, the dialog shows up and a SWF even shows up for a second in the Finder, but then disappears.

                 

                I really need to work with this file. I have submitted a support ticket to Adobe, and am awaiting their reply (not holding my breath). Please HELP!

                • 5. Re: Flash file will not publish SWF
                  crooked_toe

                  I would check all imported images in the library. If you cannot see the image in your library preview; there is a good chance that there is an issue and it will need to be reimported.

                  • 6. Re: Flash file will not publish SWF
                    esdebon Level 4

                    Your antivirus, enabled and is a bad antivirus

                    • 7. Re: Flash file will not publish SWF
                      sinious Most Valuable Participant

                      Run the movie locally. CTRL+ENTER (Windows) or CMD+ENTER (Mac). See if it plays inside the flash environment. I feel you're probably getting an error due to Flash being unable to find some code it's looking for. Be sure to read any errors that come up.

                       

                      Typically you'd want to go to publish settings, click the wrench icon next to ActionScript 3.0 in the drop-down, check any SWC loaded in this panel (that it exists) and also click the Source Path tab and look for any listed code it's trying to load. Flash is notorious for keeping a full path directly to a file so when you hand a project to someone else it can't find the code, and you get errors during export.