2 Replies Latest reply on May 4, 2010 4:14 AM by Nuwaus

    Can not load resource modules compiled with sdk 4.0.0.8287+

    NotAFlexpert

      I get these warnings:

       

      Error #2032: Stream Error. URL: app:/locales/textLayout_4.0.0.8287.swf
      Failed to load RSL textLayout_4.0.0.8287.swf
      Failing over to RSL http://fpdownload.adobe.com/pub/swz/flex/4.0.0.8287/textLayout_4.0.0.8287.swf
      Warning: Ignoring 'secure' attribute in policy file from http://fpdownload.adobe.com/pub/swz/crossdomain.xml.  The 'secure' attribute is only permitted in HTTPS and socket policy files.  See http://www.adobe.com/go/strict_policy_files for details.

      Error #2032: Stream Error. URL: http://fpdownload.adobe.com/pub/swz/flex/4.0.0.8287/textLayout_4.0.0.8287.swf

       

      and this exception:

       

      Error: Unable to load resource module from locales/en_US.swf
          at <anonymous>()[E:\dev\trunk\frameworks\projects\framework\src\mx\resources\ResourceManager Impl.as:476]
          at flash.events::EventDispatcher/dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at ModuleInfoProxy/moduleEventHandler()[E:\dev\trunk\frameworks\projects\framework\src\mx\mo dules\ModuleManager.as:1136]
          at flash.events::EventDispatcher/dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at ModuleInfo/moduleErrorHandler()[E:\dev\trunk\frameworks\projects\framework\src\mx\modules \ModuleManager.as:804]
          at flash.events::EventDispatcher/dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at mx.core::FlexModuleFactory/update()
          at mx.core::FlexModuleFactory/displayError()
          at mx.core::FlexModuleFactory/rslErrorHandler()
          at mx.core::RSLListLoader/listIOErrorHandler()[E:\dev\trunk\frameworks\projects\framework\sr c\mx\core\RSLListLoader.as:286]
          at mx.core::RSLItem/itemErrorHandler()[E:\dev\trunk\frameworks\projects\framework\src\mx\cor e\RSLItem.as:262]
          at mx.core::CrossDomainRSLItem/itemErrorHandler()
          at flash.events::EventDispatcher/dispatchEventFunction()
          at flash.events::EventDispatcher/dispatchEvent()
          at flash.net::URLLoader/onComplete()

       

      when trying to load resource modules built with sdk 4.0.0.8287 plus.  Resouce modules built with 4.0.0.8217 work fine.  Here is the command I use to build the en_US locale resouce module:

       

      >mxmlc -locale=en_US -source-path=en_US -include-resource-bundles=views -output=en_US.swf

       

      I'm not including the framework resource bundles on purpose (less typing for this example).  Did I miss something?